problem with installation


I am new to SUSE and Linux and have just installed openSUSE 11.2 on my laptop. The installation (from DVD) seemed to be succesful (only during the automatic configuration there was an error message), but when the system started there was no graphical user interface but only “text mode”. It was possible to login but KDE didn’t start.
Then I tried “repair system” from the installation DVD. Mainly two errors where found: The first was with the “package database”: /var/lib/rpm/Filemd5s was not found. This was repaired but occured again in a second check.
The second was a “boot loader error”. It said the boot loader configuration was wrong, /boot/grub/ not valid. Unfortunately I have no clue of all this, so I didn’t know how to repair this.
Thanks for any help.



  1. did you run the media check from the installer?

  2. once you logged in at the terminal screen did you type startx to start the GUI? Any errors there might point to the problem.

  3. log in as root and show us the result of fdisk -l

@j_som: you could also post some information about your hardware, especially the video card. The results of

lspci -nnk

executed as root would be helpful.

Thank you for your advice. The command startx made the GUI start normally, so it isn’t a hardware Problem. But why didn’t it start automatically? Maybe I have choosen a strange configuration.
The result of fdisk -l was

Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x081783be

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1        7022    56396182    7  HPFS/NTFS
/dev/sda2   *        7022       14593    60822059    f  W95 Ext'd (LBA)
/dev/sda5            7022        7198     1421721   82  Linux swap / Solaris
/dev/sda6            7199        9809    20972826   83  Linux
/dev/sda7            9810       14593    38427448+  83  Linux

Another thing is that the Keybord & Language setting is wrong (it is English though I have chosen German). Where can I change this?

I just found the language options in the YaSt2 Control Center. “German” is selected, but the option “adapt keyboard layout to German” is disabled.

I also found the sysconfig editor. The setting of KEYTABLE is “”, so it should be a German keyboard layout. Why is it US/English anyway?

Alright, the problem is solved now! Language/Keyboard setting was correct after a second login. The GUI didn’t start because I had chosen “runlevel 2” during the installation although I didn’t really know what that means!