Problem with Huawei E220 after Update to 11.1


I’m using a Huawei E220 USB modem for my connection to the Internet. With suse 11.0 I was able to use it with full HSDPA speed applying the umtsmon program.
After updating to suse 11.1 the umtsmon still connects to the internet but I can only get very limited access and only skype is able to connect.
I tried to install the package huawei_umtsmodem but nothing changed. I also don’t find any usefull error messages in my log files. I also tried
modeprob -r usb_storage to disable the usb storage function of the modem but this also did not help.
Does anybody has the same problem or knows another solution so that I don’t use my windows to have access to the internet via the UMTS modem?

Thank You


Yes, I have exactly the same modem.
And I used it with umtsmon in openSUSE 11.0.

In the beginning I had the same problem,
as you describe in opensuse 11.1
(as I understand, the problem is non-working DNS).
If I remember correctly, to get umtsmon
to work correctly I switched off NetworkManager in Yast:
Yast -> Network Devices -> Network Settings ->
-> Global Options -> Network Setub Method:
Traditional Method with ifup.

Or you may prefer working with NetworkManager.
(In that case of course you should not turn it off.)

There is a thread, where a kind user told me, how to do it.
How make Huawei E160X work in 10.3? - openSUSE Forums
For me it is a lot easier:
if you configure things correctly, it even connects atomatically,
when you plug in your umts-modem.

So just go straight to this post and try it yourself.
How make Huawei E160X work in 10.3? - post1929270

Just pay attention to correct configuration,
which is provided by your network (mobile) operator.
(I did not at first, and thought correspondingly
that something was wrong with the software.)

The problem is that the dns servers are not registered correctly.

You can get it working by editing /etc/resolv.conf

Add the DNS servers to this file manually
The format is
nameserver <ip-adress>

You can hardcode opendns.coms dns servers.

Sorry, but that didn’t work for me.
After installing Suse 11.1 from the scratch using NetworkManager it worked 'til I got a security update for the NetworkManager. Since then, after trying to connect to the Huawei 220 modem, the NetworkManager closes. Reinstalling and downgrading both the NetworkManager and the Modemmanager didn’t help either. Since then, for almost to months, I’m not able to use my Huawei-modem anymore and I’m stuck to windows for this task - what a pity!

Hmm, it may sound strange, but it may help
(I don’t know why, but just try if you don’t loose anything):
update to the latest version of network manager
and uninstall ModemManager.
Then reboot or ‘rcnetwork restart’.

unfortunately, with Yast I’m able to uninstall only both Network manager and ModemManager. I tried this too, but with no effect. Must be a problem with the user and different permissions, I presume.>:)

I can confirm, this problem is presented with Network Manager 0.7.0.r4359-15.1.1, but not with previus version 0.7.0.r4323-1.11.
Downgrading to previus version makes the modem to work again.

Can someone please report a bug?

Unfortunately, I cannot test connection at the moment:
I don’t have UMTS Internet subscription now.

But there is already the bug report you write about,
See comment 14, it should actually help.

> Where was: <allow own=“org.freedesktop.NetworkManager.PPP”/> removed from?

/etc/dbus-1/system.d/NetworkManager.conf in the section with user=root

> Can I add it manually until a patch is available to get back online?


Anyway, if you want a bug to be reported,
you don’t have to ask anybody.
You can do it yourself. It’s pretty easy.
Submitting Bug Reports - openSUSE

seld wrote:
> Anyway, if you want a bug to be reported,
> you don’t have to ask anybody.
> You can do it yourself. It’s pretty easy.
> ‘Submitting Bug Reports - openSUSE’
> (

That bug was reported some time ago, was researched, and has been fixed! Cannot
anyone use search anymore?

maybe it was fixed, but not on my computer, although I installed every security update. no working UMTS on a notebook is a really bad and serious bug. That means no internet! At least for me.

Sorry, but did you read my previous
post fully or just the last paragraph?

It is reported, I gave a link to a bug report,
but it is not fixed - no update available (yet).

However, according to the comments to that bug,
it’s not hard to fix problem manually.
See comment

I fixed it!

The problem was the Modem-Manager. Reading

and installing the version from comment 7, it works!

Thank You all for the tipps and hints!rotfl!

I also tried alot of thinks (uninstalling modem manager etc.) but the porblem stays the same. I can connect to the web (with the umtsmon programm using my german O2 card), my system gets an IP adress and also a DNS is provided. The log in messages when I connect looks like this:

PPP generic driver version 2.4.2
pppd 2.4.5 started by mario, uid 1001
Using interface ppp0
Connect: ppp0 <--> /dev/ttyUSB0
PPP BSD Compression module registered
PPP Deflate Compression module registered
Could not determine remote IP address: defaulting to
local  IP address
remote IP address
primary   DNS address
secondary DNS address
Setting up rules from /etc/sysconfig/SuSEfirewall2 ...
using default zone 'ext' for interface ppp0
using default zone 'ext' for interface wmaster0
batch committing...
Firewall rules successfully set
Script /etc/ppp/ip-up finished (pid 5913), status = 0x0

When I test my connection I am able to use skype, ping to several IP adresses in the web, and it is also possible to get a SSH or SFTP connection to other computers I have access to. The only thing that won’t work is the connection to the normal www.

Has anybody an idea what the problem is, because its the most strange problem I have ever seen.

I don’t really know, how to use that logs,
and it is obvious, that you receive DNS IPs,
but the problem you describe sound just like DNS malfunction.
You may see these threads:
dns lookup not working - openSUSE Forums

In OpenSUSE 11.1 change DNS to openDNS - openSUSE Forums
(how to change DNS address manually)

Thank you for your replies to my question. After you have identified my problem as a DNS problem I looked around in the internet a little more and found out that the IP addresses of the DNS servers also have to appear in the file
My update to suse 11.1 did not write the IP addresses of the nameservers in this file. After I added them manually my connection with the UMTSmon program works without problems.
The only thing I’m not sure about is what happens when I connect my laptop with the eth0 or the wlan to the internet.
But I think this I will find out sooner or later.

Yes, and the easiest way to quickly check, what’s there is:
cat /etc/resolv.conf

My update to suse 11.1 did not write the IP addresses of the nameservers in this file.
Had the same problem: no DNS was written automatically (via WiFi), until I disabled IPv6.
(Yast -> Network Settings -> ‘Global Options’ tab -> Uncheck ‘Enable IPv6’ and then reboot)