problem with hibernation

When I click on “Hibernate” in the KDE launcher, the system seems to write the image to the swap disk. It then seems to shut the computer down briefly, but then, within a few seconds, returns to the same state as it was in before I tried to put it in hibernation. I have 9GB of swap space, and so that should not be the problem. If anyone has a solution, I would appreciate hearing it.

How much memory???

writing 9 GiB to disk takes a lot of time!
there might be a bug somewhere or you pressed a key or moved the mouse, touched the touch-pad, if you use kdeconnect your phone might have pinged kde etc…
that’s why I stopped using hibernate a few years ago, I use suspend to RAM ie sleep or power off,
suspend to ram is simultaneous as nothing is written to disk but uses a bit of power.
and I don’t have a lot of ram only 4 gigs for my use it’s enough

Does invoking the following work to complete hibernation?

echo disk > /sys/power/state

Some good suspend/hibernate debugging references:

Thank you for your suggestions. Unfortunately, none of them solved the problem.

It might be that a bug report is required then.