Problem with Headless VNC resolution/scaling, 11.4

What I’m trying to do:

I’m trying to display 1280x1024 headless VNC remotes full screen and windowed on my local 1280x1024 monitor. The remotes are Tom, Dick and Harry. They are different makes/models of similar class motherboards/video cards but I believe the solution to this problem will involve the same config tweak.

With the new autodetect of monitors under SuSE 11.4 I am unable to view a remote (11.4) headless VNC 1280x1024 desktop on a local SuSE 11.1 system which is in fact 1280x1024. This worked fine under 11.1 on the remotes. (I don’t think this will affect the solution but as an aside, I CAN see the remotes at 1280x1024 on the local screen if I start the remotes with a 1280x1024 monitor attached to the remote. If I disconnect the remote monitors after boot during the current session, I lose the image if I reconnect the remote monitor, but the 1280x1024 resolution remains on the local monitor via VNC until reboot without a monitor.)

The best I can do is 1024x768. I can see this on the local either 1.) in a full screen window, 2.) full screen with the 1024x768 image in the upper left of a 1280x1024 screen. I can also 3.) view a full screen, 1024x768 of the remote scaled full screen on my local even though the local is at 1280x1024.

What I mean by a 1.) ‘full screen window’ is a 1024x768 window on my local 1280x1024 desktop which window has no scroll bars and shows the whole remote desktop.

By ‘full screen’ I mean I see the remote desktop full screen, without title bar or scroll bars or borders on my local screen. This can be seen either 2.) as a 1024x768 image in the upper left corner with white space on the right and bottom or 3.) scaled up so that it fits the 1280x1024 local screen.

When I view the remotes, the ‘Configure display settings’ icon appears in the panel but the dialog box only shows ‘Resolution’ as a grayed out, unavailable option with no available, selectable parameters.

This all seems to happen no matter if I’m using XVNC, TightVNC or vino/vinagre. I’m pretty sure I need to find a way to set something on the remotes so that, headless, they default to 1280x1024, but I absolutely cannot find out how. I’m sure I’ve spent more than 20 hours on this off and on.

Also, I believe I read somewhere that scaling is NOT compiled into this version of the VNC that runs on 11.4 but I’m not sure about that or what effect it may have on this problem.

With no success I’ve looked at and/or tried to modify local and remote files:
esp 50-screen.conf adding Modeline “1280x1024_60.00” 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsync

Local xrandr output is:

Screen 0: minimum 1280 x 1024, current 1280 x 1024, maximum 1280 x 1024
default connected 1280x1024+0+0 0mm x 0mm
1280x1024 77.0*

Remote xrandr output is:

Screen 0: minimum 320 x 200, current 1024 x 768, maximum 8192 x 8192
VGA-0 disconnected (normal left inverted right x axis y axis)
DVI-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)

Screen 0: minimum 320 x 200, current 1024 x 768, maximum 3840 x 1920
DVI-0 disconnected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
VGA-0 disconnected (normal left inverted right x axis y axis)
1024x768 (0x43) 65.0MHz
h: width 1024 start 1048 end 1184 total 1344 skew 0 clock 48.4KHz
v: height 768 start 771 end 777 total 806 clock 60.0Hz

Screen 0: minimum 320 x 200, current 1024 x 768, maximum 8192 x 8192
VGA-0 disconnected (normal left inverted right x axis y axis)
DVI-0 disconnected (normal left inverted right x axis y axis)

As you can see from the xrandr outputs of the remotes, all remote systems correctly indicate that the available video outputs are disconnected. And, by the way, though it may be, I don’t think that fooling the systems into thinking that monitors are connected is the way to go. I feel fairly confident that the default resolutions need to be adjusted. But this wouldn’t be the first time I’ve been wrong about the mysteries of life.

As I write this I’m wondering if there’s a way to reset the resolution on ‘Screen 0’ on the remotes with xrandr.

Running the following script on ‘Dick’ first causes the 1024x768 remote image in the upper left corner of the local monitor, refered to in 2.) above, and upon reboot of the remote then yields the scaled full screen 1024x768 remote on the local, refered to in 3.) above. It is the effect of this script which makes me think that I just need to find the correct version of these commands either in a script or in a config file to solve my problem.

xrandr --newmode “1280x1024_60.00” 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsync
xrandr --addmode 1280x1024_60.00
xrandr -d :0 --fb 1280x1024

To recap, I’m trying to configure screen resolution on VNC viewers, all remote machines running SuSE 11.4. I see the OS is supposed to automatically configure this and it does so correctly at first on the remote machines WHEN MONITORS ARE CONNECTED.

However, when the remotes are headless, when I view the remotes from a local machine, I can get full screen (1280x1024) local resolution of 1024x768 on the remote machines. I cannot resize the remotes to 1280x1024.

Most all of my x11* and xorg* conf files are empty as one would expect due to the auto config of the screens under 11.4.

xrandr seems to be the way to go and I’ve tried to xrandr another screen setting but I have had no success there.

Any suggestions would be greatly appreciated.


I’m speechless. I honestly don’t know what to say. I had looked up - Hire Freelancers & Find Freelance Jobs Online and I was going to post this question as a paid job, but sometimes you just get lucky.

There is a site page:* Xorg RandR 1.2 - ThinkWiki*

On that page there is a section:

*To turn off the VGA monitor.

$ xrandr --output VGA --off

Note: This apparently reboots X !!! - cf. [1]

To turn the VGA monitor back on, with its viewport to the right of the laptop monitor:

$ xrandr --output VGA --auto --right-of LVDS

And just noodling around I tried the command:

xrandr --output VGA-0 --fb 1280x1024


Apparently this command ‘turns the monitor back on’ at the desired resolution even thought it is still disconnected.

I’m sure I’d already tried this command but I used it on Screen-0 rather than VGA-0. I believe the difference is the difference between the screen, the device, the output, the mode, whatever,…the differences between all of which are way above my pay grade.

Anyway, I seem to have stumbled upon the solution and I thought I’d post it. If I have further trouble, I’ll be back, but if I don’t show up in this thread again, it means this was a permanent solution.

Luck to all!!

Congratulations and thanks for sharing your solution!

It won’t survive a reboot, but can be easily be made persistent on the remote machines by adding the xrandr command to an executable script place in a startup file.