Problem with HDMI after update to 13.2 (video not audio)


Since updating to 13.2 i cannot get openSUSE to work when i connect HDMI to computer. I used to be able to get it without any problem when connecting computer to TV when 13.1.

If i connect the HDMI-cable before booting the computer everything seems to work just fine. Screen is mirrored to TV and works just fine. Computer boots to a login-screen that never shows up if HDMI is not connected. When logging in all I get is a black screen (on both devices) with three small question marks. And nothing more happens. Stays the same on computer even if I unplug the HDMI cable.

If i connect the HDMI-cable when the computer is already turned on i can see the proper screen for about 1ms then i get the same black screen with question marks.

Would be very grateful if I could get some help to solve this.

Hi there, welcome!

It will be much easier to help you if you tell us about your system, stuff like oS version, desktop environment, video card, video driver, etc.

Also take a look at the stickies in the multimedia section, you may find some help there. Look out for outdated stuff, thou.

A search of these fora may also yield helpful hints. IMO it’s easier to search through google, prefixing your search terms with “” (no quotes, of course).

Thank you!

I run openSUSE 13.2 with KDE.

~> kde-config -vQt: 3.3.8c
KDE: 3.5.10 "release 83" 

~> /sbin/lspci -nnk | grep VGA -A2VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
        Subsystem: Lenovo Device [17aa:20e4]
Kernel driver in use: i915

I’ve tried to find help on similar problems by searching forums and google earlier. It seems like most returns regard HDMI relate to problems with audio. I have not had any success finding anything that would solve my problem yet.

This may be related to KDE 3.5, the system configuration display module.

Did you try with KDE 4.x?