Problem with gdm

I have been using for some time gnome 2.32. About 1-2 months, everything was ok, till today when I booted mine pc and gdm doesn’t show user at all. It dont show even field where I can write down user name or password. Last day I was changing packages to Packman repo. I tried to reinstall gdm, but no luck, again same issue. Does somone has any ideas what to do?

For now I login with kde, I also were login with gdm but with passwordless autologin. With this type of login I have some probles with network manager-don’t see its indicator,so I’m using ifup.Mine shutdown button is also grayed, so I can’t use it. Maybe it is because keyring is not loading properly because of passwordless login, and when I enter gnome enviroment I have to enter mine keyring password.here is screenshot of mine desktop:

http://thumbnails14.imagebam.com/11723/2a4982117222543.jpg](http://www.imagebam.com/image/2a4982117222543)

I am using elegant-gnome theme, for about 20days, I think that shouldn’t be a problem.

PS: What gdm log files are of intrest here to post them?

I did zypper dup. but problem is still there.but now I have some error when loading gdm something like listener can’t listen socket

I think it is some problem with dbus. Maybe someone can help me troubleshouting it.

Thanks in advance

no one have clue?

On 01/31/2011 08:36 PM, kalcho wrote:
>
> no one have clue?

since you had a stable usable machine for 20 days and suddenly it was
broken, i have to assume you installed something, or changed something
that you should not have…and somehow the some of the system code on
your machine got scrambled or corrupted…

or, maybe there was a system update just before (or the day before)
this series of problems began…

it is nearly impossible for anyone to determine what happened or what
you did, unless you tell us what you did just before the problem
began…then, we might have a chance to tell you how to back out of
the problem by undoing what you should not have done…

lets begin this way: show us the output of copy and pasting the
following into a terminal


zypper lr -d

and copy/paste the output back to this thread using the instructions
here: http://goo.gl/i3wnr

also tell us what version of openSUSE you are using…

and, i’m totally unfamiliar with at keyring password being needed to
enter the Gnome environment…what is that all about?


DenverD
CAVEAT: http://is.gd/bpoMD
[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.0.11, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11

Hi
As well as what DenverD has asked for. Have you tried creating a new user on your system as a test, then login as that user, does the problem follow?

Yes I tried to create new user. With new user I cant even log into gnome screen.just black screen. I have openSUSE 11.3. Here is what I did: I installed first it from KDE Live CD, than I upgraded KDE to KDE 4.5. After that I added GNOME Enviroment. And was using like that some time, but have some issues in gnome with default programs. Than I decided to remove KDE, I removed it from Yast package manager. Than I couldn’t login into gnome session.Apparently I was erased some kde packages needed for gnome. Than I added some of it. I than done zypper verify. It said that all dependencies are satisfied. I was using like that 2days. And after than one morning in gdm disappeared field where I put password or user name. Just have logo on that box (I was using Elegant gnome theme that installed with it gdm theme also).Then I switched displaymanager to kdm, and I’m now have to login like that. Thank you guys on help, but I will wait for openSUSE 11.4 final release, and then I will install it. Anyway I was planning that before.

here is zypper lr -d

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

—±-----------------------------------±-----------------------------------±--------±--------±---------±-------±----------------------------------------------------------------------------------±-------
1 | 11.3 - VideoLan | 11.3 - VideoLan | Yes | Yes | 99 | rpm-md | Index of /pub/videolan/vlc/SuSE/11.3/ |
2 | Education | Education | Yes | Yes | 99 | rpm-md | Index of /repositories/Education/openSUSE_11.3 |
3 | Education:scilab | Education:scilab | Yes | Yes | 99 | rpm-md | Index of /repositories/Education:/scilab/openSUSE_11.3 |
4 | GNOME 2.32 (openSUSE_11.3) | GNOME 2.32 (openSUSE_11.3) | Yes | Yes | 98 | rpm-md | Index of /repositories/GNOME:/STABLE:/2.32/openSUSE_11.3 |
5 | Libdvdcss repository | Libdvdcss repository | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/11.3/ |
6 | Packman Repository | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/mirrors/packman/suse/11.3/ |
7 | devel_languages_python | devel_languages_python | Yes | No | 99 | rpm-md | Index of /repositories/devel:/languages:/python/openSUSE_11.3 |
8 | multimedia:libs | multimedia:libs | Yes | Yes | 99 | rpm-md | Index of /repositories/multimedia:/libs/openSUSE_11.3 |
9 | openSUSE-11.3-OssopenSUSE-11.3-Oss | openSUSE-11.3-OssopenSUSE-11.3-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/oss |
10 | repo-non-oss | openSUSE-11.3-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/non-oss |
11 | repo-oss | openSUSE-11.3-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/oss |
12 | repo-source | openSUSE-11.3-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.3/repo/oss |
13 | repo-update | openSUSE-11.3-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.3 |

On 02/04/2011 11:06 PM, kalcho wrote:
>
> Here is what I did: <snip>
>…I will wait for openSUSE 11.4 final release…
>
> here is zypper lr -d

since i couldn’t possibly fix your machine over the internet (if i had
it in front of me, i’m not sure i could fix it either) a word of
friendly advice, hope you take it the way i intend:

reading through what all you did and your huge variety of repos, it is
no wonder to me that your system is badly broken…

my wonder is how does it even still boot??

i can tell you with great confidence that openSUSE 11.4 will also
‘suddenly’ be broken if you treat it the same way…

before you install 11.4 i’d highly suggest you take these steps:

  • backup all data, music, movies, mails, etc etc etc to an off system
    media…

  • read, understand and follow the advice in every post in every thread
    in these fora (these are for 11.3, but new ones for 11.4 will be made):

http://forums.opensuse.org/english/get-technical-help-here/how-faq-forums/new-user-how-faq-read-only/440870-new-users-opensuse-11-3-pre-installation-please-read.html

http://forums.opensuse.org/english/get-technical-help-here/how-faq-forums/new-user-how-faq-read-only/424611-new-users-opensuse-pre-install-general-please-read.html

ymmv–others here may have other opinions, you are welcome to choose
the one you like the most…

good luck…


DenverD
CAVEAT: http://is.gd/bpoMD
[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.0.11, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11

Thanks on advice. I will take it into account. I will wait for final release of 11.4.