Problem with external modem

Now I’ve “upgraded” from suse 10 to 11.1 I cannot get my modem to work! I’ve set my 56k external modem (a bog standard generic hardware modem) up through the hardware control screen but there is no icon or any other clue as to how to access it! I’ve even resorted to setting it to dial on demand, but to no avail.

Previously I was using SUSE 10 and the modem showed up under the networking icon, now there are only choices there for adsl modem and wireless networking. Nothing for starting a plain 56k modem.

The modem is recognised and working as it responds to the command “wvdial” at the terminal prompt.

I am using the gnome desktop.

Following advise on Linux I’ve tried using kinternet to connect and also tried KPPP. When I try to connect with KPPP I get the error “unable to create modem lock file”, naturally there is no clue as to what or where that is or how to fix it.

When i click on the settings tab of KPPP I get the error " you dont have permission to run /usr/sbin/pppd, make sure kppp is owned by root and has the suid bit set". Looking at the properties of /usr/sbin/pppd it says that it is owned by root, with full read write access. Just on a chance I logged in as root and tried to run both kppp and kinternet with the same result as before! I’ve also set the file to give full read write access to any user with no effect.

I’ve also installed kinternet and it works, up to a point. Though you would think that part of setting up the modem in yast would actually set up some way of actually accessing it! Or am I asking too much?

The modem dials out and connects but that is all. I cannot get any internet service to connect. I am using the same settings as I did under suse 10 and I use on my (ubuntu) laptop.

Checking the connection status kinternet reports “No name server listed in /etc/resolv.conf”

Checking resolv.conf shows there are indeed no name servers listed and no line asking for them.

The connection set up is for dhcp in any case so I would expect that to be taken care of on connection. I am not asked for a host name in either Yast or kinternet set-up dialogues. I’ve tried connecting whilst logged in as root, just in case the software was attempting to write to resolv.conf but couldn’t due to it being write protected, but with the same result.

Using kinternet the modem is connecting, the connections have appeared on my 'phone bill! It is just I cannot get anything to communicate.

Is it because I am using applications intended for the kde desktop with gnome? I’ve got ubuntu on my laptop and use gnomeppp with the modem, why no gnomeppp with suse?

The modem is good as I gave it a try on my (ubuntu) laptop. All the settings are good as they are exactly the same as those on my laptop, apart from the device name for the modem and are exactly the same as those I used with suse 10.

kppp kinternet work under gnome and KDE for modems
gnoppp will marginally work under the KDE

The fact that you are getting connect record through your phone bill atests that the system is recognizing the modem and trying to make a valid connection. As for name servers in resolv.conf this could be where you are loosing out. With many ISP’s including dial-ups you must supply the name servers. If you don’t know them and have a working UBUNTU system you can check what is listed under name servers and then enter that under Yast-Network.

It’s been a long time since I really dealt with networking/modem situations. Some principals have remained the same others have changed over the years, but gives you a place to start investigations.

First things first. You should have a Modem setup module in YaST. If you do not, than that is a problem. Perhaps your install was not correct. If you do have a module for configuring the modem; On the connection Parameters page have you tried checking Ignore prompts? What I have is Manual connection and the boxes are checked for:

  1. Modify DNS when connected
  2. Automatically retrieve DNS
  3. Automatically reconnect

Plus the Ignore Prompts
In the IP page I have Dynamic IP Address and Default Route checked. And in the Modem Parameter Details page, the Enable device Control for non root user via kinternet checked. (your user should be in the Dialup group)

Finally turn off IPv6.

edit: BTW what does the log on Kinternet show for your connection attempt? right click the Kinternet icon and select View log.

I’ve basically done everything so far suggested. I set up the modem through the modem setup program in YAST. The settings used are EXACTLY the same as when set up under suse 10. The only difference now is that, just like in the current Ubuntu release, the modem no longer appears in the network devices menu and you are left to figure out you need to install a separate dialler / modem controller by yourself. In Ubuntu there is the Gnomeppp package but there doesn’t appear to be a Gnomeppp for suse 11.

I did look for name servers on my ubuntu system but there is nothing listed there either!

I will post the logfile from kppp tomorrow.

Thank you for your time.


Dialup modems are not much supported anymore. In openSuse 11.0 neither kinternet or smpppd was installed I had to add them myself (by the way, I assume you used the DVD to install 11.1 If not you may be missing things that the live CD took out for space sake.) Now this may be because during the original installation of my 11.0 I had a Satellite connection. I also found for some strange reason smpppd (SuSE Meta pppd) was not running in runlevels 3 and 5 and required going to YaST >System Services (Runlevel) and turning it on and having it always be loaded on start. I do not recall if I had to set in kinternet the interface to be modem0 and to load at startup but that is the way it is set.

I don’t know what happened but when I ran kinternet last night to generate a log it connected and everything worked perfectly! I’ve made no changes, it just worked. Why it didn’t is a mystery.

Anyway thank you for your help and support, it is appreciated.