Problem with external hard disks

Hi

I have 3 external hard disks but i am not able to mount them. When i connect the disk, nothing happens. If i try fdisk -l, the hard disk is not listed there.
I am able to use pendrives perfectly. It automatically mounts and i have no problem. There seems to be a problem with the external hard disks.
All these disks are in NTFS format. They work correctly in windows. Even after removing them safely in windows, they are not recognized in suse. I use opensuse 11.1.
Can someone please help??

Make sure ‘usbutils’ is installed
Plug in your HD’s
Might be worth re-booting

Now run a su terminal and post the result of

fdisk -l (I know you already said you did this)

Usbutils was already installed.
I plugged in my external hard disk and then rebooted. But the system doesnt boot. It stops at the opensuse screen. If i switch off the hard disk, then it continues to boot.

Anyway, after booting, i plugged in the hard disk again.
This is the result of sudo fdisk -l:

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x4d384d37

Device Boot Start End Blocks Id System
/dev/sda1 1 6675 53616906 7 HPFS/NTFS
/dev/sda2 * 6676 8602 15478627+ 5 Extended
/dev/sda3 8603 9598 8000338+ c W95 FAT32 (LBA)
/dev/sda4 9599 9729 1052226 d7 Unknown
/dev/sda5 8473 8602 1044193+ 82 Linux swap / Solaris
/dev/sda6 6676 8472 14434339+ 83 Linux

Partition table entries are not in disk order

The /dev/sda is my internal disk. My external disk does not appear here.
Any ideas??

Maybe you have usb set as a boot device in BIOS? You should disable that so you can keep the drives plugged in and switched on.
It might be why they are not picked up, I’m not sure. My external usb works whatever I do. Maybe you should tell us what they are exactly. Make etc…

I dont have usb set as a boot device. In fact, my laptop does not support booting through usb device.

The hard disks are

  1. IOMEGA 250 GB
  2. IOMEGA 40 GB
  3. LACIE 500 GB

None of them are working. I have a desktop with 64-bit suse 11.1 installed. All three hard disks are not recognized there too. I dont know what is wrong. It used to work properly in suse 11.0

I’m still using 11.0 on my box with the external usb. Later I will plug it in to my Laptop which is now 11.1

I’ll report back in due course.

I have not been able to solve this problem yet. I dont know why my external NTFS drives are not recognized. Can someone please help??

Ok. I tried to do something to find out what the problem is.
After i plugged in my hard disk, i executed dmesg command and this is what i got:

sd 8:0:0:0: [sdb] Sense Key : No Sense [current]
sd 8:0:0:0: [sdb] Add. Sense: No additional sense information

These two lines repeated many times.

Also, I went to Yast and checked the hardware information. And in the USB section, i can see a /dev/sdb. I guess this is the external hard disk. But it does not appear in fdisk -l.

Any ideas to fix this problem?

With the drives plugged in
What does a su terminal give for the following:

lsusb

Hi
Have you got the drives powered up or sufficient power. I power my
external 2.5" ide drives via a powered usb hub, 3.5" have their own
separate power source.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-4-default
up 14:20, 2 users, load average: 0.28, 0.31, 0.33
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.82

The output for lsusb is:

Bus 005 Device 006: ID 059b:0178 Iomega Corp. Hi-Speed USB-to-IDE Bridge Controller
Bus 005 Device 004: ID 0c45:62c0 Microdia Sonix USB 2.0 Camera
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 006: ID 03f0:171d Hewlett-Packard Wireless (Bluetooth + WLAN) Interface [Integrated Module]
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 005: ID 046d:c016 Logitech, Inc. M-UV69a/HP M-UV96 Optical Wheel Mouse
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

The first item i.e. Iomega Corp. is my external hard disk.
But it does not appear in fdisk -l.

I have my external hard disk with external power source. It works fine in windows. So power is not a problem

You said at the start you have 3 external HD’s. So you have tried them all I guess.

I am wondering, if you have windows installed too. Can you currently read the windows partitions from within SUSE, as they will be NTFS format. I’m thinking is this a NTFS issue. But if you can read your internal drive windows NTFS partitions ok - then it’s probably not that. Let us know.

So, on the back of that thought. Is there any possibility to format on of the drives to say FAT32 just to see how it works with that.

Are you pluggin the usb connector for the drive directly into the PC’s USB port or via a add on hub?

I have tried all the 3 external drives.
Ya, I am able to see my internal ntfs windows partition without any problems. The problem exists only with external drives.

I will see if i can format one of them to fat32 and then post the result here.

I am connecting the disks directly to the usb port in my laptop. I am not using any usb hubs.

Does your USB work at all under Linux for any storage devices ? Can you see a USB stick when it is plugged in?

This is looking like an incompatibility between your hardware and Linux.

Have you checked to see if there are any BIOS settings that you can use to tune? i.e. switch BIOS to “legacy mode” for Linux?

I have plugged in USB sticks and they work without any problems.

My external hard disks used to work properly in suse 11.0. They are not working in suse 11.1. I dont know why there is an incompatibility now.

How do i check if there are BIOS settings to tune??

If they worked in 11.0, they should work in 11.1. It reads to me that you should be writing a bug report on openSUSE-11.1

To check you BIOS, at the very start, when booting you need to press a specific key sequence, that will get you into your BIOS. If you pay attention to the boot screen, it typically tells you what the boot sequence is. Sometimes it takes 3 or 4 re-boots to gain access … ie two or three reboots to read what the code is, and one reboot to apply the code. Or if you are quick, you can do it in one reboot.

Once in the BIOS, check for any USB settings to adjust. Be very careful what you change there, as an incorrect setting could stop your computer from functioning.

Your USB devices were plugged in when you ran this? and you waited, say a minute or so, before typing “sudo fdisk -l” after plugging in the USB drives?

Have you tried booting with the USB drives already powered, to see if it makes any difference when you type “sudo fdisk -l” (as opposed to first powering and then plugging in the USB drives ) ?

Yes, I waited for about 3 minutes before typing “sudo fdisk -l”, but the external disk is still not listed.

With the hard disk powered on, the system fails to boot. The opensuse bootscreen just stays on display. As soon as I plug off my hard disk, the system continues booting successfully.

I also checked with a live CD of Ubuntu 8.10 64-bit, and the same problem exists there too. With the disk powered on, the system fails to boot. After booting (this happens when i switch off my external disk), if i plug in the external disk, it is not recognized.

Both Ubuntu 8.10 and openSUSE-11.1 have a 2.6.27 kernel. … Not sure if that is the common factor, but it is a possibility.

I recommend you write a bug report and see if you can get this fixed:
Submitting Bug Reports - openSUSE