Problem with display settings on Samsung AiO

Hi -

I am trying Opensuse 13.1 on a new Samsung Ativ One 5 Style. I have created a live USB pendrive according to the official instructions. Everythings seems to work fine, but the display is detected as a 7’’ monitor, not as 21’’. The graphic card is AMD Radeon HD 8400. When I go in system settings -> display there is no option to change the monitor size. Any hint is appreciated, thank you!

Try to install the fglrx driver:
http://lizards.opensuse.org/2013/11/20/proprietary-amdati-catalyst-fglrx-13-11-beta6-13-25-18-1-rpm-are-released-for-any-opensuse-version/

And/or post the file /var/log/Xorg.0.log, that should give clues why you get the wrong resolution (I think that’s what you mean).
Upload the file to SUSE Paste and post a link.

Thank you. I posted the log: SUSE Paste, I’ll try to install the fglrx driver soon. Please note, however, that the resolution seems fine, it’s just that the windows and the windows label are too big, and when I check the display settings it shows a 7’’ monitor (while it is actually 21’') with the correct 16:9 aspect ratio and 1920 x 1080 resolution.

OK, I misunderstood you then.

Well, your monitor reports this:

    39.910] (II) RADEON(0): Digital Display Input
    39.910] (II) RADEON(0): Max Image Size [cm]: horiz.: 52  vert.: 29


And:

    40.197] (II) RADEON(0): Setting screen physical size to 507 x 285

Which would be ~23" if my math doesn’t fail me.

And the DPI looks fine as well:

    39.915] (==) RADEON(0): DPI set to (96, 96)

But then, there are some errors and crash backtraces, so I guess you’re lucky that you even have graphics… :wink:
AFAICS they are glamor related, so you could try to disable that. (did you enable it? AFAIK it should be disabled by default)

Well, installing fglrx will fix that hopefully.

fglrx did not work, the boot process got stuck somewhere on the initial green screen and I could not even get to the console (shift + ctrl + F1). I booted in safe mode and removed it. I have no clue how to enable/disable glamor. Since the resolution is fine but the font of the labels is too big, I have a hunch that maybe tweaking the DPI setting would do the trick… I wish I knew how to do it ;)!

But according to your Xorg.0.log the DPI setting is ok. (96x96)

You can have a look in KDE’s “Configure Desktop”->“Application Appearance”->“Fonts”. There’s a “Force Fonts DPI setting” there.

May I ask how you installed the fglrx driver and which version exactly? (did you really use the 13.1 repo?)
It should work on your system.

Have you tried to press ‘ESC’ to see where it hangs?

Or try to add “nomodeset” to the boot options. But I think the rpm should do all necessary steps.

Ah, wait. You’re running on a Live system, right?
Well, I don’t know if installing the driver works then. I fear that the kernel module will be loaded too late/the radeon driver will be loaded at boot instead, because the writeable part of the LiveUSB will be mounted too late during boot. But maybe “nomodeset” could help there…

Yes, I am running a Live USB stick with a GNOME DE (so I can’t follow your advice to force DPI setting, and I’m having no luck with google searching how to do it in GNOME). I’ll try the “nomodeset” option, I’ll report back. Thank you for your help.

Well, I proposed “nomodeset” as a way to maybe get the fglrx driver to work.
But it may help without it as well, as it will prevent the use of the radeon driver, you’ll be using fbdev instead then. But this won’t set the correct resolution I’m afraid.

For GNOME’s Font DPI settings, see here:
gnome - How do I change the font DPI settings? - Ask Ubuntu

Thanks again. I found the tweak tool and adjusted the settings so that the desktop now looks normal. There is still the issue that the monitor is detected with the wrong size (I swear it is 21’‘, not 23’'), but it does not seem to harm – so far. I’ll test the other functionality I need, I’ll try fglrx again if I decide for a HD installation. I will leave the topic open in case somebody else wants to jump in.

Well, it depends on how you measure it, I guess…:wink: