Problem with D-Link DWL-630, openSUSE 11.1

Hello

When inserting my D-Link DWL-630 on my laptop with openSUSE 11.1 I get the following messages and the card is not working - no wlan-networks found.

Jul 22 20:12:06 r-laptop4 kernel: pccard: CardBus card inserted into slot 0
Jul 22 20:12:06 r-laptop4 kernel: PCI: 0000:04:00.0 reg 10 32bit mmio: [ffff8000, ffffffff]
Jul 22 20:12:06 r-laptop4 kernel: klogd 1.4.1, ---------- state change ----------          
Jul 22 20:12:06 r-laptop4 kernel: rt61pci 0000:04:00.0: enabling device (0000 -> 0002)     
Jul 22 20:12:06 r-laptop4 kernel: vendor=8086 device=2448                                  
Jul 22 20:12:06 r-laptop4 kernel: rt61pci 0000:04:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
Jul 22 20:12:06 r-laptop4 kernel: rt61pci 0000:04:00.0: setting latency timer to 64               
Jul 22 20:12:06 r-laptop4 kernel: phy4: Selected rate control algorithm 'pid'                     
Jul 22 20:12:06 r-laptop4 kernel: Registered led device: rt61pci-phy4::radio                      
Jul 22 20:12:06 r-laptop4 kernel: Registered led device: rt61pci-phy4::assoc                      
Jul 22 20:12:06 r-laptop4 ifup: interface 'wmaster1' is a wlan helper interface. Exiting.         
Jul 22 20:12:06 r-laptop4 ifup:     wlan1     device: RaLink RT2561/RT61 rev B 802.11g            
Jul 22 20:12:06 r-laptop4 ifup:     wlan1     is controlled by ifplugd                            
Jul 22 20:12:06 r-laptop4 ifup:     wlan1     device: RaLink RT2561/RT61 rev B 802.11g            
Jul 22 20:12:06 r-laptop4 ifup-wireless:     wlan1     warning: WPA configured but may be unsupported
Jul 22 20:12:06 r-laptop4 ifup-wireless:     wlan1     warning: by this device                       
Jul 22 20:12:06 r-laptop4 ifup-wireless:     wlan1     starting wpa_supplicant                       
Jul 22 20:12:06 r-laptop4 kernel: firmware: requesting rt2561.bin                                    
Jul 22 20:12:06 r-laptop4 kernel: phy4 -> rt61pci_bbp_read: Error - PHY_CSR3 register busy. Read failed.
Jul 22 20:12:06 r-laptop4 kernel: phy4 -> rt61pci_bbp_read: Error - PHY_CSR3 register busy. Read failed.
Jul 22 20:12:06 r-laptop4 kernel: phy4 -> rt61pci_bbp_read: Error - PHY_CSR3 register busy. Read failed.
Jul 22 20:12:06 r-laptop4 kernel: phy4 -> rt61pci_bbp_read: Error - PHY_CSR3 register busy. Read failed.
Jul 22 20:12:06 r-laptop4 kernel: phy4 -> rt61pci_bbp_read: Error - PHY_CSR3 register busy. Read failed.
Jul 22 20:12:06 r-laptop4 kernel: phy4 -> rt61pci_wait_bbp_ready: Error - BBP register access failed, aborting.
Jul 22 20:12:06 r-laptop4 kernel: phy4 -> rt61pci_set_device_state: Error - Device failed to enter state 4 (-5).

Andi

grupp wrote:
> Hello
>
> When inserting my D-Link DWL-630 on my laptop with openSUSE 11.1 I get
> the following messages and the card is not working - no wlan-networks
> found.
>
>
> Code:
> --------------------
> Jul 22 20:12:06 r-laptop4 kernel: pccard: CardBus card inserted into slot 0
> Jul 22 20:12:06 r-laptop4 kernel: PCI: 0000:04:00.0 reg 10 32bit mmio: [ffff8000, ffffffff]
> Jul 22 20:12:06 r-laptop4 kernel: klogd 1.4.1, ---------- state change ----------
> Jul 22 20:12:06 r-laptop4 kernel: rt61pci 0000:04:00.0: enabling device (0000 → 0002)
> Jul 22 20:12:06 r-laptop4 kernel: vendor=8086 device=2448
> Jul 22 20:12:06 r-laptop4 kernel: rt61pci 0000:04:00.0: PCI INT A → GSI 19 (level, low) → IRQ 19
> Jul 22 20:12:06 r-laptop4 kernel: rt61pci 0000:04:00.0: setting latency timer to 64
> Jul 22 20:12:06 r-laptop4 kernel: phy4: Selected rate control algorithm ‘pid’
> Jul 22 20:12:06 r-laptop4 kernel: Registered led device: rt61pci-phy4::radio
> Jul 22 20:12:06 r-laptop4 kernel: Registered led device: rt61pci-phy4::assoc
> Jul 22 20:12:06 r-laptop4 ifup: interface ‘wmaster1’ is a wlan helper interface. Exiting.
> Jul 22 20:12:06 r-laptop4 ifup: wlan1 device: RaLink RT2561/RT61 rev B 802.11g
> Jul 22 20:12:06 r-laptop4 ifup: wlan1 is controlled by ifplugd
> Jul 22 20:12:06 r-laptop4 ifup: wlan1 device: RaLink RT2561/RT61 rev B 802.11g
> Jul 22 20:12:06 r-laptop4 ifup-wireless: wlan1 warning: WPA configured but may be unsupported
> Jul 22 20:12:06 r-laptop4 ifup-wireless: wlan1 warning: by this device
> Jul 22 20:12:06 r-laptop4 ifup-wireless: wlan1 starting wpa_supplicant
> Jul 22 20:12:06 r-laptop4 kernel: firmware: requesting rt2561.bin

Make certain that the file named “rt2561.bin” is in /lib/firmware.
From what I see in the driver, there is no error message printed if
the firmware is not found.

> Jul 22 20:12:06 r-laptop4 kernel: phy4 -> rt61pci_bbp_read: Error - PHY_CSR3 register busy. Read failed.
> Jul 22 20:12:06 r-laptop4 kernel: phy4 -> rt61pci_bbp_read: Error - PHY_CSR3 register busy. Read failed.
> Jul 22 20:12:06 r-laptop4 kernel: phy4 -> rt61pci_bbp_read: Error - PHY_CSR3 register busy. Read failed.

These errors could result from missing firmware.