Problem with connecting to WiFi hotspot in opensuse Tumbleweed

I have recently upgrade my opensuse Leap 42.2 to Tumbleweed, and now my laptop connects to my phone’s hotspot properly, but I have no internet access in firefox and chromium and other browsers, while tor browser and telegram work fine without any problem.
Please help me.
sorry for my bad english.

Make sure that proxy settings in any problem web browsers are either disabled.
Typically, settings are set to auto-detect a web proxy and may still be configured with your normal LAN settings.


I happen to have a netbook Dell Inspiron Mini 1012 and wifi “almost” stopped working after installing Tumbleweed 32 bit. Sometimes it works, sometimes works very slowly, sometimes it stops working altogether. After googling a while I have managed to make the wifi to work at full speed and stable. I had to change the /etc/resolv.conf file in the line that starts with the word “search…” to “search” and to make the change permanent I removed the last comment line as advised by the same file. Finally in the /etc/hosts file I added one line starting with followed with my hostname and workgroup. For example if your host is “papi”, and your workgroup is “grupo”, then in /etc/hosts add a line with “ papi.grupo papi”. Al least it worked for my Dell notebook.