Problem with CD/DVD automount (autofs problem?)

Hello there :smiley:

Lately, I have experienced some really wierd(read: OMGWTF how is this even possible!?) problems with my DVD drive and my DVD burner.
They occur at unpridictable times, so if you are lucky, you’ll be able to work with optical media, or, if you’re not and the computer doesn’t feel like it, well, then not…
By the way, I’m running a SUSE 11.0 (x86_64) and KDE 3.5 :open_mouth:

So, this is everything I could observe so far:
It first happened, when I wanted to burn some photos on a CD. I started K3B and it crashed. HARD. And - what really confuses me - it didn’t even react to kill -9. At this time I thought it was a K3B bug and re-booted the computer. Anyway, when you insert an optical media in a optical drive, the drive becomes usually mounted automatically and a popup appears which asks you what to do, right? But sometimes it just doesn’t happen. Also, if the drive is mounted it can happen that it just becomes unmounted(read: disappears as if it was never mounted in the first place…). Which is especially bad, when someone watches videos stored on DVD: VLC crashes and becomes “unkillable”(like K3B). And, of course, the media can’t be mounted anymore(unless I re-boot the computer). Out of curiousity, I tried umount and it said that fstab says that the drive is not mounted. Then I tried mount. It became an unkillable zombie, like VLC and K3B. And, to make matters worse, trying to kill these processes with pkill and killall processes resulted in those processes becoming freaking zombies, too. :open_mouth:

I also took a look into /etc/fstab, /etc/mtab and /media/.hal-mtab and when this problem occurs, my optical drives aren’t listed there.

What could cause this problem? And why? Any clues? I don’t know what to do anymore. I also digged through half the Internet and found nothing… Please, help.:’(