Problem with brightness on Sony laptop


I recently installed suse 13.1 from scratch on my Vaio VGN FE11 laptop, and since then I am no longer able to change the screen brightness. If I use the Fn buttons to do that, I can see the brightness bar appearing and moving, but the brightness does not change.

I remember I had this problem before, and I managed to solve it using the old sonypi driver. I understand that now this driver is part of the standard linux kernel (see
As per the link above, I added into /etc/modprobe.d/99-local.conf the following lines:

alias char-major-10-250 sonypi
options sonypi minor=250

and executed the following command:

# mknod /dev/sonypi c 10 250

Now if I try to execute spicctrl as normal user I got the following error message:

~> spicctrl --setbrightness=100/dev/sonypi: Permission denied

while the same command as root gives:

# spicctrl --setbrightness=100
/dev/sonypi: No such device

Can anybody help?

Hmm first place to look is to see if such a file exist in /dev

Note the errors are to be expected because in the first place /dev is owned by root thus non-root users can’t access anything in it.
in the second place there appears there is no file /dev/sonypi You can conferm by looking into the /dev directory.

Also note that in Unix/Linux all things are files. /dev is a virtual file system created at boot and does not actually live on the disk. In the case of /dev it represents the interfaces to devices discovered on the system.

You’re actually right, there’s no such file in /dev.
I suppose there’s a missing step in the procedure described in documentation about sonypi, but I didn’t get any error message when I tried it.

Any other suggestion? How can I verify that the sonypi module is really loaded in the kernel?

Any suggestion on the matter? Any alternative way to tune the brightness level?

On Thu 16 Oct 2014 07:36:01 PM CDT, MadSplinter wrote:

Any suggestion on the matter? Any alternative way to tune the brightness

We seem to have had a few posts on Fn keys and brightness not working
lately for various laptops.

One option is to try adding the following to the bootloader kernel
options via YaST;

acpi_osi=\"!Windows 2012\"

If the above does work, then raising a bug is in order along with
adding the output from dmidecode to the bug report.

Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-21-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

Unfortunately the option

acpi_osi=\"!Windows 2012\"

Did not make any difference whatsoever. Malcom, you mentioned raising a bug. With whom? Suse or the Linux Kernel? I’m not used to the process, could you please explain further?


Here is the link for bug reports;

If you create one, please post the bug link back here so we can follow :wink:

This ArchLinuxWiki very nicely presents solutions for the laptop screen brightness. Hope so it also remains valid in opensuse.

I also posted the same problem for my Acer Laptop

I put this problem on a standby. Once, I will finish the wiki I will tryout and post the results.

Well this is weird. None, of the methods mentioned on the wiki worked. However I tried a method by which I fixed the same problem on Ubuntu. Check

In a terminal type -

ls /sys/class/backlight/



shows up.
First go to root. Then


sudo touch /usr/share/X11/xorg.conf.d/20-intel.conf
sudo kate /usr/share/X11/xorg.conf.d/20-intel.conf

Enter following command in the .conf file

Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"EndSection

Save and exit. Log out and log in again. Brightness control should work now.

rotfl! No idea how it works.

The method which I used has a drawback. If I leave the laptop idle, while watching a movie brightness automatically decreases. Also the minimum brightness level is 0 so will get a black screen - no worries, just increase the brightness.

Also, you try out following method as described by fromfree on

But, I haven’t tested tested the second method.

Now, we have two methods. Can anyone explain which method is better.


many thanks for your suggestions! In my case, the output of ls /sys/class/backlight/ is

acpi_video0  acpi_video1

Actually, my problem is very similar to the one you signalled in this link:
I’m experiencing exactly the same behaviour, but with a couple of key differences I think:

1 - I’m not using the Nouveau driver, I’m using the Nvidia one
2 - My laptop is a Sony, and it uses spicctrl to change brightness. I’m 100% sure that if I can solve the sonypi kernel module issue, I will have my brightness control back, as I had the problem before on the very same laptop and I managed to solve it the same way. Unfortunately, I do not remember how to do that!

Small update: I noticed that if I boot the emergency system (no Nvidia drivers and minimal resolution) the brightness command actually works. Does this give anyone a hint of where the problem could be?

Don’t know but it sounds like an NVIDA driver probalem

Still no solution

Filed a bug.

Link here:

Many thanks, added myself :wink: They may want the output from dmidecode as well…

I finally found a solution!

I added the following line to the section “Device” of xorg.conf:

Option         "RegistryDwords"          "EnableBrightnessControl=1;PowerMizerEnable=0x1;PerfLevelSrc=0x3333;PowerMizerLevel=0x3;PowerMizerDefault=0x3;PowerMizerDefaultAC=0x3" 

after that, the brightness control works just fine.
Thanks to all the people that helped!