Problem with black screen.

I have a problem with installation of openSUSE and using it.
When installer is loading linux kernel and it goes to 100%, the next thing that I can see is black screen and can just use shut-down button. This situation appears about 90% tries. After 7 reboots I installed Suse successful but the problem appears also now. Just after select Suse in GRUB, the screen print some text about half a second and it goes black. Sometime I can start system normal but it is just luck.
Please help me.

I use openSUSE 11.3
Intel Core 2 Duo 2GHz, 4gb ram, Geforce 8600M GT graphic card
PS Sorry for my average English.

Ctrl-Alt-F2 and login as root, then init 3 and Xorg -configure.
You also have an nvidia card, you either need the proprietary nvidia driver or use the opensource one. nouveau would be the nvidia open source driver. It should look something like this xorg-x11-driver-video-nouveau

When I run Xorg -configure it prints in the end:

No DRICreatePCIBusID symbol
Number of created screens does not match number of detected devices.
  Configuration failed.

Dunno what is that…

If you choose the failsafe option at the boot screen, do you still have display problems?

Let’s go through this step by step.
First let’s verify whether or not you have the drm package. Which I believe is the Mesa package. Mesa-nouveau3d
This thread may help you. nouveau-drm compile failure | Gentoo | User
Edit xorg.conf and remove the Disable “dri” line, and use nouveau again.

I’m getting the exact same thing here, I have an Nvidia 9800 GTS and the nouveau packages are installed. I get the same error trying to run xorg -configure. I managed to sort it out by adding “nomodeset” to my boot options but I’m guessing that this is a bug. I’ll poke about a bit and report it tomorrow if I can’t find a decent solution.


Okay found a fix to this one which removes the need to add boot options. First boot the machine with the aforementioned nomodeset boot option. Once you are logged in as normal run yast and click on software repositories, then add and then select community repositories and click next. Now enable the NVIDIA repository and click OK, when prompted click import. One that is done click Software Management and deselect the package xorg-x11-driver-video-nouveau and click accept. This should trigger the install of the official Nvidia drivers and you should find that after a reboot everything is back to normal. I’m guessing that this is some kind of nouveau bug, I’ll have a go at reporting this tomorrow when I’m not so tired.