problem with autorepeat

Dear All,

I installed some months ago openSuSE 11 from scratch (HD had broken) on my laptop. Since then, I have a nasty problem with autorepeat.

Problem: when typing, it occasionally happens that one character of what I write is repeated many times. E.g. on the console:

> mathematica myprrrrrrrrrogram.nb &

or on a message selected in kmail, I may press [del] once and shortly, and see instead 3 deleted messages.

  • It’s not a keyboard problem – it happens also with an external keyboard.

  • As I said, it happens on a non-regular basis, and the number of “repetitions” is not always the same. So I don’t think it can be fixed by changing the autorepeat delay in xset (now 250), which I tried anyway.

  • I noticed that it happens at work and not at home, the difference being in the web connection.

  • From dmesg I get the following errors:
    ipw2100: eth1: firmware fatal error
    ipw2100: Fatal interrupt. Scheduling firmware restart.

May this be related with my problem?

  • My current kernel is

I would greatly appreciate any help on this really annoying problem.


Same problem here on OpenSUSE 11.1 64 bit and all the kernels 2.6.27.* so far on an HP 6730s laptop and KDE 4.1.3.

Did you find anything else on this problem?

Did you test with another distro’s livecd? With other keyboards?

If it happens with other kernels, this has to be a hardware problem, not necessarily in the keyboard, it can happen in the mobo’s ps/2 controller (and even if your kbd is usb, there’s a usb->ps/2 conversion circuitry somewhere in the mobo).

In my case it works fine in Windows Vista 64 (I have dual boot), so it is not a hardware problem.

Dgog, in which computer did you have this problem?

> In my case it works fine in Windows Vista 64 (I have dual boot), so it
> is not a hardware problem.

ok, if Vista is perfect then the hardware is perfect and it has to be
a Linux (driver) problem, huh?

try YaST > Hardware > Keyboard Layout

look in the “Type” block to see what keyboard the install script
identified as yours…and spin the control to try another…

you might pick one that doesn’t work…but, that is the way Russian
Roulette works…

alternatively, find a person with a HP 6730s without this problem
and learn what their keyboard setting is…

another way might be to boot from a Live CD/DVD (i’d recommend
Knoppix) and see what his hardware detection routine thinks is best
for that HP…

THEN, if you continue to have this problem it will then have been
proven to be neither hardware (because it is ‘perfect’ in Vista) nor
software (because EVERY driver gives the same error)…and, you can
begin your search for gremlins!

the first grimlin i’d look at is the accessibility features, to make
sure none of them have been activated incorrectly:
Personal Settings > Configure Desktop > Regional & Accessibility >
Accessibility >

> Bell - check “Use system bell” ON, all others off
> Modifier Keys - check “Use system bell…” all others OFF
> Keyboard Filters - all OFF
> Activation Gestures - check “Use the system bell…” all others OFF

and, if those don’t work with your keyboard/driver see what is set up
in perfect Vista, and mimic it…

CAVEAT: The author of this posting does not warrant the accuracy,
completeness, legality, or usefulness of its content and is not
responsible for consequences resulting from its use.