Problem with associations in GNOME

How to restore GNOME system-wide associations?

I have somehow lost associations of some (I think all -> all which I have tested) filename extensions in GNOME (not tried KDE, I do not use it).

This means e.g. I lost the associations of .desktop files (program shortcuts on desktop), which are now opening in gedit (and in the list of programs to open the extension I see programs like KWrite, Writer etc. = programs for opening plaintext files), instead of launching the program to which the shortcut points (and which worked day ago - even such links as GnomeOnlineHelp.desktop, SuSE.desktop). Desktop files have not the icons as they should have, but have the icons like .txt files. (but only for desktop icons, the shortcuts under Computer/More Applications work)
Second it is connected with another extensions - .odt, .pdf I’ve detected so far, e.g. it changed the association of OpenOffice document .odt to gedit (and while it is binary file, the gedit throws some error that the file cannot be open); when I set the .odt in Gnome back to be opened by Writer, it changes the association of .desktop too, so it opens .desktop in OpenOffice after the change.
Now I tried to download and open some .pdf file in Evince, and Evince tried to open the .pdf file as plaintext!!! (and it cannot open it for obvious reason, that PDF file is binary format and not plaintext).

The problem is system-wide, it means it is the same for all users in all profiles.

I suspect the VMware Player little bit, while the only thing I’ve done last day was installing the VMplayer from RPM (I had vmplayer installed already, I upgraded it from 2.0.4 to 2.0.5 using “rpm -Uvh” and then the problem began). I’ve completely removed the vmplayer but no change.

I’ve also tried to call “update-mime-database /usr/share/mime” but nothing changed (only some changed associations were lost and .desktop opens in gedit again).

Is there any way to restore the correct associations, recover mimetypes or whatever (I don’t know what exactly happened), without complete reinstall of the system?

OS version: openSUSE 11.0 64-bit
(Linux #1 SMP 2008-07-13 20:48:28 +0200 x86_64 x86_64 x86_64 GNU/Linux)

Now I verified, that the problem exists for all file types - under Properties of every file in the system, I see “Mimetype: text/plain”, no matter what the file type actually is (.txt, .pdf, .tar.gz, .mp3, .mpg, .avi, … - really all filetypes including all binary formats).

It seems to me that the Gnome lost the ability to detect actual mime type of the file and uses all files as they were text/plain - the mime type detection is probably completely broken. It is for the entire system, for all users.

Any idea how to restore the mimetype detection ability in Gnome?

I did not yet reinstall the system (not enough time yet), but I’ve found something interesting - I’ve found that in the Gnome there is subsystem called GVFS, which provides the mimetype information to Gnome applications (Nautilus etc.). And this system seems to be broken a little.

When I run in command line the command “gvfs-info somefile.pdf”, I see following:

  standard::content-type: text/plain
  standard::fast-content-type: application/octet-stream

But when I run this command under root (su), I see:

  standard::content-type: application/pdf
  standard::fast-content-type: application/pdf

The same is for another types, e.g. .desktop files - when I run it under current user, I see the same as for pdf and all other file types (text/plain); but when I run it as root I see:

  standard::content-type: application/x-desktop
  standard::fast-content-type: application/x-desktop

which seems to be correct.

So it seems that the mimetype detection is not completely broken, but somewhere in the user profile. But creating new profile or another user does not help, and it is the same under all current users.

Now I tried one more thing - I logged into Gnome as superuser (root), and anything goes fine under that account (I see correct icons for all filetypes, and they open in correct applications) - so the root account is the only accout where the mimetype detection works. Probably it can be connected with setting of rights to some file, where the information for proper detection of mimetypes is stored (but I do not know, where it is)?
But I surely did not set rights to any file under /etc or /usr … (maybe some other program could do it? e.g. the vmware player installation, which AFAIK adds some mime types for itself, e.g. for .vmx files etc.)

Does somebody know, where I should set the rights (and what rights) to get the mimetype detection work without reinstall? (which might anyway be useless, while I would then newly install the vmware player … :expressionless: )

Hi sorry to bump into your monologue after almost a year…:wink:

but I have the exact same problem running OpenSuSe 11.0 with gnome…did you finally manage to solve this problem?

Thanx for any feedback


Ok…now I am getting to have a monologue myself…

just for the sake of completeness, my problem was solved by copying /usr/share/mime to ~/.local/share/ as described here: Lost all gnome mime type recognition after update - openSUSE Forums

I have this problem too. How does one resolve it!?

My old, listed below, does not work anymore to fix this problem.

As root:
rm /usr/share/applications/mimeinfo.cache
update-mime-database /usr/share/mime

As user:
rm ~/.local/share/applications/mimeinfo.cache