Problem with additional language layouts

I often write English and Spanish text in the same document or email. And occasionally German and other languages. So I have installed default US and Spanish layouts under Keyboard Hardware and Layout. This worked fine under 42.2 but now with 42.3 when I switch to Spanish the OS presents a layout that is not Spanish and is not the layout displayed by opening Preview.

All apps are affected by this issue. At the same time I have discovered that the US layout has acquired the ability to add some, but not all, special characters. Could these two things be related?

I think I wrote about this in the past but I can’t find any reference in the forums. Memory is not good since I passed 80. I think there is a work-around when using the Spanish layout but it is clunky (ie, laborious). Can’t we go back to the functionality of 42.2?

Which GUI?

  • KDE; GNOME; MATE; Xfce; Enlightenment; Cinnamon; LXQt . . . ?

Or, are you using a TTY?

I am strictly a KDE user. Never tried anything else.

I can confirm your problem: KDE Plasma 5 with German and English-US (US international with accent keys) keyboard layouts.
The US preview shows “QWERTY” – when it’s selected “QWERTZ” is typed.
I have to admit that, I haven’t logged out and logged back in again.
Possibly, a KDE Bug Report is needed.

Do you maybe have ibus or fcitx installed?
Those may interfere, and override Plasma’s keyboard settings.

In my case, nothing related to “fcitx” is installed.

But, “libibus-1_0-5” is installed and, “rpm --query --whatrequires libibus-1_0-5” indicates no dependencies but, “zypper remove libibus-1_0-5” wants to also remove the following applications:Activities
[INDENT=2]“Application Launcher”
“Application Menu”
“Application Menu Bar”
“Declarative Toolbox”
“Default Panel”
[INDENT=2]“Desktop Containment”
“Empty Panel”
“Input Method Panel”
“KDE Plasma Desktop”
[INDENT=2]“Panel Toolbox”
“Task Manager”
[INDENT=2]“Window list”
and the following packages:patterns-openSUSE-kde

and the following patterns:kde

I’ll leave the IBus libraries installed for the moment.

By the way, logging out and then back in again didn’t help.

The only “small annoyance” which disappeared with 2 keyboard layouts defined was the “Num-Lock disables it’s self once only after logging in when <Ctrl> or <Alt> or <Meta> is pressed” issue (there is a KDE Bug Report for this issue). Removing the 2nd keyboard layout reinstated “my little friend”.

libibus is irrelevant and required.

ibus is the daemon that provides the functionality (and overrides Plasma’s keyboard layout settings).

and, “rpm --query --whatrequires libibus-1_0-5” indicates no dependencies

Yes, because the packages actually require “”…

I’ll leave the IBus libraries installed for the moment.

Yes, that’s what you should do.

Yes, I experience that too with only one keyboard layout.
But it’s not NumLock itself that gets disabled here, only the keyboard LED is switched off. The NumLock functionality is still on.
(so just a “cosmetical” issue really)

IMHO rather not a bug in KDE though, more in numlockx that is used to turn on NumLock in the first place during login, or Xorg or… :-/

PS: I meanwhile tried to add Spanish and English-US (default, and with accent keys) as additional keyboard layouts here, and switching to both works as expected (immediately, without logging out/in).

I’m using Plasma 5.12.0 on Leap 42.3 though, not 5.8…

What exact settings are you using?

KDE-Plasma-Version: 5.8.7
KDE-Frameworks-Version: 5.32.0
Qt-Version: 5.6.2

That was obvious, of course.

But what exact keyboard layout settings?

  • de - German - no accent keys
  • us - English (USA) - either default or, with accent keys

That’s what I tried, and it worked fine.

Unless there was a difference in the details…

In other words, this issue disappears with KDE Plasma 5.12 LTS – openSUSE Leap 15 – need to continually check throughout the Beta test phase.

I can only say that what I tried works fine here with Plasma 5.12.

And I haven’t tried on 5.8 yet.

Have checked Leap 15 Beta running in an Oracle VirtualBox VM – Keyboard 105 key International --plasmashell 5.11.95
Qt: 5.9.3
KDE Frameworks: 5.42.0
Kernel: 4.12.14

Everything is OK – works as expected.
[HR][/HR]And now I’m suspicious – the keyboard I’m using here is a Cherry “Cymotion Master Linux” – I’ll check on a Leap 42.3 Laptop with a 105 key International keyboard.

And, with Leap 42.3 and an International 105 key laptop keyboard:plasmashell 5.8.7
Qt: 5.6.2
KDE Frameworks: 5.32.0
Kernel: 4.4.104

it works!!!
[HR][/HR]I’ll go back to the desktop PC with a USB keyboard, change it to 105 key International, and check again.

Leap 42.3:

  1. Laptop – keyboard not mentioned in the list of USB devices – 105 key International keyboard model – different keyboard layouts work as expected.
  2. Desktop – keyboard attached via USB – regardless of the keyboard model (105 key or Cherry CyMotion), different keyboard layouts do not work.

Leap 15 Beta:

  1. Desktop in an Oracle VirtualBox VM – PS/2 keyboard – 105 key International keyboard model – different keyboard layouts work as expected.