Problem with ACPI

OpenSuse Version: 12.1 64 bit (Gnome 3 desktop)
Laptop: Lenovo Thinkpad L420, Intel Core i5-2520M

I installed OpenSuse 12.1 with ACPI=off. Now when i shutdown the laptop, it does not power off. I had to disable ACPI during installation because otherwise i got a black screen and was not able to install.
The curious thing is that OpenSuse 11.4 installs fine even with enabled ACPI.

Is there a solution for that problem?

On 11/23/2011 03:26 AM, NMO13 wrote:
> Is there a solution for that problem?

instead of acpi=off, in its place you could try


please report success, failure or change…



I tried it but with no luck -> screen is black

I have found that by changing the ACPI at boot, it can cause other problems. I went in to the ‘personal settings-configure desktop’ and under ‘shutdown’ changed the ‘Halt’ configuration from Halt to ‘poweroff’. In my case it worked OK.


I believe the above has the Intel HD 3000 graphics (onboard) without a secondary/alternate (NVidia or ATI) graphics facility. I have the prior generation (i5-430M with Intel GMA HD graphics.

Installation with ACPI=off inhibits inclusion of support necessary for power management shutdown functionality.

Was the 12.1 installation from the live CD, DVD or network or USB ?

I installed 12.1 (many flavors - MS’s and RC’s also) from the DVD. I can confirm that the DVD installer changed significantly from the 11.4 installer. The 11.4 installer (surprisingly) worked correctly with the Intel graphics, until the final boot. The 12.1 DVD installer presents the “black screen” early in the install, necessitating actions such as:

  1. Use ACPI=off
  2. Use “nomodeset”
  3. Close and re-open the lid

Installation with ACPI=off perpetuates that functionality, and, as demonstrated, is resistant to attempts to add ACPI= options. As such, I would never use this option.

Installation with “nomodeset” similarly propagates the “nomodeset” option in GRUB, which you can modify later. The “nomodeset” option is useful for less-than-fully cooperative graphics, or graphics requiring subsequent additional installations, such as NVidia.

The third option, lid closure/re-open, works, allowing the installation to complete normally. Once complete, you can rely on this action (at every boot, and all power-management actions such as suspension or hibernation). Alternatively, you may then add:


to your GRUB entry, and your graphics should behave as expected. Do take note that you may need an additional ACPI option, depending on your BIOS. Refer to Intel Graphics, the “black screen” problem update for these options.

The inclusion of the ACPI_backlight=vendor option requires that the kernel recognizes the BIOS interface(s) particular to your platform (Lenovo). I can confidently state that this option works on my Gateway PC’s (actually, Gateway contains ACER smarts) and ACER PC’s. I have been told that it works on Dell PC’s, although there are some Dell-specific bugzilla entries for the Intel HD graphics.

I should point out that re-installation of 12.1 will be necessary to achieve the above. The good part of this is you can re-install without formatting your /home partition, although I strongly suggest a backup be taken prior to the re-installation.