Problem with accessing install media - openSUSE leap 42.1

I installed openSUSE Leap 42.1 yesterday, my computer wasn’t connected to the insternet during installing openSUSE, I choose KDE as my DE. After installing openSUSE, I booted into it and I didn’t see any network applet in the panel and I also couldn’t access to the internet (I had wired networking), so then I accessed YaST => Network Settings => Global Options and choose NetworkManager Service as my Network Setup Method then I reboot openSUSE. After reboot, I have seen network manager applet and I also have accessed to the internet, I have could surfed Web with FireFox. But now I can’t install some programs/packages because openSUSE can’t access install media (can’t access to repositories, see the software repositories list screen shot here: https://drive.google.com/file/d/0B0YPxoTYHWAZSjVmT3lwMkd0am8/view?usp=sharing).
How to fix this? Help me, I’m a Ubuntu/Mint/Window user so I don’t have much experience with openSUSE
:frowning:

Either insert the installation medium, or disable or remove it in YaST->Software Repositories (i.e. select the one selected on your screenshot and toggle the “Enabled” checkbox or click on “Delete”).

You don’t really need it in your repo list (if you have an Internet connection), as everything is included in the online repos anyway.

Actually it should normally get disabled after successful installation, but the heuristic to find out which one to disable apparently can go wrong under certain circumstances.

I have deleted all repositories but now I can’t find or install any packages

I told you to remove the one repo that points to your installation medium, not all of them.

Of course, if there are no repositories configured, there are no packages available to be installed.

Add them back, e.g. by clicking on Add and entering the datails as shown in your screenshot. You should find them in the “Community Repositories” list too I think, it’s probably easier to just activate them there.

I deleted all repositories because openSUSE can’t access all of them. May this problem relate to my network configuration?

Probably, although if you can browse websites in Firefox, it seems to work in general.

Can you please post the exact error messages you get?
In particular run “sudo zypper ref” and post the output.

And more information about your Internet connection might be useful, in particular are you using a proxy?
As the package management runs as root it will not see the proxy settings you make in KDE or Firefox e.g.

Since it seems like you installed using a DVD, so IMO the easiest way to resolve all your problems including your removed repos and connect to repos problem is to simply run your DVD again and choose the “Repair” option.

After you install, you can go back to the YAST repo applet you used to create your screenshot and uncheck the “enabled” checkbox for the “repo” you highlighted in your screenshot to disable your DVD as a repo “source.” That way, when you remove your DVD your system won’t bother you about the missing repo.

If you prefer not to rely on the auto update app (likely Apper), you can invoke an online update by running the following command in a root console

zypper update

Your system should be fine after the described steps.

TSU

This “Repair” option has been removed years ago…

Because of some other reasons, I have reinstalled openSUSE and then not need to do anything more, I can browse with FireFox but I still don’t see any network applet and openSUSE still can’t access to exact these urls ( I saw them when run YaST -> Software Manager ):

Download (curl) error for ‘http://download.opensuse.org/distribution/leap/42.1/repo/oss/content
Download (curl) error for ‘http://download.opensuse.org/update/leap/42.1/oss/repodata/repomd.xml’:

See my present repositories: https://drive.google.com/file/d/0B0YPxoTYHWAZS2FpLXI2bDFFLU0/view?usp=sharing

tbk@dhcppc0:~> sudo zypper ref
Download (curl) error for ‘http://download.opensuse.org/distribution/leap/42.1/repo/oss/content’:
Error code: Connection failed
Error message: Failed to connect to download.opensuse.org port 80: unable to connect the network

Abort, retry, ignore? [a/r/i/? shows all options] (a): i
Do you want to disable the repository openSUSE-Leap-42.1-Oss permanently? [yes/no] (no): n
Skipping repository ‘openSUSE-Leap-42.1-Oss’ because of the above error.
Download (curl) error for ‘http://download.opensuse.org/update/leap/42.1/oss/repodata/repomd.xml’:
Error code: Connection failed
Error message: Failed to connect to download.opensuse.org port 80: unable to connect the network

Abort, retry, ignore? [a/r/i/? shows all options] (a): i
Do you want to disable the repository openSUSE-Leap-42.1-Update permanently? [yes/no] (no): n
Skipping repository ‘openSUSE-Leap-42.1-Update’ because of the above error.
Download (curl) error for ‘http://download.opensuse.org/update/leap/42.1/non-oss/repodata/repomd.xml’:
Error code: Connection failed
Error message: Failed to connect to download.opensuse.org port 80: unable to connect the network

Abort, retry, ignore? [a/r/i/? shows all options] (a): i
Do you want to disable the repository openSUSE-Leap-42.1-Update-Non-Oss permanently? [yes/no] (no): n
Skipping repository ‘openSUSE-Leap-42.1-Update-Non-Oss’ because of the above error.
Could not refresh the repositories because of errors.

The network applet should appear if you switch to NetworkManager in YaST->System->Network Settings->Global Options.

But as you can browse with Firefox, your network is working in general.

and openSUSE still can’t access to exact these urls ( I saw them when run YaST -> Software Manager ):

Download (curl) error for ‘http://download.opensuse.org/distribution/leap/42.1/repo/oss/content
Download (curl) error for ‘http://download.opensuse.org/update/leap/42.1/oss/repodata/repomd.xml’:

See my present repositories: https://drive.google.com/file/d/0B0YPxoTYHWAZS2FpLXI2bDFFLU0/view?usp=sharing

tbk@dhcppc0:~> sudo zypper ref
Download (curl) error for ‘http://download.opensuse.org/distribution/leap/42.1/repo/oss/content’:
Error code: Connection failed
Error message: Failed to connect to download.opensuse.org port 80: unable to connect the network

zypper (and YaST) cannot reach the server.

So I ask again:
Are you using a proxy, i.e did you have to specify one in Firefox’s or KDE’s settings? As mentioned, YaST and zypper run as root and don’t see your user settings. You’d need to specify the proxy system-wide, in YaST->Network Services->Proxy or /etc/sysconfig/proxy.

And can you open a repo URL in Firefox?
E.g. http://download.opensuse.org/distribution/leap/42.1/repo/oss/content

I can open repository urls on firefox.
I didn’t see Proxy in YaST->Network Services (I saw this: https://drive.google.com/file/d/0B0YPxoTYHWAZVnZXaUZEM19nMTA/view?usp=sharing)
I have never configured my network (proxy,…)
/etc/sysconfig/proxy

Path: Network/Proxy

Description:

Type: yesno

Default: no

Config: kde,profiles

Enable a generation of the proxy settings to the profile.

This setting allows to turn the proxy on and off while

preserving the particular proxy setup.

PROXY_ENABLED=“no”

Type: string

Default: “”

Some programs (e.g. lynx, arena and wget) support proxies, if set in

the environment.

Example: HTTP_PROXY=“http://proxy.provider.de:3128/

HTTP_PROXY=""

Type: string

Default: “”

Some programs (e.g. lynx, arena and wget) support proxies, if set in

the environment.

This setting is for https connections

HTTPS_PROXY=""

Type: string

Default: “”

Example: FTP_PROXY=“http://proxy.provider.de:3128/

FTP_PROXY=""

Type: string

Default: “”

Example: GOPHER_PROXY=“http://proxy.provider.de:3128/

GOPHER_PROXY=""

Type: string(localhost)

Default: localhost

Example: NO_PROXY=“www.me.de, do.main, localhost”

NO_PROXY=“localhost, 127.0.0.1”

:frowning:

No, that’s the xinetd configuration module.

You should have a “Proxy” entry in the main window, in the section “Network Services”.
I’m not sure whether it still exists though.

I have never configured my network (proxy,…)

Then it should not be necessary.

Strange then that it doesn’t work.
Try to disable IPv6 in YaST->System->Network Settings->Global Options and reboot.
Some people did report similar problems in the past when YaST/zypper tried to use IPv6.

I’ve been plagued with this problem for about the last 3 generations of openSUSE. I’m pleased to have found this thread.

Actually I haven’t yet disabled the DVD repo, which I’m convinced will work. But I found this workaround. My DVD was in the player but I still couldn’t access the DVD repo. So I took it out. My update continued. But then when trying to access the repositories I got the same error again. So I put the DVD back in, and it flew past that error, and continued to download and complete the update.

So the trick that worked for me was each time during the update (twice) when I was prompted for the DVD repository, I removed the DVD on the first prompt and replaced it on the second prompt.

I just went and disabled the DVD repository in Yast and update works fine :slight_smile:

I don’t know if this will work, but you can try to disarm IPv6. Yast2---->System---->Networks--------->Global options.
I have had the same problem, but if I selected retry when zypper gets the error, it works… And with the time, the problem disappeared.rotfl!

Have no problem with DVD repository (USB). Why openSUSE have this problem? I also met this on openSUSE 13.2 and I haven’t seen a same problem on window 8, 10, Ubuntu, Mint, Manjaro

My openSUSE does not and never had this problem.
And I suppose most other users don’t have it either, or there would be many more complaints.

So, did turning off IPv6 help?
This seems to be a problem with curl actually (which zypper uses to download stuff)…

The only thing I can suggest you is to file a bug report at http://bugzilla.opensuse.org/ (same username/password as here).

I have disabled IPv6 and then the problem is solved!