Problem with 12.3 and Intel i915 Haswell dual monitors

In replacing my creaky old desktop with a new Haswell system I found that the ASUS uATX MB with the integrated Intel HD graphics would not work in dual monitor mode under openSUSE 12.3. The new build is very low profile and minimal power and I’d like to keep it that way (and not install some other graphic card). So … I tried 13.04 Ubuntu and it worked out-of-the-box with the i915 driver in dual monitor mode. Hmmm … maybe it is the kernel (3.8 in Ubuntu). That led me to experiment by installing newer kernel in openSUSE (found a 3.8.2-1-desktop via the page) . Works!

So I have something that works, yet if possible I’d prefer to stick with stock openSUSE. I was wondering if anyone else had observed (and solved) this issue.


         - Bruce

So the newer the kernel, the better the support can be for new hardware. There is no problem I am aware of in running kernel 3.8 instead of 3.7. I don’t know how it was installed, but by default, openSUSE 12.3 keeps multiple kernel versions, letting you select the one you want to use. When you boot into grub 2 next time, check out the advanced menu and see that kernel 3.7.10 is still there to select. More info on kernel updates can be found in my blog here:

openSUSE and Installing New Linux Kernel Versions - Blogs - openSUSE Forums

Thank You,