Problem when WIFI is password protected

I am using Suse 10.3. I have installed Wifi Radar and KInternet. Both applications are working when I am connected to public WIFI network.

I have problem when I am trying to connect with password protected network. Both applications are able to find my home network but unable to connect. I am using Vista to connect the network, therefore my password is correct and network is working. Probably I am missing something in the settings. What may be the reason?

Thanks in advance.

Check if the package wpa_suplicant is installed.If not that is more likely to be the problem.Just install it

  • plamenpenchev,

which security (WEP, WPA…) are you using on the access point? The settings on the access point and those on the nic must match.


I have a similar problem to this, has anyone managed to work it out. I am totally new to suse and linux in general. I’m using suse 11.
Currently I’m able to pick up wireless networks but I’m not able to connect to them. I’m not really sure about the correct settings. Last time I tried to get the settings right I got a crash report from KNetworkManager. The details from the two tabs in this manager are attached below. Any help will be much welcome. I will also try to send a bug report when I work out how to do so.
General Tab in KNetworkManager - The KDE Crach Handler
This handler shows up when I click on expert settings while setting up the network!

Short Description
The application KNetworkManager (knetworkmanager)crashed and caused the signal 11 (SIGSEGV).

What is this?
An appkication mostly receives the SIGSEGV signal due to a bug in the application. The application was asked to save its documents.

Backtrace Tab
Below are the contents of this tab, also saved in knetworkmanager.kcrash

System configuration startup check disabled.

e?1034h(no debugging symbols found)
(no debugging symbols found)

(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb6890a50 (LWP 3029)]
(no debugging symbols found)

(no debugging symbols found)
[KCrash handler]
#6 0xb6615a1a in ConnectionSettings::WirelessSecurityWidgetImpl::slotExtraSettingsToggled () from /opt/kde3/lib/
#7 0xb661941b in ConnectionSettings::WirelessSecurityWidgetImpl::qt_invoke ()
from /opt/kde3/lib/
#8 0xb745d79a in QObject::activate_signal ()
from /usr/lib/qt3/lib/
#9 0xb745fa21 in QObject::activate_signal_bool ()
from /usr/lib/qt3/lib/
#10 0xb77c87ae in QButton::toggled () from /usr/lib/qt3/lib/
#11 0xb74f792c in QButton::nextState () from /usr/lib/qt3/lib/
#12 0xb74f8920 in QButton::mouseReleaseEvent ()
from /usr/lib/qt3/lib/
#13 0xb7498337 in QWidget::event () from /usr/lib/qt3/lib/
#14 0xb73f83cd in QApplication::internalNotify ()
from /usr/lib/qt3/lib/
#15 0xb73f95d6 in QApplication::notify () from /usr/lib/qt3/lib/
#16 0xb7ab0892 in KApplication::notify () from /opt/kde3/lib/
#17 0xb7392a9e in QApplication::sendSpontaneousEvent ()
from /usr/lib/qt3/lib/
#18 0xb738f8c0 in QETWidget::translateMouseEvent ()
from /usr/lib/qt3/lib/
#19 0xb738eb5d in QApplication::x11ProcessEvent ()
from /usr/lib/qt3/lib/
#20 0xb73a2d04 in QEventLoop::processEvents ()
from /usr/lib/qt3/lib/
#21 0xb7410d10 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/
#22 0xb7410ba6 in QEventLoop::exec () from /usr/lib/qt3/lib/
#23 0xb73f8a5f in QApplication::exec () from /usr/lib/qt3/lib/
#24 0xb65c2861 in kdemain () from /opt/kde3/lib/
#25 0xb7f04474 in kdeinitmain () from /opt/kde3/lib/kde3/
#26 0x0804f329 in ?? ()
#27 0x0804faca in ?? ()
#28 0x08050105 in ?? ()
#29 0x08050b12 in ?? ()
#30 0xb6e655f5 in __libc_start_main () from /lib/
#31 0x0804b971 in ?? ()

the network manager on the cd/dvd has a bug, there is an update for it on the repo’s,so, if you have a wired connection, download the update then try again


Thanks, Andy. I have been through the repositories and updated all the packages that have to do with the knetwork manager but I’m still not able to connect. I think the real issue is that I can’t work out the right settings in order to enter the network password etc. Here is some of what I have tried so far.

From the icon in the taskbar bottom right:
Edit Connections
New connection > wireless
I choose from the list that is currently available and my Essid is filled in automatically
Click next
Check “Use wireless security”

There are 3 security options.

For “WPA personal” the only option is “shared key” which doesn’t make sense to me.

For “WEP” there are plenty of “key” options which also doesn’t make sense, since this network has only one and its type is unknown to me. I’m also not sure whether to choose “Opens system” or “Shared key” for authentication. None has worked so far.

For “IEEE 802.1 X” There are plenty of fields including a “password” field. In this case the expert settings option is disabled. For the encryption option in this area I have tried both “none” and “dynamic WEP”

I have entered the password here and clicked “connect & save” but still I’m not online!


hmm, your methodolgy is correct. have you tried putting the settings in via YaST - network devices - network settings ? a few other things to check:
1 ) firewall, is it set correctly to allow outward transmission ?
2 ) is the access point using MAC address filtering as well ?


I have tried the settings via YaST, the help buttons have been useful there for informing the decisions being made but still connection is not achieved even after rebooting.

I have left the firewall set to “External zone” which seems to be the default.

/sbin/ifconfig returns a HWaddr (which is the same as the MAC address displayed in the overview tab in YaST network settings.) It seems MAC address filtering is thus in use, as is the case for the ethernet connection I’m currently using to write this.


Using WEP…did you try entering the pass in hex decimal?
And let us know what you come up with.

It is not possible to enter the password in hexadecimal. It is basically a word with alphabetical letters and numbers.

I now think the problem is not just the password but something else. I’m currently writing from a wireless network which I’m accessing via my MS Windows partition. Using it requires that first my computer picks it up and connects, then I have to run vpn before I can actually browse the web. SuSE picks it up but fails to connect to it because when I run vpnc (as root) after entering my username and password, it claims that the host is unknown, which implies that the wireless is simply not connected.

I wonder if this might have to do with the way my kernel was compiled because I’m also having issues with displaying 3D graphics from remote machines (abaqus cae to be specific) despite having all the mesa3D-related packages. Someone hinted that I might have to recompile my kernel -I have no idea at the moment how to go about that!

But wonder why it does not affect Ethernet connections!


I have the exact same issue. I can access any open public wifi, but anything with WPA or any kind of security, simply won’t show up. Thus I can’t log into it. I’d make my network open if I didn’t live in the middle of a big city apartment building. :slight_smile:

Reading this post, I’m going to try a few things. See if I can get it to work. :expressionless: I sure hope so.

After having a very similar problem on my own network, I think I know what the problem is, however, this probably only applies if KNetwork and the gnome NetworkManager are frontends for the same API.

I’m using the gnome install of OpenSuse 11. This used to work, back at RC1 time, but now, no luck.

Basically, my wireless router is password protected, and uses WPA2. I’ve tried using AES and AES+TKIP, or WPA instead of WPA2, but no luck.

What I have discovered, however, is that it does not seem to be storing the password I enter!

For instance, let’s pretend my password is “bakedbeans.” If I tell it to connect to my network (which is detected properly), it asks me to enter my WPA password. A few moments later, the same dialog pops up.

If I click the checkbox that says 'show password, I discover that it doesn’t have my password after all. Instead, I end up with what appears to be garbage characters: caa2c14270da36b966a57de4a2e828d8cf037d7d9cfd13937a3f86409a82b4ab

Unless that’s a hash of my password, which seems odd to auto-fill into a password field, then it’s not storing my password.

For reference, unsecured network works.

it’s a hash of your password


If it’s a password hash, why put that in the password box instead of leaving it blank? That seems kind of backwards. If you click OK, it would hash the hash.


Instead of Wpa personal try Wpa enterprise.

I can see that many have similar problem but no solution so far. Anything working?

The strange thing is that always when I try to access wifi network both wifiradar and kinternet are reporting connected. With wifiradar it require IP but after while reports IP (none)

Kinternet reports connected even with other available wifi networks even without typing any password. With my modem it reports connected without password.

I have tryed tho change some options like password in hex, ascII, encrypted etc but non of them seems to work.

How I can find the solution?

The modem is with wep encription enabled, when disabled - same result.

In YAST when setting up the WiFI for home use you need to enter your SSID and then the password, it can be hex if you check the box. There should be 3 seetings just above Passphrase, Password ASCII and HEX, just check the hex option, and key in the numeric password. I never had any problems getting the Wifi to work on 10.3 whether it was using a public or my home Qwest wifi.

I think I will try openSuse 11 and then if needed I will come back on this issue