Problem when updating my system

Hi,
Whenever I want to update I get this message:


zypper up
No se encuentra el archivo /repodata/repomd.xml en el medio http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/
¿Cancelar, reintentar o ignorar? [a/r/i/...? mostrar todas las opciones] (a): 

but I’m sure to have the correct repositories. This is my ‘lr’:


 zypper lr
Prioridades del repositorio en vigor:
                            (Consulte zypper lr -P para obtener más información)
      95 (prioridad aumentada)   :  1 repositorio 
      96 (prioridad aumentada)   :  2 repositorios
      97 (prioridad aumentada)   :  2 repositorios
      98 (prioridad aumentada)   :  1 repositorio 
      99 (prioridad por defecto) :  7 repositorios

#  | Alias                               | Nombre                                                   | Habilitado | Comprobación GPG | Actualizar
---+-------------------------------------+----------------------------------------------------------+------------+------------------+-----------
 1 | VLC                                 | VLC                                                      | Si         | (r ) Si          | Si        
 2 | X11_MATE_Current                    | The latest official release of MATE (openSUSE_Leap_42.3) | Si         | (r ) Si          | Si        
 3 | download.opensuse.org-non-oss       | Repositorio principal (NON-OSS)                          | Si         | (r ) Si          | Si        
 4 | download.opensuse.org-non-oss_1     | Repositorio de actualizaciones (No OpenSource)           | Si         | (r ) Si          | Si        
 5 | download.opensuse.org-oss           | Repositorio principal (OSS)                              | Si         | (r ) Si          | Si        
 6 | ftp.gwdg.de-suse                    | Packman Repository                                       | Si         | (r ) Si          | Si        
 7 | http-download.opensuse.org-02e521f4 | openSUSE:Leap:42.3                                       | Si         | (r ) Si          | Si        
 8 | http-download.opensuse.org-06fb081e | multimedia:libs                                          | Si         | (r ) Si          | Si        
 9 | http-download.opensuse.org-795a8ca2 | X11:wxWidgets                                            | Si         | (r ) Si          | Si        
10 | http-download.opensuse.org-b395959f | multimedia:apps                                          | Si         | (r ) Si          | Si        
11 | http-opensuse-guide.org-6e4a4e8f    | libdvdcss repository                                     | Si         | (r ) Si          | Si        
12 | repo-packman                        | repo-packman                                             | Si         | ( p) Si          | Si        
13 | repo-update                         | openSUSE-Leap-42.3-Update                                | Si         | (r ) Si          | Si        

and my ‘zypper refresh’ shows a similar message:


zypper refresh
El repositorio VLC está actualizado.                                            
El repositorio The latest official release of MATE (openSUSE_Leap_42.3) está act
                                                                                
No se encuentra el archivo /repodata/repomd.xml en el medio http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/
¿Cancelar, reintentar o ignorar? [a/r/i/...? mostrar todas las opciones] (a): 

Can you help me?
Thanks :slight_smile:

Whenever I want to update I get this message:

“Whenever” as in this has been happening for a long time, several days or several weeks? Or, as in “Whenever” today?

If the latter, then you probably just need to wait for the mirror to get in sync, so try later.

If the former, then you need to override MirrorBrain’s mirror redirection. It is not always as brainy as its name sounds.

Living on the west coast of Canada, I need to constantly do this, because instead of redirecting me to a good mirror just a few miles/kilometres south of me in the U.S., MirrorBrain insists on redirecting me to a rather poor mirror on the other end of the Continent simply because it is in Canada.

Wait a few hours, and try again.

You were probably connecting to a mirror that is in the middle of updating.

Change

http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/

to

http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/suse/

and the same for the oss repo.

Thanks for all of your replies.
The last reply seemingly gives me the solution. I had problems since several months ago, and dozens of updates!
What can I do with the Packman repo?
Thanks :slight_smile:

Packman was down for work on the weekend, should be okay now.