Problem using Wine 1.1.49_1 on 11.3 and Wine 1.3.12-3.4 11.4

I have a problem using Wine on openSUSE 11.3 and 11.4

Not this used to work fine for opensuse 10.2

i think i should explain a scenario here first.

I am using self contained encrypted usb memory stick which is primarily design for windows XP. they way i used it on 10.2 is as follows:

  • plug in usb device and mount it to a folder (mount -t vfat /dev/sda1 /media/temp)
  • goto that particular folder and run exe file using wine.
  • it displays an explorer window to input password
  • when password is typed in press enter and it will display the usb memory stick contents.

Now on 11.3 i can go up to the final step and i can type my password in but when i press Enter key nothing happens.

i tried using different versions of wine (they are even worst)

On 11.4 things are worst for me; i get Program Error dialog saying The program xx.exe has encountered a serious problem and needs to close…

Is anyone using Wine on 11.3 or 11.4 and are they working fine,…

I dont know if that is right place to ask this question but i am wondering this same works fine for 10.2 with Wine 1.1.23. I will post this on Wine forum as well (if there is any) here is the details of OS and Wine version.

openSUSE Wine version
10.2 1.1.23
11.3 1.1.49_1.2rc6-2.1
11.4 1.3.12

though i have already tried using the latest version of Wine

any help will be much appriciated… thanks

Apparently i got a work around for this for now.

which is when running exe files with wine from konsole i can pass command line arguments/parameters,… this is fine but not ideal