Problem using Tumbleweed

I just installed openSUSE 11.4 and got all of the updates through yast. I then added Tumbleweed and Packman’s Tumbleweed. When I ran zypper dup --from Tumbleweed this is what I got:

Voyager:/home/dave # zypper dup --from Tumbleweed
Loading repository data…
Reading installed packages…
Computing distribution upgrade…

Problem: hdjmod-kmp-desktop-1.28_k2.6.37.1_1.2-1.2.x86_64 requires ksym(desktop:snd_card_create) = 797efb49, but this requirement cannot be provided
uninstallable providers: kernel-desktop-[openSUSE-11.4-11.4-0]
Solution 1: deinstallation of hdjmod-kmp-desktop-1.28_k2.6.37.1_1.2-1.2.x86_64
Solution 2: keep obsolete kernel-desktop-
Solution 3: break hdjmod-kmp-desktop by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/c] (c): c

I have not knowingly added any closed source kernel drivers. I am using a new Intel i7 2600 processor on an Intel DH67CL motherboard. Why the dependency problems?



Me too. I chose (1) and all was well. The repo maintainer gregkh remarked that it is a known issue that would be fixed eventually.

Turns out I can’t resolve it as you the hdjmod package comes from the Contrib repo, which you must have installed it from on your own previously. I can’t put it in Tumbleweed as it is not in Factory.

So, sorry about that. And yes, it’s safe to uninstall, unless you have that hardware and wish to use it on your system. If so, please work with the package maintainer/owner to get it moved into the openSUSE:Factory repo and then I can pull it into Tumbleweed.


greg k-h

I don’t know where it came from, how it got installed. Just part of the passing parade of mysteries.

I uninstalled the package and tumbleweed worked.