Problem using the Nvidia x driver

I installed Opensuse 12.2 and updated to the latest kernel. The graphic card is a Nvidia Geoforce 9800gt. I installed the driver using the easy way (https://en.opensuse.org/SDB:NVIDIA_drivers). The installation appeared to be successful. When I launched Nvidia settings, I got the following message: “You don’t appear to be using the Nvidia X driver”. Then, it is suggested to run “nvidia-xconfig”, which I did in console mode, and to reboot. I did exactly what they suggested, but I still have the same problem. I have not found any solution in the forums or internet. There was one place where it was mentioned that there could be a conflict with the Nouveau driver, but not in the latest Opensuse versions. Some help would be appreciated.

Guy

I believe you have to disable or blacklist the Nouveau driver or it will cause problems with nvidia Drivers.
this page will show you how to blacklist it.
https://en.opensuse.org/SDB:NVIDIA_the_hard_way#Blacklist_nouveau

What do you mean by the ‘latest kernel’ ?

There are some issues with the 3.7 kernel and some nvidia hardware and the proprietary nVidia graphic driver.

For example, on this thread a nVidia 8600GT user with the kernel 3.7+ noted this:

I do not know if that is relevant to your hardware, which is different hardware.

Hi, welcome

Please open a terminal window and post output of the following commands, between CODE tags


uname -a
/sbin/lspci
rpm -qa | grep nvidia
zypper lr -d
grep INITRD /etc/sysconfig/kernel

It is not obvious that this solution works for version 12.2. It is mentioned to backlist nouveau by adding modeset.nouveau=0 in the menu.lst file. However, this file does not exist anymore. It is replaced by grub.cfg, and there is a warning not to edit this file.

The results are:
linux-5178: # uname -a


Linux linux-5178 3.4.11-2.16-desktop #1 SMP PREEMPT Wed Sep 26 17:05:00 UTC 2012 (259fc87) x86_64 x86_64 x86_64 GNU/Linux

linux-5178: # /sbin/lspci


00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 81)
00:01.0 PCI bridge: Intel Corporation 82945G/GZ/P/PL PCI Express Root Port (rev 81)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)
00:1c.4 PCI bridge: Intel Corporation 82801GR/GH/GHM (ICH7 Family) PCI Express Port 5 (rev 01)
00:1c.5 PCI bridge: Intel Corporation 82801GR/GH/GHM (ICH7 Family) PCI Express Port 6 (rev 01)
00:1d.0 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation N10/ICH7 Family SATA Controller [IDE mode] (rev 01)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 01)
01:03.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22A IEEE-1394a-2000 Controller (PHY/Link) [iOHCI-Lynx]
01:04.0 Mass storage controller: Integrated Technology Express, Inc. ITE 8211F Single Channel UDMA 133 (rev 11)
02:00.0 Mass storage controller: Silicon Image, Inc. SiI 3132 Serial ATA Raid II Controller (rev 01)
03:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8053 PCI-E Gigabit Ethernet Controller (rev 15)
05:00.0 VGA compatible controller: NVIDIA Corporation G92 [GeForce 9800 GT] (rev a2)
linux-5178:~/Documents # rpm -qa | grep nvidia
x11-video-nvidiaG02-304.64-22.1.x86_64
nvidia-gfxG02-kmp-default-304.64_k3.4.6_2.10-21.1.x86_64
oyranos-monitor-nvidia-0.4.0-3.1.2.x86_64
nvidia-gfxG02-kmp-desktop-304.64_k3.4.6_2.10-21.1.x86_64
nvidia-texture-tools-2.0.6-18.1.4.x86_64
nvidia-computeG02-304.64-22.1.x86_64

linux-5178: # zypper lr -d


# | Alias                     | Name                               | Enabled | Refresh | Priority | Type   | URI                                                             | Service
--+---------------------------+------------------------------------+---------+---------+----------+--------+-----------------------------------------------------------------+--------
1 | nVidia Graphics Drivers   | nVidia Graphics Drivers            | Yes     | Yes     |   99     | rpm-md | ftp://download.nvidia.com/opensuse/12.2/                        |
2 | repo-debug                | openSUSE-12.2-Debug                | Yes     | Yes     |   99     | yast2  | [Index of /debug/distribution/12.2/repo/oss](http://download.opensuse.org/debug/distribution/12.2/repo/oss/)  |
3 | repo-debug-update         | openSUSE-12.2-Update-Debug         | Yes     | Yes     |   99     | rpm-md | [Index of /debug/update/12.2](http://download.opensuse.org/debug/update/12.2/)                 |
4 | repo-debug-update-non-oss | openSUSE-12.2-Update-Debug-Non-Oss | Yes     | Yes     |   99     | rpm-md | [Index of /debug/update/12.2-non-oss](http://download.opensuse.org/debug/update/12.2-non-oss/)         |
5 | repo-non-oss              | openSUSE-12.2-Non-Oss              | Yes     | Yes     |   99     | yast2  | [Index of /distribution/12.2/repo/non-oss](http://download.opensuse.org/distribution/12.2/repo/non-oss/)    |
6 | repo-oss                  | openSUSE-12.2-Oss                  | Yes     | Yes     |   99     | yast2  | [Index of /distribution/12.2/repo/oss](http://download.opensuse.org/distribution/12.2/repo/oss/)        |
7 | repo-source               | openSUSE-12.2-Source               | Yes     | Yes     |   99     | yast2  | [Index of /source/distribution/12.2/repo/oss](http://download.opensuse.org/source/distribution/12.2/repo/oss/) |
8 | repo-update               | openSUSE-12.2-Update               | Yes     | Yes     |   99     | rpm-md | [Index of /update/12.2](http://download.opensuse.org/update/12.2/)                       |
9 | repo-update-non-oss       | openSUSE-12.2-Update-Non-Oss       | Yes     | Yes     |   99     | rpm-md | [Index of /update/12.2-non-oss](http://download.opensuse.org/update/12.2-non-oss/)               |

linux-5178: # grep INITRD /etc/sysconfig/kernel


INITRD_MODULES="sata_sil24 ata_piix pata_it821x ata_generic xen-vbd xen-vnif"
NO_KMS_IN_INITRD="yes"
DOMU_INITRD_MODULES="xennet xenblk" 

Thank you for your help.

Guy

The one coming with Opensuse 12.2: 3.4.11-2.16

I spent considerable time trying to find a solution. Somebody indicated that the nouveau driver had to be blacklisted,
and pointed out the location for the instructions. It appears that the most recent version of the Nvidia driver does that already.
In /etc/modprobe.d, 4 different files are created by the nvidia installer, and they contain the instructions “blacklist nouveau”.
So, that does not seem to be the problem. The problem seems to be caused by a conflict between the Nvidia driver and the
opensuse 12.2. kernel. Before installing the Nvidia driver, I was able to boot in normal mode. Now, I have to boot in “recovery” mode,
only because the command “nomodeset x11failsafe” is included. This, I think, explains why I get the message “you do not appear to
be using the nvidia x driver”, if I understand correctly the role of x11failsafe. Any suggestion?

Guy

I was doing a fresh install of 12.2 today and was looking at the installation details as the packages were being downloaded and installed. I noticed an error message that said the proprietary Nvidia driver is not compatible with rivafb which is enabled in the kernel. Installation of the driver was halted and the message included a suggestion to recompile the kernel without rivafb support. I had blacklisted both the Nouveau and NV drivers in the package list before starting the install and was hoping to force the proprietary Nvidia drive to be installed as part of a fresh system install.

As a noob I would need some guidance about where the install log is and how to view and post the contents.

Mike

I am not sure what you are doing but I have never seen this error. If you want to install the nVIDIA propritary video driver using YaST, the two things needed to happen will occur for you. To manually install the nVIDIA proprietary video driver, It will take four steps. 1) Download the nVIDIA driver compatible with your video card, 2) Go into YaST / System / Sysconfig and disable Kernel Mode Setting 3) Add the kernel load option to Grub default kernel settings called nomodeset & 4) Reboot the PC into Run Level 3, then install the nVIDIA proprietary video driver. The fours basic nVIDIA drivers that exist are: rivafb, nvidiafb, nvidia and **nouveau **and normally the nouveau driver will be used short of some sort of manual intervention on your part and nvidia is the proprietary video driver…

For more info on installing the proprietary video driver, have a look here:

Installing the nVIDIA Video Driver the Hard Way: https://forums.opensuse.org/blogs/jdmcdaniel3/installing-nvidia-video-driver-hard-way-29/

AND

LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3 - Version 1.46: https://forums.opensuse.org/blogs/jdmcdaniel3/lnvhw-load-nvidia-driver-hard-way-runlevel-3-version-1-10-32/

AND for editing any system owned file, including lnvhw after it is downloaded, have a look here:

SYSEdit - System File Editor - Version 1.50: https://forums.opensuse.org/blogs/jdmcdaniel3/sysedit-system-file-editor-version-1-00-60/

I would look at every link I have provided, read through the information and then come back with questions.

Thank You,

Looking further to find a solution, I found the advice to add “nomodeset” at the end of the optional kernel command
line parameter. This did not solve the problem. The other commands on this line are:
video=1680x1050 resume=/dev/disk/by-id/ata-WDC_WD4000YR-01PLB0_WD-WMAMY1248490-part1 splash=silent quiet showopts
Could there be some conflict with some of these commands?

Guy

I have never had a problem with the default Grub 2 settings or adding in nomodeset. What does your copy of openSUSE do on startup? Do you just have a terminal session and no X graphic session or what does happen? What desktop are you loading?

Thank You,

Here’s the problem:

Linux linux-5178 **3.4.11-2.16-desktop** #1 SMP PREEMPT Wed Sep 26 17:05:00 UTC 2012 (259fc87) x86_64 x86_64 x86_64 GNU/Linux

the bold part is the kernel version, and it’s package version

linux-5178:~/Documents # rpm -qa | grep nvidiax11-video-nvidiaG02-304.64-22.1.x86_64
**nvidia-gfxG02-kmp-default-304.64_k3.4.6_2.10-21.1.x86_64**
oyranos-monitor-nvidia-0.4.0-3.1.2.x86_64
nvidia-gfxG02-kmp-**desktop**-304.64_k**3.4.6_2.10-21.1**.x86_64
nvidia-texture-tools-2.0.6-18.1.4.x86_64
nvidia-computeG02-304.64-22.1.x86_64

You see, you have the nvidia kernel-module for the stock installed kernel, whilst actually you’re running the updated kernel. Don’t know why the NVIDIA packages have not been updated, Don’t know either how you got both to be installed. The red bold package should not be installed at all. Remove that one first.

The rest of the output seems OK to me, but this here has got to be fixed.

After removing the red marked package, you should update the nvidia-gfx02-kmp-desktop to match your kernel version, i.e. 3.4.11-2.16

Thank you very much for your help. However, it didn’t work. Here is the output from rpm -qa | grep nvidia


x11-video-nvidiaG02-304.64-22.1.x86_64
oyranos-monitor-nvidia-0.4.0-3.1.2.x86_64
nvidia-gfxG02-kmp-desktop-304.64_k3.4.6_2.10-21.1.x86_64
nvidia-texture-tools-2.0.6-18.1.4.x86_64
nvidia-computeG02-304.64-22.1.x86_64


As you can see, nvidia-gfxG02-kmp-default-304.64_k3.4.6_2.10-21.1.x86_64 is not there anymore. Also, it appears that I have the most updated version of nvidia-gfx02-kmp-desktop for the kernel.

Guy

When I boot in normal mode, many lines of commands are displayed.
Then, I get a black screen and the monitor goes off line. So, I don’t have
a terminal session or a graphic session. I load the KDE desktop. However,
the stall happens well before KDE is loaded.

And if you select the rescue menu option in grub 2, what happens?

Thank You,

The system boots, but the nvidia x driver is not activated. When I try to setup the nvidia X server settings,
I get the message “You do not appear to be using the NVIDIA X driver”. Even If I run nvidia-xconfig as root,
as suggested, there is no change.

Thank you

This is suggested by NVIDIA (admitted, not clear at all) but you shouldn’t. xorg.conf is deprecated.
Do

su -c 'rm /etc/X11/xorg.conf'

, reboot and see what happens. Just to make sure an Xorg update hasn’t crippled the NVIDIA driver, reinstall the driver packages.

My experience with driver rpms suggests that if one had the wrong rpm installed, simply removing the rpm may not be enough. Sometimes one ALSO needs to re-install the rpms that were previously installed. The reason is the wrong rpm (now removed) may have over written libraries or binaries, that need to be restored again.

I don’t know if that is the case here (as I do not install the nvidia driver via rpms myself) but since I dont’ recall anyone else mentioning this aspect on this thread, I thought it worth mentioning.

First, I removed xorg.conf. Nothing happened. So, I reinstalled the driver package. When I asked for Nvidia setting, I still got the message "You do not appear to be using the NVIDIA X driver. " Then, I ran nvidia-xconfig as suggested in terminal mode and then restarted the X server. So, a new xorg.conf file was created. See my xorg.conf file below. If I keep xorg.conf, I am not able to boot in normal mode, only in recovery mode. As soon as I delete xorg.conf, I can boot in normal mode. Also, I am pretty sure that xonf.org corrupts the nvidia drivers. When I made some tests with xorg.conf, I had to reinstall the drivers a few times.

Guy

My xorg.conf file:


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 304.64  (buildmeister@swio-display-x86-rhel47-12)  Tue Oct 30 12:04:46 PDT 2012

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection