problem upgrading 11.2 -> 11.3 (x86_64)


tried to follow the instructions <> for a command line upgrade of 11.2 to 11.3 (x86_64).

however right after completing the zypper upgrade step with the designated command:

zypper in zypper

couldn’t any longer run zypper again.

always gets the following error:

zypper: symbol lookup error: /usr/lib64/ undefined symbol: _ZNSt7num_getIcSt19istreambuf_iteratorIcSt11char_traitsIcEEE2idE, version GLIBCXX_3.4

any ideas?

Hang on a second. This may be a stupid question, but I’ll ask any way. You have zypper installed, so why are you trying to INSTALL zypper with zypper? It should be zypper up zypper

no, it’s no stupid question, was wondering the same thing to be honest but decided not to deviate from procedure described:

*  First upgrade the package management stack: 

zypper in zypper

* Now execute the full distribution updgrade. 

zypper dup

(never made it to the last step :frowning: )

anyway, don’t think it has anything to do with the problem since it eventually did the “upgrade” so i presume if you have the package installed it will update/upgrade it (depending on your repos setting, right?)


I just ran zypper dup myself. Of course after changing my repos.

that is my goal as well, however “upgraded” zypper (that is after “zypper in zypper”) will no longer run with the message reported.

anyone had similar experience or could offer an opinion/solution?

Hash: SHA1

Download the zypper rpm from the 11.2 repository and install it using
rpm, download and install all the dependencies it tell you until you can
install zypper without problem, then change the repos again and do:

zypper clean -a
zypper ref
zypper dup

it work great for me many times, there’s no need for zypper up zypper,
but if you want to do zypper up zypper, not zypper in zypper


Microsoft Windows is like air conditioning
Stops working when you open a window.
Version: GnuPG v2.0.12 (GNU/Linux)
Comment: Using GnuPG with SUSE -


just tryed that (didn’t make any difference :frowning: )

downloaded all required packages from 11.2 like you suggested


deltarpm-3.5-3.2.x86_64.rpm satsolver-tools-0.14.10-1.1.1.x86_64.rpm
libzypp-6.21.2-1.1.1.x86_64.rpm yast2-ncurses-pkg-2.18.4-2.9.x86_64.rpm
python-satsolver-0.14.10-1.1.1.x86_64.rpm yast2-pkg-bindings-2.18.11-1.1.4.x86_64.rpm
rpm-4.7.1-6.7.3.x86_64.rpm zypper-1.2.8-0.1.3.x86_64.rpm

and installed them with no problems with the command:

rpm -Uhv --oldpackage *

however, no luck, right after tried to run zypper again to follow your suggestion with the error:


zypper: symbol lookup error: /usr/lib64/ undefined symbol: _ZNSt7num_getIcSt19istreambuf_iteratorIcSt11char_traitsIcEEE2idE, version GLIBCXX_3.4

i just don’t have enough experience to really understand what is wrong here and try to resolve it.

though that it might be because of the libstdc++ (the zypper in zypper upgraded this as well) so tried to get the one from the 11.2 repo and had to install it with the command:

rpm -Uhv --oldpackage --force libstdc++44-4.4.1_20090817-2.3.4.x86_64.rpm

otherwise (not using the --force) would get:

rpm -Uhv --oldpackage libstdc++44-4.4.1_20090817-2.3.4.x86_64.rpm
Preparing… ########################################### [100%]
file /usr/lib64/ from install of libstdc++44-4.4.1_20090817-2.3.4.x86_64 conflicts with file from package libstdc++45-4.5.0_20100604-1.12.x86_64

my big problem is that i need to find a reliable way to upgrade my production servers, reinstall is not an option for me, too costy.

sorry, lost it there for a minute.

anyway, no luck with the libstdc++ downgrade as well :frowning:

You just need to install libstdc++3.4 libraries - I believe it should work… Use Yast temporarily for doing the installations/upgrade…

thank you for the recommendation!

however installing 3.3 (didn’t find 3.4 as suggested) didn’t make any difference. is seems that i didn’t uninstalled the (aparently problematic?) 4.5 (which was installed during the “zypper in zypper” -btw, i later tried “zypper up zypper” without any difference, those commands had identical results- was installed and seemed to cause all the problems).

so now i am upgrading with the 4.4 version installed and the upgrade proceses suggested that 4.4 will be removed and replaced with the (problematic?) 4.5. i’ll have the results in about and hour from now.

this is very weird in any case and believe i should have never faced that problem (no?). i followed the designated steps from the guide after all. (not to mention that my problem was rather generic and my installation was almost “minimum” -it’s a server installation without X-windows etc-)

make it.

eventually made it with the “trick” mentioned. upgraded to 11.3 with libstdc++45 and zypper working :slight_smile:

however was using libstdc++44 while upgrading. it wouldn’t run with the new libstdc++45.

thank you all so very much for you help and time!

kind regards,


hi there.

i’ve got exactly the same problem; i tried to follow your steps, but got stuck with your post on 19-Jul-2010 15:29…

i also reinstalled these rpms and forced installation of libstdc++44-4.4.1…

but zypper/yast and so on always returns

symbol lookup error: /usr/lib64/ undefined symbol: _ZNSt7num_getIcSt19istreambuf_iteratorIcSt11char_traitsIcEEE2idE, version GLIBCXX_3.4

need help!

in my case the solution was to remove the newly installed libstdc++45 (from “zypper up zypper”). then zypper would run happilly with no problem. i suggest you find and remove the libstdc++45 that comes with the 11.3 and then go straigt to the upgrade “zypper dup”.

good luck,


how did you remove libstdc++45-4.5.0_20100604-1.12.x86_64 ?

zypper rm won’t work cause of the errors mentioned above and i’m quite afraid tof using rpm -e --force --nodeps libstdc++45-4.5.0_20100604-1.12.x86_64 on a productive server

i know what you mean :slight_smile:

i suggest you try it forst without --force and --nodeps and see it’s dependencies, i think it’s only with a yast module that won’t effect you during th upgrade (if i rember right in my case).

then with --nodeps (i think it will remove it and will be able to use zypper again).

thx a lot, it worked:

just in case another lost soul has to solve this problem:

i deinstalled the lib using “rpm -e --nodeps” and reinstalled the older lib (got it from suse-ftp: /pub/opensuse/distribution/11.2/repo/oss/suse/x86_64) using “rpm -Uvh”

zypper is working fine again.

I ran into the same problem just yesterday, trying to upgrade an old system with yast-wagon.

The following lines got my system to a working state again:

rpm -e --nodeps libstdc++45-4.5.0_20100604-1.12.x86_64
rpm -Uvh libstdc++44-4.4.1_20090817-2.3.4.x86_64.rpm