problem updating

hello, I just installed OpenSuse 11.2 RC on my PC, new to this whole Linux thing so I’m sorry if the question seems a bit “noob”, everything went throu just fine, exept 1 lil problem, I can not update, It seems like the Repo’s are wrong, so I was wondering, wich one are the actual good repos for 11.2 ? Thanks in advance.

This is what it says: a release candidate; lots of things, like the repos from which you will eventually be able to update, have not yet been finalised.

So I even try to add another repo with zypper and this is what i get:
xxxx@linux-p0vh:~> sudo zypper addrepo
Failed to download /suse/11.2/Packman.repo from Index of /
Abort, retry, ignore? [a/r/i/?] (a): a

Problem accessing the file at the specified URI:
[] URI=
Please check if the URI is valid and accessible.

I can access and even see the .repo file, but apparently suse can’t. Am I doing something wrong or my release is not able to Update at all?

Thanks in advance.

I even tried the “Wine” repo and it say the same thing… I have access to the INTERNET and can download stuff throu BitTorrents, what its goin on? I’m goin insane here :frowning:

Try using yast to add repositories.

Also post the output of zypper lr -d and someone could probably help you more easily. For instance, here is mine (you do not need the KDE 4.3.2 ones, other than that I just have stock repos and packman):

1 | KDE_4.3.2 | KDE 4.3.2 | Yes | Yes | 95 | rpm-md | |
2 | KDE_4.3.2_Community | KDE 4.3.2 Community | Yes | Yes | 120 | rpm-md | |
3 | | Packman Repository | Yes | Yes | 90 | rpm-md | |
4 | repo-debug | openSUSE-11.2-Debug | No | Yes | 99 | NONE | |
5 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 99 | yast2 | |
6 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 99 | yast2 | |
7 | repo-source | openSUSE-11.2-Source | No | Yes | 99 | NONE | |
8 | repo-update | openSUSE-11.2-Update | Yes | Yes | 99 | rpm-md |

I’m also fairly new to opensuse, but I’ve been using ubuntu since feisty. Just figured I’d try to help get the ball rolling on solving your problem :).

Ok, do I tried to add those repos, and when i get to puch “OK” at the final screen I get this msg:

Download failed:
Failed to download /repodata/repomd.xml.asc from Index of /pub/packman/suse/factory

  • [] IRI=

So I can’t even add any Repos, and I dont have any, 'cause I delete them, since the ones that were there I tho were wrong. :frowning:

Any ideas?


You have two choices: wait until after the release of 11.2 or re-install 11.1; there is no point struggling with repos at this point unless you are bug-hunting in which case you should be reporting things to Bugzilla and not here.

I installed 11.2 official release, and encountered same problem.

I am encountering the same behavior. I did an inplace upgrade from 11.1 to 11.2, and the error messages I see are (depending whether it’s yast or the update applet that complains):

Error: PackageKit Error repo-not-available. Failed to download /content from
Index of /distribution/11.2/repo/non-oss


Download failed:
Failed to download /repodata/repomd.xml.asc from
[AbstractCommand cc:195] URI=

or in the oss and non-oss repositories, not getting repomd.xml (without the .asc extension), with a slight change in wording: “Can’t provide /repodata/repomd.xml” and “Valid metadata not found at specified URL(s).”

Using a browser, I can see /repodata/repomd.xml down the oss and non-oss paths ([oss|non-oss].

I’d welcome any suggestions. If need be, I’ll backup my data off the notebook, then do a fresh install of 11.2 instead of an upgrade.

Fwiw, I’m trying this across a wireless connection that is working fine for the browsers and e-mail clients. But when telling yast to configure the repositories, one error does suggest that the repo server is unavailable or unaccessible. Does the updating look for an internet path anywhere different than the browsers and email do?

Hello folks!
I have just been fresh installing 11.2 and when it came to test the internet connection, then update the repos and do the online updates, suddenly I was receiving similar error messages and nothing worked anymore.
YAST could not find any of the repositories, although when browsing to them with a internet browser from another machine, I could find everything just fine.

After doing a lot of debugging I could finally solve the problem: I am having a gateway server who is running as “unified-thread-management”-server (“Endian Firewall - community edition”](, e.g. as a firewall, which is filtering incoming and OUTGOING traffic, and in addition is working as a HTTP-proxy.
YAST seems to be making some http-filetransfers via TCP/3080 (god knows why) and somehow everything got stuck in my transparent HTTP-proxy. When I added the IP of the machine to the “Bypass transparent proxy” setting, suddenly everything worked like a charm.

Please feedback, if this applies to you, too!


Has anyone has been able to fix this problem I’ve been stock on this one for the past week…

Yes Tomakos thankyou!
In my case I was using a squid proxy, grepping the logs for suse showed zypper was trying to get


acl Safe_ports port 3080

to squid.conf and restarting squid got me going again

Cheers and thanks Ian

Tomakos thanks a lot…
i have the same issue and i added my host ip it into bypass transparent proxy and now its working
Thanks again