problem to pair bluetooth speaker

Hello everybody

I did a fresh install of latest opensuse leap 15 and i’m trying to get bluetooth works with external speakers to stream music from internet (youtube, …)
I’ve an Hp Pavillion x2 10-n105nl (energy star).
Previously with leap 42.3 i was able to stream music with bluetooth using pulseaudio and pavucontrol (that i used to configure A2DP).
But now with leap 15 i cannot start pulseaudio anymore, when a did pulseaudio -D nothin happened and i get: “failed to start daemon”.
I’m not able able to open pavucontrol too.
The bluetooth speaker get connect but after 2-3 sec get disconnect and failed to pair. If I login as root nothing change
Any suggestions?
thanks in Advance

What Desktop are you running?
For instance, KDE has its own bluetooth connectivity components.


Hello, i’m running gnome desktop.

For my tablet I’ve rolled back to opensuse leap 42.3 and now bluetooth is working again.
But i’m going to install leap 15 on virtualbox and see if in a desktop pc bluetooth is working.

My tablet is windows 10 native and the sound doesn’t work . You could just stream music from internet by means of bluetooth’s external speaker.

I’ll report if bluetooth and audio will works after virtualbox installation (gnome desktop in any case)

Best Regards

First: many of us don’t even run Windows, so that issue is something that needs solving/fixing elsewhere
Second: downloading a Leap 15 live image would IMHO give a better impression than a virtualized install.

Hi, I don’t have Windows 10 anymore on my tablet .

I format it and I’ve installed OpenSUSE 42.3. openSUSE is running much more better on my tablet than windows 10.

I’m usually running opensuse anywhere from my laptop to my desktop that i use in my work (i’m a Network Engineer) so i’m not new in openSUSE.

I’ll trying to run Leap 15 live image as you’ve suggested. I’ll report back later


Hello everybody

I’ve tried to install opensuse leap 15 live image on my tablet but it has not recognized the usb iso so nothing to do.
the version I’ve tried: openSUSE-Leap-15.0-GNOME-Live-x86_64-Snapshot20.90-Media.iso

My tablet has the following spec:
Intel® Atom™ Z8300 con scheda grafica Intel® HD (1,44 GHz, 2 MB di cache, 4 core)
eMMC , 32 GB

I’ve followed the same procedure as I did before to install Leap 15 and Leap 42.3 by means of USB iso stick:
live-fat-stick --isohybrid /path/to/openSUSE-filename.iso /dev/sdX

below the opensuse version’s that works on my tablet:

both iso’s above are working on my tablet but bluetooth is working just in leap 42.3 not in leap 15.

Now iI’m running leap 42.3 but whats will happen if I would perform an upgrade to leap 15?
Bluetooth will stop to work?
Thanks for any help or suggestions