Problem to install/uninstall VMWare


I’m new on openSuse world ^^ and have some problems.
I’m running an openSuse 11.1 64 bits with gnome.

I wanted to install VMware Player. So I got the rpm package from VMware website and install it. The install successed but when I launched it, an error occurred : it didn’t find my kernel header to compil some of it specifics modules.
I tried many times but with no success.

Then I tried to install the Workstation version of VMWare with the same process : download the rpm package from VMWare and try to install it with :
rpm -i VMware-Workstation-6.5.1-126130.x86_64.rpm
and got these errors :
*error: Required dependancies :
VMware-Player conflict with VMware-Workstation-6.5.1-126130.x86_64
VMware-Workstation conflict with VMware-Player-2.5.2-156735.x86_64

Then I tried to uninstall the VMware Player with :
vmware-uninstall. It success.
Try again to install the Workstation and got the same error …

And if I test those :

  • sudo rpm -i VMware-Player-2.5.2-156735.x86_64.rpm
    package VMware-Player-2.5.2-156735.x86_64 already installed
    sudo rpm -e VMware-Player-2.5.2-156735.x86_64.rpm
    error: package VMware-Player-2.5.2-156735.x86_64.rpm isn’t installed

Then I don’t know how to really uninstall the VMWare Player and install VMWare Workstation.

Really need help, thanks ^^.

in order to compile the kernel modules, youll need the kernel source and kernel syms packages. You can install them with

sudo zypper install kernel-source kernel-syms

then run vmware player (or workstation) with the command:

gksu /usr/bin/vmplayer

as it starts up, it should prompt you to build the modules, follow the instructions on screen. After the modules are installed, you should close the vmware-player window and re-open it as a regular user.

as rpm saying it cannot uninstall things…try

sudo rpm --rebuilddb

that may take care of the problem. Good luck!

thanks you for the answer,
I’ll test this as soon as possible, I’ll say you if it works or not ^^.


I tried what pimanac said :

sudo zypper install kernel-source kernel-syms

→ OK

sudo rpm --rebuilddb

→ OK

But got the same problem …
Then I have read again the rpm manpage and find this option : --replacepkgs.
Then tried :

 sudo rpm -U VMware-Player-2.5.2-156735.x86_64.rpm  --replacepkgs

which install the package even if it is already install ^^.

And for now all is working well.
Since I installed kernel sources, VMware Player successed to compil these modules ^^.

I still didn’t try again to install VMWare Workstation, as soon as I tried it I’ll let you know about it :slight_smile:

Thanks again to pimanac :slight_smile:

you’re quite welcome!

if you choose to install vmware workstation, you shouldnt have to recompile the drivers.

if for some reason you compile a new kernel sometime down the road, you will have to rebuild the modules to fit the new kernel.
its the same command as building them the first time…

gksu /usr/bin/vmplayer