Problem to Connect to VPN

Hi Everyone

I am getting a error when i try to connect to VPN

Could anyone please help me, if u had this error before.

Thank u in advance.

Here is the what the logs throws

2014-10-12T13:01:03.748124-05:00 localhost NetworkManager[857]: <info> VPN service ‘vpnc’ started (org.freedesktop.NetworkManager.vpnc), PID 2135
2014-10-12T13:01:03.765139-05:00 localhost NetworkManager[857]: <info> VPN service ‘vpnc’ appeared; activating connections
2014-10-12T13:01:05.262368-05:00 localhost NetworkManager[857]: <info> VPN plugin state changed: starting (3)
2014-10-12T13:01:05.267345-05:00 localhost NetworkManager[857]: <info> VPN connection Name of VPN’ (Connect) reply received.
2014-10-12T13:01:05.328896-05:00 localhost NetworkManager[857]: <warn> /sys/devices/virtual/net/tun0: couldn’t determine device driver; ignoring…
2014-10-12T13:01:07.553428-05:00 localhost NetworkManager[857]: <warn> VPN plugin failed: 0
2014-10-12T13:01:07.554394-05:00 localhost NetworkManager[857]: <info> VPN plugin state changed: stopped (6)
2014-10-12T13:01:07.555357-05:00 localhost NetworkManager[857]: <info> VPN plugin state change reason: 10
2014-10-12T13:01:07.556339-05:00 localhost NetworkManager[857]: <info> Policy set ‘Profile 1’ (em1) as default for IPv4 routing and DNS.
2014-10-12T13:01:07.557081-05:00 localhost NetworkManager[857]: <warn> error disconnecting VPN: Could not process the request because no VPN connection was active.
2014-10-12T13:01:13.241105-05:00 localhost NetworkManager[857]: <info> VPN service ‘vpnc’ disappeared

Thank you
Manuel Ramos

How did you set up your VPN?

From your error log,
It appears that the VPN configuration couldn’t determine what kind of VPN is supposed to be started.

TSU

Cisco VPN and set up with Netowork setting manager adding a new VPN and choose the Cisco VPN and fill the gateway, username, group name, group password and user password :S

I am using openSUse 13.1

Thank u for reply

Did your Cisco VPN admin provide you with a connection answer file?

TSU

Yes i had a password for the group name.

The error i think is in this line
: <warn> /sys/devices/virtual/net/tun0: couldn’t determine device driver; ignoring…

and dont find the file tun0, Do u have an idea for restore that file?

Thank u

For starters, you should verify you have the tun/tap driver package installed.

zypper in vtun tunctl

I’d be a bit surprised if you installed any VPN packages already (did you?) where your tun/tap isn’t already installed (it’s pretty basic and common to many types of vpns). The above command installs what may be missing (vtun) and the tool to manage (create/configure/remove) your tun/tap device (tunctl).

TSU

Yes i have it installed
vpnc
NetworkManager-vpnc-gome
NetworkManager-vpnc

about the command you give i get this

*Loading repository data…
Reading installed packages…
‘tunctl’ is already installed.
No update candidate for ‘tunctl-1.5-22.1.2.x86_64’. The highest available version is already installed.
‘vtun’ not found in package names. Trying capabilities.
No provider of ‘vtun’ found.
Resolving package dependencies. *

So it doesnt work. mmm another idea why is looking that particular file, i read something about and they say it is for firewall or something like that i am not really surjust guessing, I am talking about tun0
/sys/devices/virtual/net/tun0: couldn’t determine device driver; ignoring…

I read from other forums the problem could be libgcrypt11 package maybe there is a way to downgrade the packge.

Thank u
Manuel Ramos