problem to burn mpeg file


i converted a avi file to mpeg file

i used k3b to created a dvd with it

when i try to burn it, i get


SONY DVD RW AW-G540A 1.74 (/dev/sr0, CD-R, CD-RW, CD-ROM, DVD-ROM, DVD-R, DVD-RW, DVD-R DL, DVD+R, DVD+RW, DVD+R DL) [DVD-ROM, DVD-R séquentiel, DVD-R double couche séquentiel, DVD+R double couche à saut, DVD-RAM, DVD RW à réinscription limitée, DVD-RW séquentiel, DVD+RW, DVD+R, DVD+R double couche, CD-ROM, CD-R, CD-RW] [SAO, TAO, RAW, SAO/R96P, SAO/R96R, RAW/R16, RAW/R96P, RAW/R96R, Réinscription restreinte, Saut de couche] %7]


mkisofs print size result: 0 (0 bytes)


K3b Version: 1.69.0
KDE Version: 4.3.4 (KDE 4.3.4) “release 2”
QT Version: 4.5.3

Used versions

mkisofs: 1.1.9


/usr/bin/genisoimage: No such file or directory. Failed to open VIDEO_TS.IFO
/usr/bin/genisoimage: Can’t open VMG info for ‘/tmp/kde-collinm/k3bVideoDvd0/’.
/usr/bin/genisoimage: Unable to parse DVD-Video structures.
/usr/bin/genisoimage: Could not find correct ‘VIDEO_TS’ directory.
Possible reasons:

  • VIDEO_TS subdirectory was not found on specified location
  • VIDEO_TS has invalid contents

mkisofs calculate size command:

/usr/bin/genisoimage -gui -graft-points -print-size -quiet -volid Autumn_Fin_Du_Monde_2009 -volset -appid K3B THE CD KREATOR (C) 1998-2009 SEBASTIAN TRUEG -publisher -preparer -sysid LINUX -volset-size 1 -volset-seqno 1 -sort /tmp/kde-collinm/k3bU21816.tmp -no-cache-inodes -udf -iso-level 1 -path-list /tmp/kde-collinm/k3bT21816.tmp -dvd-video -f /tmp/kde-collinm/k3bVideoDvd0

any idea?


You may want to install DeVeDe, its what I use for home made DVD’s

Same probleme here! I recorded a TV-stream under kaffein, cutted it with dvdcut and wanted to burn it on DVD.
But neither DVD-Styler/Videomaker/2ManDVD nor QDVDauthor wanted to burn an ISO from it. They converted the files to Audio and Video, but did not burn it>:(.
So I had the files and thought, I could burn it with k3b. But no succsess here, too.
I got the same errors like you did. After trying for three days now, I’m searching for an advice here, too.
Perhaps anyone outside to help us solving this problem?:idea:

Think I’ve fixed it!lol!
Installed k3b for KDE4, including the -devel package.
Than ran DVDStyler without “burning” on the fly,but building an ISO file in the home directory.
Afterwards starting k3b-4 (the "old k3b " didn`t work!? Started in here before. I don’t know why? - Anybody else does?) and burned the ISO on DVD. That was it.
So I created my FIRST OWN DVDrotfl!!

K3B needs the DVD file structure to burn a video disk. It won’t create this for you. Dvdauthor will do this, and if you don’t need menus and buttons, it’s pretty quick and easy to use.

Devede application is the one which I use for the last year(recommended in the forum) and you can create iso files from almost any input files and even you can subtitles to the DVD(that functionality doesn’t work all the time and not sure why). You can have a basic menu created with a background from a png file and some sound and basic buttons(not very fancy). I tried to use 2ManDvd and QDVDAuthor without success. the burn is done via K3b after the iso is created.

yes, you are right, but Devede did not work here.In fact, it always crashed after opening the startscreen. It was not possible to keep it on the desktop for more than 1 second; neither by opening it via startbutton on the desktop, nor starting it via konsole>:(. I’ve tried a lot of different programms before (see post above). The only way for me was doing it the way I wrote. Burning an ISO - for example the ISO files of openSUSE;) worked without any problems. Only the films caused my “problems”. 2ManDVD and QDVDAuthor worked not here, too. Don’t no why.
They both started, but 2ManDVD told me, “mpeg2enc” is missing (looking in yast said, it is installed!) and interrupted the conversion of the files.
Almost the same in QDVDAuthor. Here I could add the files, convert them, let it build an ISO - but the ISO always had 0 MB…??
That is why I use the other way.