problem tightvnc server on opensuse 11.4 and keyboard mapping


I use opensuse 11.4 with TightVNC Server version 1.3.9.
I use french keyboard mapping (yast configuration).
When I connect with putty via ssh all is ok (keyboard mapping). But when I use tightvnc viewer on windows the mapping is not correct.
I’ve verified many time the configuration of the keyboard in yast (graphical) and desktop options (french mapping). I can’t map correctly. It seem there is no issue with direct attached keyboard.
Another strange behavior is the shift key. I want to use . (need to press shift + :wink: and this put a >. But sometime if I press “shift + ,” before then “shift + ;” it works.

I’ve passed long time on google and find no answer yet.

Have you any idea ?

Is there a issue with tightvnc server ?
A bug with tightvnc viewer ? (I’ve tried with realvnc and same results).


Olivier MICHEL
Unix administrator