Problem switching back to wireless from wired

Running my TW KDE Network Manager laptop on wireless works fine normally, however yesterday needed to back up and wired is faster so connected via lan cable and turned off wireless. When finished I removed the wired cable and enabled wireless but Network Manager could not connect to my previously used wireless connection (only one available) every time I tried to connect it just gave up. I needed a reboot to get connected wirelessly again.

Any suggestions please as to why this might happen or what to look for next time?


I don’t see this issue ( just tested, unplugging wired cable instantly activates my wireless connection if not already active. ). Try reproducing it, and if you succeed in doing so, report a bug,

I have had that happen, though it was a while ago.

It turned out that I can “disable networking” on the Network tray applet. And then when I re-enable, I could connect again.

It’s been a while, so I don’t know if that still works. But it is worth trying, because it is simpler than rebooting.

Thanks, I’ll try the disable network thing and see what happens. If still no luck I’ll raise a bug.