Problem starting xserver after upgrade

Hello everyone,
today I did a serious mistake.

I was about to do upgrade from 11.3 to 11.4.
I was following the guide I found in opensuse’s website.
I was to the point where I had to disable all 11.3 repositories and add the 11.4
at that point I forgot to change my nvidia repository ( I have a g210m graphic card).

thus after the upgrade the X could not start at all. I think this was because Yast could not find the nvidia driver.

Using text mode YaSt2 I added the nvidia driver but after restart I can not see and X running. I receive an error message that the current kernel can not be loaded!!!

I also checked in command line if there is something like Sax2… but I couldnot find anything.

What is the easiest way first to make X work with a simple graphic card and then afterwards add the nvidia driver?

I would like to thank you in advance for your help


I have an idea, it may or may not work, but before I need to see your

zypper lr -d

. If it is not possible try it doing it like this:

 zypper search --sort-by-repo -i "*" >> all.txt

And after that:

zypper search --sort-by-repo -i --repo=alias_of_your_11.4_oss --repo=alias_of_11.4_nonoss -i "*" >> some.txt

and after that:

diff -w -B --suppress-common-lines all.txt some.txt >> difference.txt

Then you should see your installed packages that doesn’t belong to either on of the 11.4 repos. I would uninstall them, and make a zypper dup again (after making sure of the enabled repos are correct though :)).

This maybe a risky move, I would personally go for it but, I like adventures. It is up to you.

If the kernel could not be loaded you would not be able to do anything
further, so its sounds to me that it was not able to load a kernel module??
First of all check if there is an old xorg.conf in /etc/X11 and if so rename
it and try to restart X. It might be you have simply an old xorg.conf as
leftover from your 11.3 which is not compatible with the nvidia driver in

PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
9600 GT | 4GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
ION | 3GB Ram

Tried this one.
I removed it as root the file and wrote startx. The kde appeared :slight_smile:
then I logged in as normal user but startx failed! which is the file that I am looking to remove now? Did not find anything in my home folder

Vielen Dank. Scoenes Wochenende

That can be a lot of things, since I guess you have your old .kde4 config
You can rename the .kde4 folder in your home and check if that helps, it can
also be that the problem lies in the folder .kde or the file .kderc (do not
delete it, it may contain things you need, like the emails in kmail).

Another way to check that is to create a new user and see if that user works
with kde.

By the way did you try the following simple test?
Login as root on the console (not from within kde).

init 3 # to be sure you are not in runlevel 5
init 5 # to go to the runlevel where kdm should start automatically

PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
9600 GT | 4GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
ION | 3GB Ram

This is normal… more precisely this is the expected behaviour. SInce 11.4, startx doesn’t work for normal users anymore. If you want to be able to run startx as user, you have to set Xorg SUID again, so as root:

chmod 4711 /usr/bin/Xorg

Don’t know if it advisable though (they may have change it for a good reason… or not).

You might have to uncomment the following line in /etc/permissions.local too:

#/usr/bin/Xorg                 root:root              4711
  • Haven’t read the whole thread and I don’t know what is the problem. But this is how to run startx as user.

I did this and worked . Regards