Problem solved: Broadcom Wireless Card worked on 12.1

I have found this website OpenSUSE Wlan Page which solved my problem.
For a better information, I have a Compaq Presario CQ57 notebook with very low wireless signal strength. This is solved with the website I provided above.

Hi BA,

I have been trying to solve a problem just like this for months (see

Noting that HP & Compaq are often the same machines “under the cover”, I thought that your link may throw up something? Although on inspection, I have been down that route before - without success!
To try and confirm that your success is relevant to my situation, can you tell me what your wireless chipset is?
Can you either post the results from your version of:

#hwinfo --wlan

or tell me that your and my chip are not the same.

Secondly, can you (or anyone else), suggest how I can tell if installing the broadcom-wl and broadcom-wl-kmp-desktop from the package manager (as described here) has been effective? Or is it being overwritten by an existing (less than ideal) bcrmsmac driver or firmware?

Regards, Martin