Problem running Thunderbird

When I try opening thunderbird it just sits there for several minutes then eventually comes up with a message saying the following script has stopped responding

chrome://messenger/content/mailWindow.js:193

Whether I click Continue or Stop script it continues to sit there for about five minutes then goes away

Thunderbird then runs incredibly slow and fails to login to any of the accounts in my profile

If I try to run thunderbird with a new freshly created profile it gives me a screen saying:

Sorry - we're unable to communicate with our sign-ip server.  Please check your connection

All I can do at that point is kill thunderbird and if I’ve run it from konsole I see the message given below:

mail.provider   ERROR   Something went wrong loading the provider list JSON file. Going into offline mode

I’ve checked my connection is fine, uninstalled & reinstalled thunderbird, googled the errors and found nothing useful

Also searched the system and can’t find a mailWindow.js file anywhere

Any suggestions appreciated

Tried an earlier version of thunderbird in case it was a bug in the release version I had, same problem

On 12/10/2012 01:16 PM, Ecky wrote:
> Any suggestions appreciated

i suggest tell us

-the operating system and version you are using

-the desktop environment and version you are using

-the version of Thunderbird you are using

-if you are using any add-ons

-what happens if you run in a terminal


thunderbird -safe-mode

-if this system ever had a working Thunderbird

–if yes, when did it change (like during a version change, or?)

–the the change happen after an add-on was installed?

–if no, is this a new install and TB never worked

–if no, how was TB installed (via YaST, zypper, download+rpm command,
compile from source and install, or what?


dd http://tinyurl.com/DD-Caveat

openSuse 12.2 x86_64

Kde 4.8.5 release 2

17.0-49.23.1-x86_64 and 16.0.2-49-19.1-x86_64 (tried the earlier version after getting the issue in the later one)

No

Exactly the same

yes

Not entirely sure, started a few days ago, there were some updates, don’t recall exactly what and don’t remember seeing thunderbird as one of them

Not using addons

Thunderbird’s worked since the day the OS was installed

Installed using zypper

ok, from your answers i conclude that the problem is not in Thunderbird
itself (since the problem is now seen in both 16 and 17, and both worked
ok previously)…nor is it from an addon…

so, something has changed in your system–but, what? lets see if it is
something ‘bad’ in your personal configuration files:

if you use YaST > Security and Users > User and Group Management to
temporarily add a new TestUser, then log out and log back in as the
TestUser, is the problem resolved?


dd

On the right track there dd

Tried as another user, first time for thunderbird to run as that user and I didn’t get the message about no connection to the sign-up server, opened up with the account wizard as you’d expect

How to figure out what’s in my profile causing it’s the thing, I’m gonna see what I can find relating to thunderbird and mozilla in my user’s homedir

On 12/10/2012 06:36 PM, Ecky wrote:
> I’m gonna see what I can find relating to thunderbird and
> mozilla in my user’s homedir

first: Thunderbird and Firefox are both made by mozilla, and in your
home directory is a .mozilla which is where the Firefox goodies hide,
and .thunderbird is where the secrets of your email client lives…

second: be VERY careful…if i were you the first thing i would do is
make a COPY of .thunderbird and name it something else, like
…thunderbird-old, so if you mess up you can go back to using the original…

so, under /home/[yourID]/.thunderbird is a directory named
[randomStuff].default and that is where your TB is…do you have to have
more than one [randomStuff].default?

unless you don’t care about all your email, BE VERY CAREFUL because you
email is absolutely inside
/home/[yourID]/.thunderbird[randomStuff].default/Mail

you might consider trying to find a real Thunderbird guru…maybe in a
forum on mozilla.org


dd http://tinyurl.com/DD-Caveat

Sorry for so slow replying dd … day from hell!

My thunderbird profile isn’t in the default location, about the only thing of relevance in the .mozilla folder is the profiles.ini file giving the profile path which is a folder I keep in ~/bin (several of the folders in my home dir are bind mounts, bin being one of them), but I’d also tried a ‘fresh’ profile

Issues aren’t limited to thunderbird now though, couple of other apps also started misbehaving notably ktorrent & kvirc. kvirc has started leaving artefacts if I move any windows around,ktorrent started taking forever to ‘draw’. Thought it was begnning to seem more x-related and a look in ~.xsession-errors shows what seems an awful lot of entries

I did recently have a displayport to dvi adaptor go bad on me so I had to go from 3 monitors to 2 until I get another adaptor and I had previously used the ‘Save as default’ option in systemsettings > display & monitor so I wouldn’t have to keep redoing my three screen setup, got a feeling it’s related, or at least not helping (I’m using the opensource graphics driver as I couldn’t get 3 monitors working with fglrx)

I’ll be back on 3 screens in the next day or two so I’ll see what happens then, recreate the user if necessary, let ya know what happens

Bit of an update, done some fiddling and got the desktop on both screens back to ‘default’, default backgrounds, cloned default layout, ‘matching’ resolutions etc, at this point thunderbird and ktorrent ran as normal

Logged out and then logged back in

Set the backgrounds to two that I downloaded and resolutions to the max each monitor takes (1920x1080 and 1680x1050), set the dvi monitor to be ‘right of’ the hdmi monitor, thunderbird and ktorrent still running ok

Logged out and then logged back in

Set the second screen to search and launch instead of default desktop layout, and this is when the problem reappeared

Something about the setup doesn’t seem to wanna work with search & launch, but the curious thing is, when I had the three monitors two of them were using the search & launch layout without any issues whatsoever

I think I will try the fglrx driver whilst I’m still on two screens and test whether I still get the same issue with one screen set as the search & launch layout … but that’ll be tomorrow now as I need sleep

On 2012-12-10 13:16, Ecky wrote:
> All I can do at that point is kill thunderbird and if I’ve run it from
> konsole I see the message given below:
>
>
>
> Code:
> --------------------
> mail.provider ERROR Something went wrong loading the provider list JSON file. Going into offline mode
> --------------------

There should be 4 .json files in the thunderbird folder:
search-metadata.json, search.json, folderTree.json, session.json. One of
those may be bad.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

On 12/11/2012 10:06 PM, Ecky wrote:
> let ya know what happens

no need to let me know what happens…i’m not very good at guessing
what kind of file or graphics system set up there…

so i’ll exit this thread and let the more clairvoyant here help.


dd

Sorted now anyway