Problem on "Software management" KDE

I installed SUSE 11.0 Live CD medium. Everything goes well. I could not find gcc (after command $which gcc). Therefore i managed to check the software package on the machine via “Software management”. In the mean time to start “Software management”, i got error message
“cannot access installation media (Medium 1) Check whether the server is accessible”.
My machine is offline, i do not know which server it mentions to.
Then i skip the error, but i still cannot add or remove any software package.

Could anyone please help me?

Get it to say that again and click details and tell us which server is offline

To swerdna
I am sorry to make something unclear. I just mean my machine has no internet access.
The error message i got is
“cannot access installation media (Medium 1) Check whether the server is accessible”.

I do not know what is the server it mentioned to. Then i tried to access the internet via lan in my university. When I tried to edit the internet option, I also get the similar error message
“cannot access installation media (Medium 1)”
and finally cannot get my machine to internet.

But the internet access is not my aim, i just want to be able to add some softwares i need to my SUSE machine.

Any suggestion? Thank you in advance.

OK, have a look in Yast → Software → Software repositories. Uncheck (the x) for any in the list that need the internet. that will leave you only with your installation CD/DVD. Make sure that one is active (does have an x). Then try the software you wnt to install via Yast → Software → software management.

And put your installation CD into the drive :wink:

Thank you very much for your helps. I will try, everythings should be OK now.