Problem on KDE: Leave/Lock button

I seem to be having a “drawing” problem in terms of the leave/lock button in KDE 4.3.5 with openSUSE 11.2. That button seems to have drawn far beyond where it should draw. This is a screenshot of the lower right of the screen where the button is located: Google Docs

This only occurs with the one non-root account. It also disappears if I open Yast! or Desktop Settings but then reappears after I close it. I tried deleting the entire .kde4 folder in case it was a configuration problem but that didn’t work. I installed openSUSE months ago but have only been having this problem for the past few weeks.

Also, if it makes any difference, I have also had wireless network issues under this account starting at around the same time (not precisely the same time, but within the same day or a few days) which I may have resolved by deleting the .kde4 folder and re-configuring everything. The wireless issue was also non-existent in the root account.

Oh, and this really isn’t all that serious of an issue (the button) since the worst that it has been is a distraction. I can still easily remove it and just the leave button under the Kickoff menu (or I can just deal with the annoyance). However, in the case that this isn’t the only effect of something else that’s gone wrong, I would like to resolve it.

You imply that you have other logins where the issue is not there?! Is this correct?
If it is, then it seems to be user settings related, rather than a system issue with say QT.
Are you using any non-standard widgets in the account it troubles?

It’s possible to remove the main panel and install a new default one, have you tried it?
Main Panel - Windows Live

Maybe you would like to have a look at Systemsettings > Appearance > Icons > Advanced, and see what effect changing/playing around with the size for icons on the Panel has.

Nope, just the plain old default panel.

Yes I have.

That directly didn’t do anything. However, I decided to change the icon theme from Oxygen to the GNOME default and the problem was gone. I changed it back to Oxygen and the problem didn’t come back. So I guess that solves it. Unless for some reason, it decides to come back again after I reboot (can’t exactly do that at the moment).

If it does come back, I will reply back here. If I don’t reply in say by tomorrow, it’s probably gone for good.

Thanks for the help!

DO NOT ever log into a GUI as root! You can and will damage things.

Try creating a new test user account and see if it also shows the problem.

Nope, the problem’s definitely gone. As is the networking issue.

I still can’t see how I would damage things…unless I started messing around with stuff or something (which probably can’t be more than if I just used sudo or something). I went in for a minute or so and the most damage I could’ve probably done would be from running Yast.

Anyways, I’m pretty sure I didn’t do anything terrible as everything still seems normal and I know what not seeming normal is from the past (when I did screw up things on other distros. But I do have a new test user account as well.

So anyways, problem solved. Thanks for the help everyone.

If you browse a user directory logged in a root in a GUI it can change ownership of certain control files. This can make it so the user can no longer log in. There are numerous other problems that can happen also as well as potential exposing the machine to nefarious software. Just because you don’t see the problem does not mean there is not one. There is nothing that you can do logged into a root GUI that you can not do logged into a normal user GUI and becoming root temporarily.