problem on installing media codecs

I installed tumbleweed on my new ryzen 5 desktop, and trying to install the media codecs according to the sticky thread on this forum.
I get “Problem: nothing provides libwebp.so.7()(64bit)…” on most of them, so I can’t install them, because I can’t find it anywhere.I’m on 2018-05-02 snapshot, if that matters and had a fresh install.
Can someone help please?

Hi,

Please, tell us what you did.
Command and output. And repositories.
Use the “#” button in the tool bar of the post editor.

sorry, I thought it was a quite common problem.There you go:

zypper repos -d
Repository priorities are without effect. All enabled repositories share the same priority.

# | Alias                            | Name                                   | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                               | Service
--+----------------------------------+----------------------------------------+---------+-----------+---------+----------+--------+-----------------------------------------------------------------------------------+--------
1 | http-ftp.gwdg.de-615d23d8        | Packman Repository                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Tumbleweed/                    |        
2 | http-opensuse-guide.org-c4c7c46f | libdvdcss repository                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/                               |        
3 | openSUSE-20180410-0              | openSUSE-20180410-0                    | No      | ----      | ----    |   99     | rpm-md | hd:///?device=/dev/disk/by-id/usb-A-DATA_USB_Flash_Drive_679104c0af7048-0:0-part2 |        
4 | repo-debug                       | openSUSE-Tumbleweed-Debug              | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/tumbleweed/repo/oss/                           |        
5 | repo-non-oss                     | openSUSE-Tumbleweed-Non-Oss (20180501) | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.tumbleweed.boombatower.com/20180501/repo/non-oss/                 |        
6 | repo-oss                         | openSUSE-Tumbleweed-Oss (20180501)     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.tumbleweed.boombatower.com/20180501/repo/oss/                     |        
7 | repo-source                      | openSUSE-Tumbleweed-Source             | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/tumbleweed/repo/oss/                          |        
8 | repo-update                      | openSUSE-Tumbleweed-Update             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/                                   |        
 


and

sudo zypper install libdvdcss2 ffmpeg lame gstreamer-plugins-libav gstreamer-plugins-bad gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon vlc vlc-codecs flash-player flash-player-ppapi libxine2 libxine2-codecs
[sudo] password for root: 
Loading repository data...
Reading installed packages...
'lame' is already installed.
No update candidate for 'lame-3.100-1.1.x86_64'. The highest available version is already installed.
Resolving package dependencies...
5 Problems:
Problem: nothing provides libwebp.so.7()(64bit) needed by gstreamer-plugins-bad-1.12.5-4.4.x86_64
Problem: nothing provides libMagickWand-7.Q16HDRI.so.6()(64bit) needed by libxine2-1.2.9-133.8.x86_64
Problem: nothing provides libwebp.so.7()(64bit) needed by libavcodec57-3.4.2-6.2.x86_64
Problem: nothing provides libwebp.so.7()(64bit) needed by libavcodec57-3.4.2-2.2.x86_64
Problem: nothing provides libwebp.so.7()(64bit) needed by libavcodec57-3.4.2-2.2.x86_64

Problem: nothing provides libwebp.so.7()(64bit) needed by gstreamer-plugins-bad-1.12.5-4.4.x86_64
 Solution 1: do not install gstreamer-plugins-bad-1.12.5-4.4.x86_64
 Solution 2: break gstreamer-plugins-bad-1.12.5-4.4.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 


I said it’s a fresh installation of tumbleweed and adding media codecs is one of the first things I always do.Didn’t face a similar problem on installation on my old desktop.
Here is the conflict.txt rpovided from yast, after doing the “one click install” solution

#### YaST2 conflicts list - generated 2018-05-19 12:12:11 ####

nothing provides libwebp.so.7()(64bit) needed by gstreamer-plugins-bad-1.12.5-4.4.x86_64

    [x] do not install gstreamer-plugins-bad-1.12.5-4.4.x86_64

     ] break gstreamer-plugins-bad-1.12.5-4.4.x86_64 by ignoring some of its dependencies



nothing provides libwebp.so.7()(64bit) needed by libavcodec57-3.4.2-6.2.x86_64

    [x] do not install ffmpeg-3.4.2-6.2.x86_64

     ] break libavcodec57-3.4.2-6.2.x86_64 by ignoring some of its dependencies



nothing provides libwebp.so.7()(64bit) needed by libavcodec57-3.4.2-2.2.x86_64

    [x] do not install gstreamer-plugins-libav-1.12.5-29.1.x86_64

     ] break libavcodec57-3.4.2-2.2.x86_64 by ignoring some of its dependencies




#### YaST2 conflicts list END ###

I still didn’t switch my packages to packman through yast, because I get tons of others conflicts:P

#### YaST2 conflicts list - generated 2018-05-19 16:44:15 ####

problem with installed package libavcodec57-3.4.2-1.1.x86_64

     ] keep obsolete libavcodec57-3.4.2-1.1.x86_64

     ] Following actions will be done:
deinstallation of libavcodec57-3.4.2-1.1.x86_64
architecture change of libqt5-qtwebengine-5.10.1-3.1.x86_64 to libqt5-qtwebengine-5.10.1-3.1.i586
deinstallation of libopencv3_3-3.3.1-3.4.x86_64
architecture change of libQtAV1-1.12.0-1.6.x86_64 to libQtAV1-1.12.0-1.6.i586
deinstallation of k3b-18.04.0-1.1.x86_64
deinstallation of gegl-0_3-0.3.34-2.1.x86_64
architecture change of ffmpegthumbs-18.04.0-1.1.x86_64 to ffmpegthumbs-18.04.0-1.1.i586
architecture change of plasma5-addons-5.12.4-1.1.x86_64 to plasma5-addons-5.12.4-1.1.i586
deinstallation of messagelib-18.04.0-1.1.x86_64
deinstallation of libksieve-18.04.0-1.1.x86_64
architecture change of libKPimGAPICore5-18.04.0-1.1.x86_64 to libKPimGAPICore5-18.04.0-1.1.i586
deinstallation of kontact-18.04.0-1.1.x86_64
deinstallation of kio-extras5-18.04.0-1.1.x86_64
deinstallation of kdepim-runtime-18.04.0-1.1.x86_64
deinstallation of kdepim-addons-18.04.0-1.1.x86_64
deinstallation of akregator-18.04.0-1.1.x86_64
deinstallation of libdigikamcore5-5.9.0-1.2.x86_64
architecture change of kfilemetadata5-5.45.0-1.1.x86_64 to kfilemetadata5-5.45.0-1.1.i586
architecture change of libQtAVWidgets1-1.12.0-1.6.x86_64 to libQtAVWidgets1-1.12.0-1.6.i586
deinstallation of libKF5MailCommon5-18.04.0-1.1.x86_64
deinstallation of kmail-18.04.0-1.1.x86_64
deinstallation of akonadi-import-wizard-18.04.0-1.1.x86_64
deinstallation of pim-sieve-editor-18.04.0-1.1.x86_64
deinstallation of libKPimGAPITasks5-18.04.0-1.1.x86_64
architecture change of libKPimGAPIContacts5-18.04.0-1.1.x86_64 to libKPimGAPIContacts5-18.04.0-1.1.i586
deinstallation of libKPimGAPICalendar5-18.04.0-1.1.x86_64
deinstallation of showfoto-5.9.0-1.2.x86_64
deinstallation of digikam-5.9.0-1.2.x86_64
architecture change of libKF5Baloo5-5.45.0-1.1.x86_64 to libKF5Baloo5-5.45.0-1.1.i586
deinstallation of gwenview5-18.04.0-1.1.x86_64
architecture change of dolphin-part-18.04.0-1.1.x86_64 to dolphin-part-18.04.0-1.1.i586
architecture change of baloo5-widgets-18.04.0-1.1.x86_64 to baloo5-widgets-18.04.0-1.1.i586
architecture change of baloo5-tools-5.45.0-1.1.x86_64 to baloo5-tools-5.45.0-1.1.i586
architecture change of baloo5-kioslaves-5.45.0-1.1.x86_64 to baloo5-kioslaves-5.45.0-1.1.i586
architecture change of baloo5-file-5.45.0-1.1.x86_64 to baloo5-file-5.45.0-1.1.i586
deinstallation of mbox-importer-18.04.0-1.1.x86_64
deinstallation of libKPimImportWizard5-18.04.0-1.1.x86_64
deinstallation of plasma5-workspace-5.12.4-4.1.x86_64
deinstallation of plasma5-desktop-5.12.4-2.1.x86_64
architecture change of dolphin-18.04.0-1.1.x86_64 to dolphin-18.04.0-1.1.i586
architecture change of baloo5-imports-5.45.0-1.1.x86_64 to baloo5-imports-5.45.0-1.1.i586


problem with installed package libavdevice57-3.4.2-1.1.x86_64

     ] Following actions will be done:
deinstallation of libavdevice57-3.4.2-1.1.x86_64
deinstallation of libQtAV1-1.12.0-1.6.x86_64
deinstallation of libdigikamcore5-5.9.0-1.2.x86_64
deinstallation of libQtAVWidgets1-1.12.0-1.6.x86_64
deinstallation of showfoto-5.9.0-1.2.x86_64
deinstallation of digikam-5.9.0-1.2.x86_64
     ] keep obsolete libavdevice57-3.4.2-1.1.x86_64



problem with installed package libavfilter6-3.4.2-1.1.x86_64

     ] Following actions will be done:
deinstallation of libavfilter6-3.4.2-1.1.x86_64
deinstallation of libQtAV1-1.12.0-1.6.x86_64
deinstallation of ffmpegthumbs-18.04.0-1.1.x86_64
deinstallation of libdigikamcore5-5.9.0-1.2.x86_64
deinstallation of libQtAVWidgets1-1.12.0-1.6.x86_64
deinstallation of showfoto-5.9.0-1.2.x86_64
deinstallation of digikam-5.9.0-1.2.x86_64
     ] keep obsolete libavfilter6-3.4.2-1.1.x86_64



problem with installed package libavformat57-3.4.2-1.1.x86_64

     ] keep obsolete libavformat57-3.4.2-1.1.x86_64

     ] Following actions will be done:
deinstallation of libavformat57-3.4.2-1.1.x86_64
architecture change of libqt5-qtwebengine-5.10.1-3.1.x86_64 to libqt5-qtwebengine-5.10.1-3.1.i586
deinstallation of libopencv3_3-3.3.1-3.4.x86_64
architecture change of libQtAV1-1.12.0-1.6.x86_64 to libQtAV1-1.12.0-1.6.i586
architecture change of kfilemetadata5-5.45.0-1.1.x86_64 to kfilemetadata5-5.45.0-1.1.i586
deinstallation of k3b-18.04.0-1.1.x86_64
deinstallation of gegl-0_3-0.3.34-2.1.x86_64
architecture change of ffmpegthumbs-18.04.0-1.1.x86_64 to ffmpegthumbs-18.04.0-1.1.i586
architecture change of plasma5-addons-5.12.4-1.1.x86_64 to plasma5-addons-5.12.4-1.1.i586
deinstallation of messagelib-18.04.0-1.1.x86_64
deinstallation of libksieve-18.04.0-1.1.x86_64
architecture change of libKPimGAPICore5-18.04.0-1.1.x86_64 to libKPimGAPICore5-18.04.0-1.1.i586
deinstallation of kontact-18.04.0-1.1.x86_64
deinstallation of kio-extras5-18.04.0-1.1.x86_64
deinstallation of kdepim-runtime-18.04.0-1.1.x86_64
deinstallation of kdepim-addons-18.04.0-1.1.x86_64
deinstallation of akregator-18.04.0-1.1.x86_64
deinstallation of libdigikamcore5-5.9.0-1.2.x86_64
architecture change of libQtAVWidgets1-1.12.0-1.6.x86_64 to libQtAVWidgets1-1.12.0-1.6.i586
architecture change of libKF5Baloo5-5.45.0-1.1.x86_64 to libKF5Baloo5-5.45.0-1.1.i586
deinstallation of gwenview5-18.04.0-1.1.x86_64
architecture change of dolphin-part-18.04.0-1.1.x86_64 to dolphin-part-18.04.0-1.1.i586
deinstallation of digikam-5.9.0-1.2.x86_64
architecture change of baloo5-widgets-18.04.0-1.1.x86_64 to baloo5-widgets-18.04.0-1.1.i586
architecture change of baloo5-tools-5.45.0-1.1.x86_64 to baloo5-tools-5.45.0-1.1.i586
architecture change of baloo5-kioslaves-5.45.0-1.1.x86_64 to baloo5-kioslaves-5.45.0-1.1.i586
architecture change of baloo5-file-5.45.0-1.1.x86_64 to baloo5-file-5.45.0-1.1.i586
deinstallation of libKF5MailCommon5-18.04.0-1.1.x86_64
deinstallation of kmail-18.04.0-1.1.x86_64
deinstallation of akonadi-import-wizard-18.04.0-1.1.x86_64
deinstallation of pim-sieve-editor-18.04.0-1.1.x86_64
deinstallation of libKPimGAPITasks5-18.04.0-1.1.x86_64
architecture change of libKPimGAPIContacts5-18.04.0-1.1.x86_64 to libKPimGAPIContacts5-18.04.0-1.1.i586
deinstallation of libKPimGAPICalendar5-18.04.0-1.1.x86_64
deinstallation of showfoto-5.9.0-1.2.x86_64
deinstallation of plasma5-workspace-5.12.4-4.1.x86_64
deinstallation of plasma5-desktop-5.12.4-2.1.x86_64
architecture change of dolphin-18.04.0-1.1.x86_64 to dolphin-18.04.0-1.1.i586
architecture change of baloo5-imports-5.45.0-1.1.x86_64 to baloo5-imports-5.45.0-1.1.i586
deinstallation of mbox-importer-18.04.0-1.1.x86_64
deinstallation of libKPimImportWizard5-18.04.0-1.1.x86_64


problem with installed package libavresample3-3.4.2-1.1.x86_64

     ] Following actions will be done:
deinstallation of libavresample3-3.4.2-1.1.x86_64
deinstallation of libQtAV1-1.12.0-1.6.x86_64
deinstallation of ffmpegthumbs-18.04.0-1.1.x86_64
deinstallation of libdigikamcore5-5.9.0-1.2.x86_64
deinstallation of libQtAVWidgets1-1.12.0-1.6.x86_64
deinstallation of showfoto-5.9.0-1.2.x86_64
deinstallation of digikam-5.9.0-1.2.x86_64
     ] keep obsolete libavresample3-3.4.2-1.1.x86_64



problem with installed package libavutil55-3.4.2-1.1.x86_64

     ] Following actions will be done:
install libavutil55-3.4.2-6.2.x86_64 (with vendor change)
  openSUSE  -->  http://packman.links2linux.de
deinstallation of gegl-0_3-0.3.34-2.1.x86_64
architecture change of libqt5-qtwebengine-5.10.1-3.1.x86_64 to libqt5-qtwebengine-5.10.1-3.1.i586
deinstallation of libopencv3_3-3.3.1-3.4.x86_64
architecture change of kfilemetadata5-5.45.0-1.1.x86_64 to kfilemetadata5-5.45.0-1.1.i586
deinstallation of k3b-18.04.0-1.1.x86_64
architecture change of libQtAV1-1.12.0-1.6.x86_64 to libQtAV1-1.12.0-1.6.i586
architecture change of ffmpegthumbs-18.04.0-1.1.x86_64 to ffmpegthumbs-18.04.0-1.1.i586
architecture change of plasma5-addons-5.12.4-1.1.x86_64 to plasma5-addons-5.12.4-1.1.i586
deinstallation of messagelib-18.04.0-1.1.x86_64
deinstallation of libksieve-18.04.0-1.1.x86_64
architecture change of libKPimGAPICore5-18.04.0-1.1.x86_64 to libKPimGAPICore5-18.04.0-1.1.i586
deinstallation of kontact-18.04.0-1.1.x86_64
deinstallation of kio-extras5-18.04.0-1.1.x86_64
deinstallation of kdepim-runtime-18.04.0-1.1.x86_64
deinstallation of kdepim-addons-18.04.0-1.1.x86_64
deinstallation of akregator-18.04.0-1.1.x86_64
deinstallation of libdigikamcore5-5.9.0-1.2.x86_64
architecture change of libKF5Baloo5-5.45.0-1.1.x86_64 to libKF5Baloo5-5.45.0-1.1.i586
deinstallation of gwenview5-18.04.0-1.1.x86_64
architecture change of dolphin-part-18.04.0-1.1.x86_64 to dolphin-part-18.04.0-1.1.i586
deinstallation of digikam-5.9.0-1.2.x86_64
architecture change of baloo5-widgets-18.04.0-1.1.x86_64 to baloo5-widgets-18.04.0-1.1.i586
architecture change of baloo5-tools-5.45.0-1.1.x86_64 to baloo5-tools-5.45.0-1.1.i586
architecture change of baloo5-kioslaves-5.45.0-1.1.x86_64 to baloo5-kioslaves-5.45.0-1.1.i586
architecture change of baloo5-file-5.45.0-1.1.x86_64 to baloo5-file-5.45.0-1.1.i586
architecture change of libQtAVWidgets1-1.12.0-1.6.x86_64 to libQtAVWidgets1-1.12.0-1.6.i586
deinstallation of libKF5MailCommon5-18.04.0-1.1.x86_64
deinstallation of kmail-18.04.0-1.1.x86_64
deinstallation of akonadi-import-wizard-18.04.0-1.1.x86_64
deinstallation of pim-sieve-editor-18.04.0-1.1.x86_64
deinstallation of libKPimGAPITasks5-18.04.0-1.1.x86_64
architecture change of libKPimGAPIContacts5-18.04.0-1.1.x86_64 to libKPimGAPIContacts5-18.04.0-1.1.i586
deinstallation of libKPimGAPICalendar5-18.04.0-1.1.x86_64
deinstallation of showfoto-5.9.0-1.2.x86_64
deinstallation of plasma5-workspace-5.12.4-4.1.x86_64
deinstallation of plasma5-desktop-5.12.4-2.1.x86_64
architecture change of dolphin-18.04.0-1.1.x86_64 to dolphin-18.04.0-1.1.i586
architecture change of baloo5-imports-5.45.0-1.1.x86_64 to baloo5-imports-5.45.0-1.1.i586
deinstallation of mbox-importer-18.04.0-1.1.x86_64
deinstallation of libKPimImportWizard5-18.04.0-1.1.x86_64
     ] keep obsolete libavutil55-3.4.2-1.1.x86_64



problem with installed package libgstgl-1_0-0-1.12.5-1.1.x86_64

     ] install libgstgl-1_0-0-1.12.5-4.4.x86_64 (with vendor change)
  openSUSE  -->  http://packman.links2linux.de

     ] keep obsolete libgstgl-1_0-0-1.12.5-1.1.x86_64



problem with installed package libgstphotography-1_0-0-1.12.5-1.1.x86_64

     ] install libgstphotography-1_0-0-1.12.5-4.4.x86_64 (with vendor change)
  openSUSE  -->  http://packman.links2linux.de

     ] keep obsolete libgstphotography-1_0-0-1.12.5-1.1.x86_64



problem with installed package libpostproc54-3.4.2-1.1.x86_64

     ] Following actions will be done:
deinstallation of libpostproc54-3.4.2-1.1.x86_64
deinstallation of libQtAV1-1.12.0-1.6.x86_64
deinstallation of ffmpegthumbs-18.04.0-1.1.x86_64
deinstallation of libdigikamcore5-5.9.0-1.2.x86_64
deinstallation of libQtAVWidgets1-1.12.0-1.6.x86_64
deinstallation of showfoto-5.9.0-1.2.x86_64
deinstallation of digikam-5.9.0-1.2.x86_64
     ] keep obsolete libpostproc54-3.4.2-1.1.x86_64



problem with installed package libquicktime0-1.2.4cvs20150223-13.1.x86_64

     ] install libquicktime0-1.2.4cvs20150223-15.1.x86_64 (with vendor change)
  openSUSE  -->  http://packman.links2linux.de

     ] keep obsolete libquicktime0-1.2.4cvs20150223-13.1.x86_64



problem with installed package libsox3-14.4.2-5.1.x86_64

     ] install libsox3-14.4.2-7.5.x86_64 (with vendor change)
  openSUSE  -->  http://packman.links2linux.de

     ] keep obsolete libsox3-14.4.2-5.1.x86_64



problem with installed package libswresample2-3.4.2-1.1.x86_64


…“The text that you have entered is too long (15373 characters). Please shorten it to 15000 characters long.”
Can I get some help now please?

I do not have any problem. For me all works.
Try “zypper -vvv dup --from 1”

Hi
I would suggest getting to the latest snapshot first 2018-05-17 via a zypper dup, then look at switching to the packman repository via the command given by user another_roadrunner.

Since packman will follow Tumbleweed rebuilds it’s highly likely that since your on an old snapshot the newer builds are not on your system to satisfy dependencies…

5 | repo-non-oss                     | openSUSE-Tumbleweed-Non-Oss (20180501) | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.tumbleweed.boombatower.com/20180501/repo/non-oss/                 |        
6 | repo-oss                         | openSUSE-Tumbleweed-Oss (20180501)     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.tumbleweed.boombatower.com/20180501/repo/oss/  

Why these URLs?

forgot to mention, I use boombatower(https://github.com/boombatower/tumbleweed-cli) to switch snaps , that’s why I’m still on 2018-05-02 snap, because according to http://review.tumbleweed.boombatower.com/, it’s the latest most stable one.I used this way of updating on my older desktop and tumbleweed was really rock stable.Dunno, if there is a better and safer way to switch between snaps, since this worked for me so far
I also tried what another_roadrunner suggest and that’s the result:

sudo zypper -vvv dup --from 1
[sudo] password for root: 
Verbosity: 3
Initializing Target
Checking whether to refresh metadata for Packman Repository
Retrieving: http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Tumbleweed/repodata/repomd.xml .............................................................................................................................[done]
Checking whether to refresh metadata for libdvdcss repository
Retrieving: http://opensuse-guide.org/repo/openSUSE_Tumbleweed/repodata/repomd.xml ........................................................................................................................................[done]
Checking whether to refresh metadata for openSUSE-Tumbleweed-Non-Oss (20180501)
Retrieving: http://download.tumbleweed.boombatower.com/20180501/repo/non-oss/repodata/repomd.xml ..........................................................................................................................[done]
Retrieving: http://download.tumbleweed.boombatower.com/20180501/repo/non-oss/media.1/media ................................................................................................................................[done]
Checking whether to refresh metadata for openSUSE-Tumbleweed-Oss (20180501)
Retrieving: http://download.tumbleweed.boombatower.com/20180501/repo/oss/repodata/repomd.xml ..............................................................................................................................[done]
Retrieving: http://download.tumbleweed.boombatower.com/20180501/repo/oss/media.1/media ....................................................................................................................................[done]
Checking whether to refresh metadata for openSUSE-Tumbleweed-Update
Retrieving: http://download.opensuse.org/update/tumbleweed/repodata/repomd.xml ..................................................................................................................................[done (371 B/s)]
Loading repository data...
Reading installed packages...
Computing distribution upgrade...
Force resolution: No
14 Problems:
Problem: problem with installed package libavresample3-3.4.2-1.1.x86_64
Problem: problem with installed package libavfilter6-3.4.2-1.1.x86_64
Problem: problem with installed package libavformat57-3.4.2-1.1.x86_64
Problem: problem with installed package sox-14.4.2-5.1.x86_64
Problem: problem with installed package libavcodec57-3.4.2-1.1.x86_64
Problem: problem with installed package libpostproc54-3.4.2-1.1.x86_64
Problem: problem with installed package libavutil55-3.4.2-1.1.x86_64
Problem: problem with installed package libswscale4-3.4.2-1.1.x86_64
Problem: problem with installed package libswresample2-3.4.2-1.1.x86_64
Problem: problem with installed package libavdevice57-3.4.2-1.1.x86_64
Problem: problem with installed package libsox3-14.4.2-5.1.x86_64
Problem: problem with installed package libgstgl-1_0-0-1.12.5-1.1.x86_64
Problem: problem with installed package libgstphotography-1_0-0-1.12.5-1.1.x86_64
Problem: problem with installed package libquicktime0-1.2.4cvs20150223-13.1.x86_64

Problem: problem with installed package libavresample3-3.4.2-1.1.x86_64
 Solution 1: Following actions will be done:
  deinstallation of libavresample3-3.4.2-1.1.x86_64
  deinstallation of libQtAV1-1.12.0-1.6.x86_64
  deinstallation of ffmpegthumbs-18.04.0-1.1.x86_64
  deinstallation of libQtAVWidgets1-1.12.0-1.6.x86_64
  deinstallation of libdigikamcore5-5.9.0-1.2.x86_64
  deinstallation of digikam-5.9.0-1.2.x86_64
  deinstallation of showfoto-5.9.0-1.2.x86_64
 Solution 2: keep obsolete libavresample3-3.4.2-1.1.x86_64

Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 

But Packman’s packages are only built against the latest snapshot. (and libvpx has been upgraded from libvpx5 to libvpx7, hence your problem)

So either upgrade to the latest snapshot, or forget about Packman and additional multimedia codecs.
MPEG 1/2 (and MP3) support is included in the standard distribution since a couple of months btw.

I’ll give it a try then.May be this was the way I did it on my latest installation and just forgot it.Guess I’m getting old:disapointed:

Well, it may work fine for some time.
But you’ll get into trouble when some important package gets a major upgrade in the distribution, like libvpx5 -> libvpx7 in this case, because Packman’s package will start to depend on the upgrade.

Oops, sorry.
I mean libwebp6 -> libwebp7 of course.

Although, a libvpx upgrade (e.g. libvpx4 -> libvpx5) can cause similar conflicts… :wink:

wolfi323 it worked just fine;) Thanks a lot mate and malcolmlewis too, that mentioned the same solution before, but I didn’t pay so much attention(sorry).
I think, that now that the codecs are installed I can use the safe choice of boombatower to update in the future.I feel so stupid though I didn’t go the straightforward way from the beginning:(

Sure, that should work.

You probably will not be able to install (some) updates from Packman though until you update to a newer snapshot, if they start to require things that didn’t exist yet at that time.

That’s fine with me, it worked this way for months on my old pc.I personally prefer more stability than latest updates;)Thanks again mate for showing the obvious solution, I couldn’t see:)

if you want stability why not install LEAP?
TW is a stable rolling distro one snapshot is not much better then the other if a bug is found it’s fixed in the next snapshot keeping an old TW snapshot is beyond silly you don’t even get security updates

I was on leap, for a few years and had no problem. I switched to tumbleweed, mostly because of the kernel support for my new ryzen desktop, and it’s as stable as leap, plus all the other positives, imo
I didn’t say I don’t update for long mate. I just wait a few days to choose the less buggy one. Delaying an update for 1-2 weeks doesn’t make my system much outdated or vulnerable, but it makes it more stable than getting the latest snap as soon as it’s released, imo.
Anyway, that’s my “problem”, and even if you think it’s a “silly” way, it works fine for me on my laptop for over a year (I also dual boot Arch on it, and handle it the same way, for about 5 years)
Thanks for your opinion though

Hi,

It seems that boombatower it is not an openSUSE official mirror.
https://lists.opensuse.org/opensuse-factory/2018-05/msg00264.html.

My opinion: stay with an official openSUSE mirror. If you want so, upgrade few days after a snapshot appear (while watching openSUSE forum and factory mailing list).
BTW, I have a Ryzen too. I use TW for few months now and no problems so far (except one or two with nvidia driver).

Hope that helps

I’m pretty sure, that tumbleweed-cli, works like a script, that targets to official mirrors. I agree, it’s not the official way to update, but it’s far easier and more manageable.
You can check the official announcement :https://lists.opensuse.org/opensuse-factory/2016-12/msg00025.html
Things got better after all that time. I mentioned on my previous post, that I use this way for over a year on my laptop and it’s rock stable.

Ok.
Do it as you are accustomed to.
Anyway, TW is a great distro and is rock stable.

PS. I did not think that you are getting old. If “75” means your year of birth, I am a little older than you. :slight_smile: