problem of optirun and bumbeeble


I’ve installed bumbeelbe following instruction on page:

However, the depository is not avaible, and I added the following two:



I used command

zypper in dkms dkms-nvidia-bumblebee dkms-bbswitch bumblebee primus x11-video-nvidia

There is no dkms-nvidia, and I installed “dkms-nvidia-bumblebee” instead.

However, when I tried to run some program with optirun, it always failed with messages:

Xlib:  extension "GLX" missing on display ":8".
OpenGL GLX extension not supported by display ':0'
Info) [0] Quadro K1100M       2 SM_3.0 @ 0.71 GHz, 2.0GB RAM, KTO, OIO, ZCP
Warning) Detected X11 'Composite' extension: if incorrect display occurs
Warning) try disabling this optional X server feature.
Xlib:  extension "GLX" missing on display ":8".
ERROR) The X server does not support the OpenGL GLX extension. 

Here is more informations:

dreamy:/home/albert # lspci | grep -E "VGA|3D"
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
02:00.0 3D controller: NVIDIA Corporation GK107GLM [Quadro K1100M] (rev ff)

dreamy:/home/albert #  zypper se -si nvidia
Loading repository data...
Reading installed packages...

S | Name                   | Type    | Version     | Arch   | Repository                        
i | dkms-nvidia-bumblebee  | package | 331.38-11.1 | x86_64 | home:Knurpht:dkms-nvidia-bumblebee
i | x11-video-nvidia       | package | 331.49-2.1  | x86_64 | home:Knurpht:dkms-nvidia-bumblebee
i | x11-video-nvidia-32bit | package | 331.49-2.1  | x86_64 | home:Knurpht:dkms-nvidia-bumblebee

/home/albert> cat /proc/acpi/bbswitch
0000:02:00.0 OFF
/home/albert> systemctl status bumblebeed
bumblebeed.service - Bumblebee C Daemon
   Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled)
   Active: active (running) since Wed 2014-05-21 22:00:46 CEST; 41s ago
 Main PID: 1863 (bumblebeed)
   CGroup: /system.slice/bumblebeed.service
           └─1863 /usr/sbin/bumblebeed

dreamy:/home/albert # cat /etc/bumblebee/xorg.conf.nvidia
Section "ServerLayout"
    Identifier  "Layout0"
    Option      "AutoAddDevices" "false"
    Option      "AutoAddGPU" "false"

Section "Device"
    Identifier  "DiscreteNvidia"
    Driver      "nvidia"
    VendorName  "NVIDIA Corporation"

#   If the X server does not automatically detect your VGA device,
#   you can manually set it here.
#   To get the BusID prop, run `lspci | egrep 'VGA|3D'` and input the data
#   as you see in the commented example.
#   This Setting may be needed in some platforms with more than one
#   nvidia card, which may confuse the proprietary driver (e.g.,
#   trying to take ownership of the wrong device). Also needed on Ubuntu 13.04.
#   BusID "PCI:01:00:0"

#   Setting ProbeAllGpus to false prevents the new proprietary driver
#   instance spawned to try to control the integrated graphics card,
#   which is already being managed outside bumblebee.
#   This option doesn't hurt and it is required on platforms running
#   more than one nvidia graphics card with the proprietary driver.
#   (E.g. Macbook Pro pre-2010 with nVidia 9400M + 9600M GT).
#   If this option is not set, the new Xorg may blacken the screen and
#   render it unusable (unless you have some way to run killall Xorg).
    Option "ProbeAllGpus" "false"

    Option "NoLogo" "true"
    Option "UseEDID" "false"
    Option "UseDisplayDevice" "none"

thank you very much

could someone give me some helps?

I don’t know how to solve the problme.

thx a lot

Don’t mix repos like that, besides the packages in Knurpths repo have different versions. Uninstall all nvidia related and disable Knurpths repo, then install the nvidia-bumblebee and nvidia-bumblebee-32bit packages from the X11:Bumblebee repo. In addition you’ll probably have to add the line “blacklist nouveau” to /etc/modprobe.d/50-blacklist.conf and run the command mkinitrd.

thanks a lot.

finally it works again.rotfl!