problem=> mouse stucks

hi everybody,
yesterday I installed opensuse 11.1 !
but already while installation i couldnt move my mouse anymore, keyboard worked.
so i restarted the installation and everything was ok.
but the problem still exists…
after 1 to 30 minutes, using opensuse 11.1 my mouse gets stuck but the keyboard works.
2nd strange thing:
I am able to shutdown my pc normally, if my mouse hasnt got stuck yet.
but as soon as i cant move the mouse anymore and I try to shutdown the pc by using the keyboard, it crashes!
plz help me… thank you for reading that

Please, a bit more info on your system.

Did you try other mice? They don’t live forever…

yes, i tried 3 other mice!
razer copperhead
logitech mx 518
standard logitech optical wheel mouse
always the same problem.
i never had these difficulties on other os before.
my hardware:
core 2 duo e6600c4
geforce 7900gtx xt
2 gig corsair ddram
asus p5nsli mainboard

since three different mice returned the SAME problem, then it is not a
mouse problem, at least not from the mouse in your hand, to the plug
in the computer (huh?)…

could be other hardware, or software, or software setup (huh?)

things to try:

-disable or remove beagle

-turn off compiz and/or desktop effects

-if using ATI or Nvidia graphics: switch to the closed source driver…

-check that your motherboard and CPU has sufficient cooling air flow
(vacuum out the cat hair, etc)

-have you added hard drives (or etc) and overtaxed the power supply
unit, heat sinks and fans? most systems are sold with JUST ENOUGH
power supply and system cooling to do the needed job for the hardware
sold in the box…add something and you come close to exceeding the
units power/cooling capability you have…

-run memtest


duo

its not the plugs fault.
as is said, it worked fine on other os.
motherboard and cpu temperature is fine (today i cleaned the cooler). nothing is overtaxed.
i didnt do any software changes, just formatted my harddisk and set up the os, nothing else.
i even changed my harddisk, to test if i still got problems.
im wondering, why this bug appears from 1 min to even 1 hour after i start my pc, seems quite strange to me.

> im wondering, why this bug appears from 1 min to even 1 hour after i
> start my pc, seems quite strange to me.

when the mouse stops responding, if you just let it sit for (say) 10
minutes and then try it, does it work then?

did you remove or disable beagle yet?

open a terminal, type in top and press enter, arrange your
desktop so that you can SEE the terminal, then when the mouse freezes,
grab a pencil and paper and write down the top five things using your
system…

did you read and follow all the directions to make sure you used good
install media? (did you check the md5sum prior to burning the DVD?)
see: http://tinyurl.com/6jwtg9


Conficter

I have had two similar hangs after upgrading to 11.1 & KDE4.

The mouse cursor moves, but clicking on buttons/windows has no effect. The X server is still running, app windows display their contents and I can alt-tab between apps. While clicks are detected ( for example, by mplayer which complains and ignores them), neither buttons nor windows get focus.

Rebooting (since you can’t click on the little KDE logout thingie) clear the problem. Not much of a bug report, I know. Just another data point.

opensuse 11.1
KDE4
nvidia binary driver
compositing & desktop effects off.

There is another thread on this problem. The workaround I use is to cntrl-alt-f1 to get the text console, login and kill the window with focus. Sometimes it is the desktop that has focus so you need to logout. cntrl-alt-delete in gnome pops up the logout menu and hitting enter causes the default logout action.