Problem mounting share on my router

On my TW KDE system I am unable to access or mount a share which is defined on my router unless I force CIFS to use vers=1.0 on the mount command. Is there any way to get my system to default to v1.0 for both mounting by command an using Samba. I tried clientmin protpcol set to SMB1 in the smb.conf but testparm shows it is ignored. The annoying thing is that I can access it on Windows 7 without issue and without any additional parameters.


Just to add the output for smbclient

smbclient -d4 -L //
lp_load_ex: refreshing parameters                                                                                                                                                                         
Initialising global parameters                                                                                                                                                                            
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)                                                                                                                                 
Processing section "[global]"                                                                                                                                                                             
doing parameter workgroup = DISORGANISATION                                                                                                                                                               
doing parameter netbios name = TUMBLEWEED                                                                                                                                                                 
doing parameter server string = "Deskctop PC"                                                                                                                                                             
doing parameter local master = yes                                                                                                                                                                        
doing parameter preferred master = yes                                                                                                                                                                    
doing parameter os level = 85                                                                                                                                                                             
doing parameter passdb backend = tdbsam                                                                                                                                                                   
doing parameter map to guest = Bad User                                                                                                                                                                   
doing parameter usershare allow guests = No                                                                                                                                                               
doing parameter client ipc max protocol = CORE                                                                                                                                                            
doing parameter ldap admin dn =                                                                                                                                                                           
doing parameter wins server =                                                                                                                                                                             
doing parameter wins support = No                                                                                                                                                                         
pm_process() returned Yes                                                                                                                                                                                 
added interface enp5s0 ip= bcast= netmask=                                                                                                                           
Client started (version 4.7.5-git.37.6d30796c515SUSE-oS15.5-x86_64).
Connecting to at port 445
 session request ok
 negotiated dialect[NT1] against server[]
 session setup ok
Enter DISORGANISATION\stuart's password: 
Server requested LANMAN password (share-level security) but 'client lanman auth = no' or 'client ntlmv2 auth = yes'
tree connect failed: NT_STATUS_ACCESS_DENIED


So on the client machine edit /etc/samba/smb.conf in the [global] options for this;

Server requested LANMAN password (share-level security) but 'client lanman auth = no' or 'client ntlmv2 auth = yes'

On my system I use;

client use spnego = no
client ntlmv2 auth = no

I would guess you need;

client lanman auth = yes
client ntlmv2 auth = no

Well I added your guess and for good measure the spnego as well. Now smbclient works and the smb protocol from dolphin also accesses the shares OK. However I can only mount them using -o vers=1.0 with a mount cifs command, unless I force that it does not work, also mounting from SMB4K (my preferred way) does not work either. Quite why this is all a bit messy I don’t know. ZyXEL made a bad decision on how to configure Samba in their router as you cannot specify a workgroup.


As a workaround, you could put all the mounting options in a shell script, and call that to mount the share,

You might need to force with the ‘client min protocol’ directive in smb.conf (global section). For example

client min protocol = NT1

For more info

man smb.conf

I tried that but SMB4K still fails as does the mount command without specifying vers=1.0.