Problem mounting camera v13.1

oS v13.1x64, KDE
On same computer prior to install of v13.1 I was running v12.2 and no problem automounting usb devices. Now I can auto mount storage devices, both usb2 & usb3 but not other devices.

My camera shows up in configure desktop->hardware->digital camera and if I click on test is is ‘successful’. But it does not mount and device notifier shows “no devices available”.


 4522.733420] usb 1-1.1: USB disconnect, device number 19
 4534.692104] usb 1-1.1: new high-speed USB device number 20 using ehci-pci
 4534.777843] usb 1-1.1: New USB device found, idVendor=04b0, idProduct=0329
 4534.777847] usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
 4534.777860] usb 1-1.1: Product: NIKON DSC COOLPIX S4300-PTP
 4534.777862] usb 1-1.1: Manufacturer: NIKON
 4534.777864] usb 1-1.1: SerialNumber: 000030015973


/dev/disk/by-id/ata-ST31000524AS_5VPD6PXP-part5 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-ST31000524AS_5VPD6PXP-part6 /                    ext4       acl,user_xattr        1 1
/dev/disk/by-id/ata-ST31000524AS_5VPD6PXP-part7 /home                ext4       defaults              1 2


00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation H77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series/C210 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Turks PRO [Radeon HD 7570]
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Turks/Whistler HDMI Audio [Radeon HD 6000 Series]
02:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 07)

lsusb: (camera shows at device 020)

Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 020: ID 04b0:0329 Nikon Corp. 
Bus 001 Device 003: ID 0557:2008 ATEN International Co., Ltd UC-232A Serial Port [pl2303]
Bus 001 Device 004: ID 0cf3:e004 Atheros Communications, Inc. 
Bus 002 Device 006: ID 0461:4d81 Primax Electronics, Ltd Dell N889 Optical Mouse
Bus 002 Device 004: ID 413c:2107 Dell Computer Corp. 
Bus 002 Device 005: ID 058f:6362 Alcor Micro Corp. Flash Card Reader/Writer

And fdisk -l does not show the camera.

A thread from last year menioned fuse-gvfs

The tail of mount contains:

gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=100)
gvfsd-fuse on /var/run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=100)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)

Since this camera mounted in v12.2 and also my iphone & ipad mounted using v12.2 but not now under v13.1. Also, running Apple in a virtual machine, my ipad mounts to Apple OS so there is some kind of communication between the usb devices and the machine.

Since the camera is detected with lsusb and in device configuration I am left to believe there is something missing in my system regarding mounting devices.
Any ideas?

thanks, Jon

Since you didn’t have a problem with 12.2, you may have been caught out by a change in the default settings of /etc/usb_modeswitch.conf; try changing the line




and see if that works for you.


Thanks for the reply, unfortunately that didn’t work. I also see in that file that I can enable logging but since the device attaches (as indicated by the digital camera config) but does not mount I am not sure that the logging will be helpful.

Rgds, Jon

I note that your camera is reported as

 4534.777860] usb 1-1.1: Product: NIKON DSC COOLPIX S4300-PTP

From the specs I read from here

Nikon Coolpix 4300, four megapixel: Digital Photography Review

it is mentioned

Plug-and-play USB interface for smooth connection to a computer (USB Mass Storage Class or PTP)

Maybe you need to adjust your camera settings for ‘USB Storage Class’ (or similar), so that it is detected accordingly.

As things stand currently, Dolphin should also be able to communicate with the camera via ‘Camera:/’ (PTP protocol)

I’ll look into camera settings but I didn’t change any and it worked fine in v12.2. I can also say that my camera, iPad, & iPhone were visible in Dolphin under 12.2 and not 13.1

I need to investigate this Camera:/ as I am not familiar with that. Maybe that is what I need to get it fixed.

Thanks, Jon

The iPhone and iPad definitely do not get treated as storage devices, they utilize MTP/PTP (data transfer) protocols, but the notifier should work (as it does for me with openSUSE 12.2). I’m not sure what the notifier issue is with KDE in openSUSE 13.1, perhaps you’ve encountered a bug. The ‘camera:/’ (kamera-kio) for Dolphin should let you navigate the devices file systems (as if they were mounted as storage media), essentially disguising the fact that PTP communication protocol is really in use. Check that your notifier settings are set up as you’d expect (for removable devices).

Another thought I had - is this a clean install, or upgrade from 12.2? You might want to make sure that udisks2 package is installed.


This was an upgrade. udisk2 is installed, as is kio_camera & libgphoto2-6 (but not gphoto). If I can’t get anywhere I’ll install gphoto and see what happens but I hate to clutter up my system with software that I don’t need.

I’ll play around with the device notifier settings, but I know that I had no issues in v12.2 with any of these devices and I don’t recall ever needing to take any steps to get them working in v12.2, they just worked.

And it’s odd that the iPad is accessible in the Apple guest VM running on this machine.

I don’t see camera:/ anywhere in dolphin, I need to research what that means.

Thanks for the suggestions,

OK, camera:/ works. My Dolphin didn’t have a location bar displayed and once I turned that one I could enter camera:/

Oddly, it displays 2 instances for my camera, maybe that is because I tried usb3 once to see if that would work, even though I was sure it wouldn’t.

So I can now access my photo’s from dolphin which is want I wanted to do to begin with. However, it still doesn’t show in the device notifier like it did in v12.2

Thanks for the help, I still need to play with the notifier settings.



In device notifier this is what I have for Open with File Manager…Camera

kioclient exec camera:/
The device property Suppoted Drivers must contain gphoto
Type: Camera
Value name: Supported Drivers
Equals: gphoto

OK, I can see how maybe =gphoto is messing me up. But what to change it to? I tried supported protocols contains PTP and that didn’t work. But it’s a start.
Thanks, Jon

Mine is the same with respect to that (usingKDE 4.10). Is Device Notifier Settings >> Settings set with ‘Removable Devices’ (or ‘All Devices’), and check ‘Removable Devices’ options as well. If this all checks out, the please check that udisks2 is installed (as opposed to udisks)

rpm -qa|grep udisks

Arrgh! Forget that advice about udisks2. Only applies to storage media devices. We’re dealing with PTP/MTP devices… :slight_smile:


I’m using KDE 4.11.2

Settings is for Removable Devices only.

Removable Devices is set with Enable Auto Mounting and also Auto Mount when Attached.

What is NOT set is auto mount if manual mount before, and mount at login.

Also on Device Overrides, nothing is checked and the camera is not shown there.
The removable Devices section seems to relate only to mounting and you’ve established that PTP is not mounting like storage is (or at least that is how I understand it).

Also, I have installed gphoto and note that the list of cameras has “coolpix 4300” but not “coolpix S4300”. That said, the camera would open in Dolphin under v12.2 when I attached it.


Jon, try the following. Open a terminal and

solid-hardware listen

Plug in your camera and turn on. Note any output.

For reference, I get

Device Added:
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:1d.7/usb2/2-6'

With your camera attached, run

solid-hardware list details

and look for the output block corresponding to your Nikon camera (if any).

My camera model is not explicitly listed by gphoto2, but is still auto-detected

udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:1d.7/usb2/2-6'
  parent = '/org/kde/solid/udev'  (string)
  vendor = 'Canon Inc.'  (string)
  product = 'Canon Digital Camera'  (string)
  description = 'Camera'  (string)
  Block.major = 189  (0xbd)  (int)
  Block.minor = 137  (0x89)  (int)
  Block.device = '/dev/bus/usb/002/010'  (string)
  Camera.supportedProtocols = {'ptp'}  (string list)
  Camera.supportedDrivers = {'gphoto'}  (string list)


Nothing with list details nor with listen. I redirected the details output to a file that I can Suse Paste if you want to check me but it’s not there.

But it is shown in Digital Camera hardware System Settings:

 Manufacturer: Nikon Corporation
 Model: S4300 
   Version: COOLPIX S4300  V1.0
 Vendor Extension ID: 0xa (1.0)
 Vendor Extension Description: 1.0;

 Capture Formats: JPEG
 Display Formats: Association/Directory, Defined Type, JPEG, DPOF, MS AVI, Apple Quicktime, MS Wave

 Device Capabilities:
     File Download, File Deletion, File Upload
     Generic Image Capture, No Open Capture, No vendor specific capture
     Nikon Wifi support

 Storage Devices Summary:
     StorageDescription: S4300 
     VolumeLabel: None
     Storage Type: Removable RAM (memory card)
     Filesystemtype: Digital Camera Layout (DCIM)
     Access Capability: Read-Write
     Maximum Capability: 4000317440 (3815 MB)
     Free Space (Bytes): 4000088064 (3814 MB)
     Free Space (Images): 771

 Device Property Summary:
 Property 0xd407:(read only) (type=0x6) 1
 Property 0xd406:(readwrite) (type=0xffff) ''
 Property 0xd002:(readwrite) (type=0x6) Enumeration [1,2,3,4,5,6,7] value: 6
 Date & Time(0x5011):(readwrite) (type=0xffff) '20131129T194051'

 Flash Mode(0x500c):(readwrite) (type=0x4) Enumeration [1,2,3,4] value: Automatic flash (1)
 Focus Mode(0x500a):(readwrite) (type=0x4) Enumeration [2,3] value: Automatic (2)
 Focal Length(0x5008):(read only) (type=0x6) Enumeration [3500,4600,5300,6100,7300,8600,10500] value: 35 mm (3500)
 Battery Level(0x5001):(read only) (type=0x2) Enumeration [2,5,25,50,65,80,100] value: 100% (100)
 Property 0xd303:(read only) (type=0x2) 1

It also shows up in kinfocenter usb devices ehci host controller 1:

Manufacturer: NIKON
Serial #: 000030015973

 | *Class*|| ((Defined at Interface level))|
| *Subclass*|||
| *Protocol*|||
| *USB Version*| 2.00||
| *Vendor ID*| 0x4b0| (Nikon Corp.)|
| *Product ID*| 0x329||
| *Revision*| 0.00||
| *Speed*| 480 Mbit/s||
| *Channels*|||
| *Max. Packet Size*| 64||

Very odd…

Rgds, Jon

Somehow udev is not handling your camera as expected. I don’t know if this as simple as a rule change with new libgphoto2, or something else. You might want to consider submitting a bug report.

OK, thanks. I’ll wait a few days just in case someone else chimes in.
Do I need to register for making a report or can I just use my forum login?



Thanks for your post in bugzilla Bug 852551.

It fixed my problem.