Problem loading firewall

When I clicked on the firewall icon in Yast this morning, a new package asked to be installed, and when I tried to load the firewall after the install I get the message:

Trying to connect to firewalld, waiting

I have rebooted the machine, but the same thing happens. I need some help on this matter.

Dag R

What does the following report?

systemctl status firewalld

I think it’s not running:

dagr@opensuse:~> systemctl status firewalld
● firewalld.service - firewalld - dynamic firewall daemon
   Loaded: loaded (/usr/lib/systemd/system/firewalld.service; disabled; vendor preset: disabled)
   Active: inactive (dead)
     Docs: man:firewalld(1)

Ok, so enable the service and start it…

sudo systemctl start firewalld.service
sudo systemctl enable firewalld.service 

I don’t understand how this happened, but when I got the tip from you about status, I went to services and restarted the firewalld. Now it’s running fine.

Thanks a lot.

Dag R

Good. Happy to have been of help. :slight_smile:

I ran into the same problem after installing tumbleweed. I followed your advice and was then able to gain access to the firewall applet. Thank you.