Problem: libKF5KHtml5-lang-5.12.0-1.1.noarch requires libKF5KHtml5 = 5.12.0

Apparenty, the 64 bit version is not available yet. full message:


Problem: libKF5KHtml5-lang-5.12.0-1.1.noarch requires libKF5KHtml5 = 5.12.0, but this requirement cannot be provided
  uninstallable providers: libKF5KHtml5-5.12.0-1.1.i586[Main_OSS]
 Solution 1: keep obsolete libKF5KHtml5-lang-5.11.0-1.1.noarch
 Solution 2: install libKF5KHtml5-5.12.0-1.1.i586 despite the inferior architecture
 Solution 3: break libKF5KHtml5-lang-5.12.0-1.1.noarch by ignoring some of its dependencies

**Choose from above solutions by number or cancel [1/2/3/c] (c): 

**...

edward@openSUSE-Tumbleweed:~> zypper info libKF5KHtml5            
Loading repository data...
Reading installed packages...


Information for package libKF5KHtml5:
-------------------------------------
Repository: Main OSS
Name: libKF5KHtml5
Version: 5.11.0-1.1
Arch: x86_64
Vendor: openSUSE
Installed: Yes
Status: up-to-date
Installed Size: 8.0 MiB
Summary: HTML rendering engine
Description:  
  KHTML is a web rendering engine, based on the KParts
  technology and using KJS for JavaScript support.
edward@openSUSE-Tumbleweed:~> 



Has anyone else seen this? I checked the repository and it is indeed missing.

Yes, I ran into that.

I cancelled out, and then did “zypper up” (instead of “zypper dup”). And that updated lots of stuff. I assuming this will be fixed in the next few days.

On another Tumbleweed system, I did not see this. The system where I did not see it was one where I had not updated for the 20150712 snapshot. It looks as if there was something installed for 20150712 that caused the problem.

Was the other system 32 bit?

I also expect it to be fixed in the next few days.

This was all for 64-bit systems. I have not tried 32-bit Tumbleweed (and probably won’t).

The 43 bit library is there, only the 64 is missing (still today). The library is in the factory Frameworks 5 repository, though.

This was fixed in the latest snapshot.