Problem launching caffeine

I’m trying to install caffeine and after I install it, I cannot get it to launch. Trying to open from the desktop does nothing and trying to launch from konsole gives me.

ERROR:root:Could not find any typelib for Gtk
Traceback (most recent call last):
  File "/usr/bin/caffeine", line 40, in <module>
    import caffeine
  File "/usr/lib/python2.7/site-packages/caffeine/", line 22, in <module>
    from gi.repository import Gtk, Gio
ImportError: cannot import name Gtk

Any idea what I’m missing?
I’m running openSUSE 13.1 with a KDE4 shell.

How are you installing???

I tried the one click install here

It’s a GNOME application, not really designed for KDE…

That would cause some problems wouldn’t it? I should have caught that. Thanks!

It shouldn’t cause problems.

I cannot guarantee that it would work though.
But I think it should even on KDE. There are some cross-desktop standards in place… :wink:

You might also try this from the [noparse]KDE:Extra[/noparse] repo, this seems to be something similar:

But I haven’t tried this myself either.