Problem installing/upgrading to 11.1


I’m currently running openSuse 11.0, which works ok. I’d like to upgrade to 11.1, so I burned a DVD, boot from it. After the familiar green welcome screen, it crashes:

Starting udev … ok

Linuxrc crashed. :-((
Press enter to continue.

After pressing enter:

udevd[592]: bind failed: Address already in use

udevd[592]: error binding control socket, seems udevd is already running

Can somebody help me out?
HW: AMD Sempron™ Processor 3400+, 500 MB RAM.

Thank you.

At the menu select the media check to check the dvd is good. It takes a while so go get a brew.

Thank you for your suggestion. Unfortunately, at start of the check it crashes the same way. I did check the MD5 of the .iso which is OK. Other suggestions?

Do a check of the dvd
Md5sum of Burned CDs

If you mean that “Check Installation Media”, I did. That failed with a crash, directly after loading. Any other DVD check?

It’s not clear to me what EXACTLY is happening.

When you boot the dvd do you get to the menu and select the media check? Or does it fail before the menu?

What OS are you running an any / all your computers?

when I choose from the menu, it loads the kernel. After that it fails. I just ran the check on another computer, and found it doesn’t fail then. So there’s apparently some hardware-incompatibility with the first computer and the 11.1 kernel.

All computers run Unix/BSD/Linux. This is the only computer that runs openSuse.

Possibly. You could check the BIOS settings of the PC where you are experiencing the problem.

It could also be your CD/DVD reader/writer calibration is signficantly different between different hardware.

I’ve encountered many cases where a CD/DVD burned on a relatively new CD/DVD writer could not be read on an older CD/DVD reader, and visa versa. I also discovered if one burns the CD/DVD at a high speed, it can aggravate this incompatibility between readers/writers.

That is one reason why I purchase the Novell/SuSE-GmbH boxed DVD, as it is burned on a commercial burner, and tends to have this sort of problem less (than burning on a home burner) although even then it can occur.

Is it worth trying a Live CD?

Ok, a few comments after a new numbers of attempts.

After downloading the LiveCD I checked the md5sum and it is ok.

I burned the CD and boot the computer, and check the CD with Check Installation Media. It ends in terminal mode with the message that there is an md5sum error.

Then I burn the CD again, with another program. Then I go through everything once again, up to ending with the md5sum error.

Next I decide to start Gnome Live and at the point where the loading and checking of the video driver ends, it drops out of X server, into terminal mode. There the message tells me that GdmDisplay lasted for 2.46something seconds. I can login with root and run startx. That quits stating “Fatal server error: Cannot run in framerbuffer mode. Please specify busIDs.”.

So even though now the kernel doesn’t crash, it’s both X and a weird md5sum message that keeps me from running 11.1

I ha a similar behaviour from a PC of my mother’s when I went to install openSUSE-10.2 on it, a number of years back. It turns out her CD drive was so badly out of calibration, I could not get Linux to install, even though the CDs were good. In the end I purchased a replacement CD drive and openSUSE-10.2 installed easily.

I can’t say if that is what you are experiencing, but I do note that a CD drive can have difficulty with the burned CD, even if the CD is burned correctly.

Try this method of boot from cd

Installation Problem Suse 11 - openSUSE Forums

OK, “sax2 -r -m 0=vesa” gives the following:

initializing please wait…
no X-server is running
will start own server if needed

something went wrong when X was called with -probeonly
try to call “sax2 -p” and select a single device ?

> try to call “sax2 -p” and select a single device ?

and, when you did that what happened?

CAVEAT: The author of this posting does not warrant the accuracy,
completeness, legality, or usefulness of its content and is not
responsible for consequences resulting from its use.

and, when you did that what happened?

It says:

Chip: 0 is -> NVidia GeForce FX 5200 (0x0322) 01:00:0 0x10de 0x0322 AGP nv

Thats the same graphic device I have in my “sandbox PC”. It works well with Linux.

When you typed “sax2 -r -m 0=vesa” you did type “zero equals vesa” and not “Oh equals vesa” ?

“zero equals vesa” and not “Oh equals vesa” ?

Yes, just checked to be sure. Typed “zero equals vesa”.

Hmmm … I still think it could be the cd/dvd reader.


I’ve got the same error. And I can say it is not caused by the DVD or the DVD reader since I tried it first with a selfmade ISO-DVD and then again with a DVD from a magazine and got the same error every time.

Does anyone know more about it?


Why would that indicate it may not be the reader? In my mother’s PC case (which was a problem with her reader) I tried a few difference CDs (one being the commercially pressed one from the openSUSE-10.2 Novell boxed package), one being from a PC magazine, and one being one that I burned myself. All failed. In 2 out of 3 cases the error was the same.

When I replaced her CD drive with a new CD drive, the installation worked.

Now you may be correct, it may not be the reader, … but IMHO its premature to rule it out as a possibility.