problem installing the proprietary ATI driver

needless to say that I have little experience…

I’m trying to upgrade the driver from 10.9 to 10.10.
my first step was to unistall the older driver from /usr/share/ati I run the “sh ./”

then after rebooting in runlevel 3 (I hope I got this right!) I run the “sh ./”.
at this point I had an error saying

/usr/X11R6/lib64/modules/dri/ already existed

and that the file could not be created.
I gave the command “aticonfig --initial” without problems.

I can boot on the desktop but the driver is not correctly installed.

could you please point me in the right direction?
thanks in advance

…just as additional information, at the last kernel upgrade I followed this excellent guide


go to openSUSE 11.3 – proprietären Grafik-Treiber ATI Catalyst 10.10 als RPM installieren. He has a excellent script for install ATI Drivers. The site is in german.
You only have to download the script “”, chmod +x to make executable an run it as root
with the parameter -i. ( -i). After that you can call the script with -irs and from now on
the system makes automatic new kernel drivers if the kernel changes.
It really works perfect.


When building the propreitary ATI graphic driver, I have found it always best to first remove any exisiting rpm files with fglrx in the file name. Ultimately after the new rpm file is built (or simply downloaded) a new version of the fglrx rpm will be loaded.

Also, ensure that the version of kernel-source and kernel syms match the current kernel version on one’s PC.

Thanks guys! I’ll give it a go after work and I’ll let you know how it goes.

yesterday I re-installed 10.9 as 10.10 was not good and it worked no problem.

That could be because you still had the fglrx from 10.9 installed. Hence a fresh 10.9 install would be compatible with that fglrx rpm.

To install 10.10 you need to remove the 10.9 fglrx rpm first.

I assume from your words that if I remove the fglrx rpm the 10.10 package will install the correct fglrx rpm? or do I need to get it somewhere else? (sorry, maybe the question is silly but I have little experience)

I’ve always installed ‘the hardway’ which means installing from the ATI .run package, and not used the repository method. For the ‘hardway’ before building the rpm (which is what the .run package does) I first remove the old rpm with fglrx in the name. If you are asking about how the repository method installation works for this, I don’t feel comfortable in speculating for an answer. Sorry.

The module cannot be removed when it is loaded, which would be the case if you did run sh ./ under X.

I didn’t know that Catalyst has been released. Are there other issues with 10.10 we would need to know about?

They are 2 ways to install from the ATI .run package:

  • create a rpm package first and install this rpm (the best method IMHO)


  • install the driver directly.

In the first case, you would deinstall the driver as oldcpu explained, as it is a package like any oher. (notice that the file /usr/share/ati/ doesn’t exist in this case).
In the second case, you should run /usr/share/ati/ to deinstall the driver - provided it is not loaded.

Has anyone compiled ATI fglrx drivers for Cataylist 10.10 on kernel 2.6.36?

I have tried but so far no joy.


I would like to offer an English translated version of the site. As it was much easier for me to follow. Google Translate

I would like to offer an English translated version of the site. As it was much easier for me to follow. Google Translate

I’d like to thank everybody here.
Thanks to your help I managed to get the driver working so… I’m happy again :wink: