Problem installing Texmaker 5.0.1

Hello, everyone.

I have quite a bit of a problem, whenever I try to install texmaker, it asks me to have qt 5.7 or greater on the system. I installed the qt 5.9.1 from the web installer given at qt page, and re-tried the installation process. Nothing happened, same error. After that I tried adding the directory where it got installed to the PATH environment, but then again, nothing happened.
I’ve been searching for answers on how to get it to work, but I cant find anything. This was my last resource, since I think it’s something easy, but I haven’t figured out yet how to get it to work.

In case anyone is wondering why I want the latest version of texmaker, it’s due to the fact that I’m constantly writing, and the Live-preview would be helpful.

Hi and welcome to the Forum :slight_smile:
So openSUSE Leap 42.3 comes with version 4.5, I’m guessing you want version 5.0.1?

As can be seen it’s just been updated in the development repository (Publishing), but even here it’s failing with the same issue…

Where did you get the qt version from? The openSUSE Build Service?

Thanks for replying.
I got the qt version from And I followed the steps in there, also. But it didn’t work at all. I’ve been trying for quite a while, but everything I do, doesn’t seem to help.

I had the same problem once (but with another software). I suggest you take an look here:

you really shouldn’t use Qt from as you might break something, you can get the latest qt from the kde:qt5 reposetory
but that might require you to update plasma 5 too the latest 5.10.x version

You’re going to have to be more precise about, preferably providing links.

  • Where you’re downloading from
  • What guide you’re following. does not contain any links to apps built on qt. It only has links and documentation about the qt framework.

If you go to the texmaker website, the following is the download page for Fedora RPM package which should likely work on openSUSE as well.

I can’t imagine what guide you’re following to install, but YaST or zypper should step you through installing this package letting you know what dependencies might be missing, and then you can use various methods to add repos which can provide packages for those dependencies.

Or, if you don’t mind using v4.5, it’s immediately available which should install without extra work.
You can also submit a “feature request” to asking the maintainer for Texmaker to update packages to the latest version from the Project.


Already spoke to one of the Maintainers on IRC, it has been updated to 5.0.1, but only builds for QT 5.7 (Tumbleweed/Factory) and later now;

Or gets into a KDE build repo…