Problem installing SUSE 11.3 on Dell e6410

Hi to everybody,

it’s my first post on this forum and I hope that you can help me solving my problem.
I have my brand new Dell latitude e6410 delivered with Windows 7 already installed.
I want a dual boot and I decided to try SUSE for the first time.
I used the installation DVD, the installation seemed to end up well.
The problem is that already at the first reboot, the screen went completely black.
By pressing ctrl-alt-del I can reboot the laptop.
It seems to me a problem with the graphic card.

My setup is:
Dell Latitude e6410
Intel i5 m560 @2.67 GHz
nVidia NVS 3100M
4Gb DDR ram
Intel 82577LM Gigabit Network connector

If I start in failsafe mode, the X server starts, I have KDE, although
with a somewhat sketchy graphic, I can use SUSE almost normally. The main
problem in this case being that the system doesn’t find any ethernet/wi-fi device,
so I cannot connect to the Internet (I’m writing from Win7 right now).

I tried choosing the default SUSE boot with the additional boot option “nomodeset”
at the grub prompt.
This is a suggestion mentioned in another post on this forum, although in that
case the problem was coming from a bug dealing with an Intel graphic card.
The system goes up but then kde doesn’t start. I’m asked to lgin at a prompt.
If I try to launch kde from command line (startkde), it complains that
the variable $DISPLAY is not setup.

This is where I am now. I’m quite out of ideas, so I want to ask you few things.

First stupid question: is the problem coming likely from the drivers of the nvidia
graphic card ?

Second question: in that case, how can I fix it, considering that the linux partition
is “isolated” ?

The fact that in failsafe SUSE doesn’t see any network adapter concerns me a bit.
Do you agree ?

I thank you in advance for your help. In case you need more informations,
please ask.


First welcome to our forum! Second these questions are not stupid. Third I had problems with drivers in my pc( I have ati radeon graphics card Ati 5850 & ati 6970) I want for you to unistall your graphics drivers.

Hello, and welcome to the forums!

You are not the first to experience this problem. I have a Gateway NV79, with Intel i5 m430, etc., and have been through this. Fortunately, you have an nVidia graphics in addition to the Intel GMA graphics (aka Arrandale/“Ironlake”). With the nVidia, you have two options: 1) Install the nVidia drivers, or 2) forge ahead with getting the Intel GMA to work for you (and then, install the nVidia drivers). I have not installed nVidia, and will defer to others who can help you.

In failsafe mode, I can detect both wi-fi and ethernet, so I suspect this may be related to the nVidia graphics.

Again, I suspect the nVidia graphics.

There are (almost) no “stupid questions”. First: do NOT uninstall anything until you have a plan. Many here will help you, but have a plan first! Second: explore the nVidia drivers issue. Third: if you wish to go the Intel GMA route, read the following:

The “Black Screen” on Boot … a Surprise !

This problem can be addressed and I and others will help you.Go slowly, and have a plan.

Hi everybody,

thanks for the support, I really appreciate it!
My opinion is that the first thing that I have to solve is the connection
when I am in failsafe. Debugging switching from linux to windows is
a nightmare, I must be able to connect from linux for speeding up the

So, I gave a look and for some reason the ethernet card is not loaded by the kernel
(but it is seen with lspci).
The output of lspci is here
The output of dmesg is here

With Yast I checked out the section about network devices,
I found the following message

82577LM Gigabit Network ConnectionBusID : 0000:00:19.0

Unable to configure the network card because the kernel device (eth0, wlan0)
is not present. This is mostly caused by missing firmware (for wlan
devices). See dmesg output for details.

I post at the bottom of the message the outputs of lspci and dmesg.

I tried to do as root

modprobe e1000e

but it didn’t help.

Do you have suggestions ? I don’t think this can be connected with the nvidia drivers.

Thanks in advance !


digging deeper in my dmesg (see previous post) I found this line that is the root of the issue
with my eth0 device

e1000e: probe of 0000:19:00.0 failed with error -2

So, I googled it and I found a lot of references,
it seems like a bug in the module used for kernel >= 2.6.34

See for example:
e1000e probe failure on 2.6.34 and higher, Intel MB | KernelTrap Intel Wired Ethernet: Detail: 3035627 - e1000e probe failure on 2.6.34

In the last link there is a proposal for work around (replace the module e1000e in 2.6.34 with the version used in 2.6.33 or a patched one)

I will give it a shot as soon as the work leaves me some free time.
I will let you know how it goes.


You have found part of the same ideas that I found. Apparently, the 82577LM works with earlier (2.6.31/2.6.32) kernels, and became wonky ca. 2.6.33. The openSUSE 11.3 DVD installation setup kernel 2.6.34-12, which I have found to desperately need the updates to for most tasks. Unfortunately, without an ethernet connection, your only immediate alternative would be wireless. I did not see an entry for wireless in you original post.

This is unusual, as most install problems have a wired connection and problems with wireless. If you do have a wireless connection, connect up, and run the updates. After that, the next step would be to upgrade your kernel.

If you do not have a working wireless connection, then I would suggest that you consider the (almost released) openSUSE 11.4, which has the more up-to-date kernel. This recommendation (suggesting an unreleased solution) may prompt contrary comments for some, but I think it is a viable alternative.

As to your earlier posting, I doubt that this problem (the 82577LM) is related to the nVidia driver.

Deleted - discovered ‘nomodeset’ was attempted.

Hi everybody,

I fixed both problems !
Firstly, I looked for a free wi-fi spot.
At home I have only an ethernet connection, that’s why I had troubles.
But the wireless worked properly out-of-the-box.
So, after connecting, I updated the kernel with Yast.
The ethernet card started to work immediately.

With an Internet connection properly working, it was very easy to fix the other
problem with the graphic card.
I followed the instructions on
Nvidia Installer HOWTO for openSUSE users

namely, I added the nvidia repositories to Yast and updated the nvidia drivers.
At the restart, my Suse worked nicely in graphic mode.

I’m happy to start playing with it right now :wink:


Great news! This is the first time in my recollection of wireless working and wired failing!

With the Nvidia drivers working, you (most likely) do not experience the dreaded “black screen” associated with the Intel GMA. You may wish to test the Intel GMA, as at least one other poster expressed interest due to reduced power consumption (on battery).